cancel
8440pFTW Honor Student
Honor Student
3 1 0 0
Message 1 of 1
26
Flag Post
HP Recommended

8440w with 820QM "stuck" at 1.2ghz

Elitebook 8440w
Microsoft Windows 10 (64-bit)

I posted this on the techsupport subreddit and got no response so I'm trying here hoping for better results

 

I got a 8440w free from work because it had a dying mobo. I swapped that out with one from ebay for $30 and also found a 820QM for $26. Seemed like a pretty decent upgrade over the i7 640m it came with and I could replace the 520m in my 8440p with that. Lovely. Everything "works." But in any software I run to view CPU clock, it never goes over 1.73ghz and turbo is supposed to be 3.06. I don't believe thermals to be the problem even though it is a big chip for such a small cooler. I spent a lot of time overhauling the cooling and with the backside slightly elevated to allow the intakes to breath, it idles in the high 30s to low 40s. It has a 500GB WD Blue boot drive, 8GB of PC3-12800 and is running W10 pro 1809 with the bios updated to F60. I've searched and searched HP's support page, Intel's crappy website, forums, the machine's BIOS didn't seem to contains anything to magically enable, everything I can think of but no luck. It is an officially supported chip, it's listed in the 8440p/w manual as the highest spec CPU it'll take so it seems like it should just work. The 640m that is now in my 8440p turbos just fine and is also on SSD/W10pro/8GB/F60.. Any help is greatly appreciated.

 

And my most recent update to the situation is that it is now "locked" at 1.2ghz... No matter what I open or how many things are running at the same time, it never changes from 1.2ghz..

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation