Tanner_91 Tutor
Tutor
14 6 0 0
Message 1 of 1
329
Flag Post
HP Recommended

HP Thin Client T610 and HP Elite Display S140U

Elite Display S140u
Microsoft Windows 7 (32-bit)

Hello, I am in trouble with Windows 7 x86 embedded operating system.

I am with HP thin client  t610. 

The  installed OS in  the thin client HP  t610 is Windows 7 x86 embedded.
I connect to thin client two monitors.
The first monitor is connected with DVI cable and  it's work fine without troubles.
The second display is HP Elite Display S140U and here is the problem.
All drivers are installed.

I do these things to setup second displey for the first time:
I start the thin client.
I Install the drivers for second display HP Elite s140u.
The Windows 7 embadded OS recognize the HP Elite Display s140u and  it's work fine, but after restart of  the thin client, HP Elite Display s140u doesn't work never again, the indicator of s140u is white it's not orange but the screen is black.

To solve this problem I should disconnect s140u device from thin client,  I should restart the thin client, after reboot the thin client I should connect the s140u device, and everything is work again to next restart of thin client with Windows 7 embadded OS.

The second way to solve this problem is to go Control Panel, Administrative Tools, and there is one service of name DispayLinkManager, this service is with setting to automatically start by default  but when I reboot the thin client this service  is not start to work automatically, I should to start it manually and then HP Elite s140u start to work without problems.
But after every reboot of the system the user need to go services to start the DispayLinkManager service manually.

I tried HP elite display s140u with Windows 8 x86 embadded OS installed in different model of HP thin client and I don't have any problems.

 

 

 

 

 

 

 

 

I tried HP elite display s140u with Windows 7 x64 enterprise in Lenovo Desktop machine and I don't have any problems.

But with WIndows 7 embadded OS, HP Elite s140u doesn't work fine.

I tired with power shell command to start DisplayLinkManager service and it's work fine.
I tried with cmd command to start DispayLinkManager service and work fine.
I tired to write script to start DispayLinkManager service with dos command in bat file and  it's work fine.
I tired to copy the bat file with dos command to start DispayLinkManager service in the startup but it's not work.
I tired with task sheduler to shedule service but again it doesn't work.


I think the problem is in  the Windows 7 embadded operating system.

I can't connect with HP technical support to discuss the problem.


I will be happy to see your posts about the problem.

Thanks and regards .

Tanner Zaitt.

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation