cancel
Showing results for 
Search instead for 
Did you mean: 
Tomiliy
New member
1 0 0 0
Message 1 of 1
56
Flag Post

HP Omen 15-en0 and i-Tec USB3 HDMI Dual Dock - LAN Performance Problem

HP Recommended
OMEN 15-en0
Microsoft Windows 10 (64-bit)

Hello,

I have 2 HP Omen 15-en0 laptops with 2 respective docking stations from i-Tec HDMI Dual HDMI (https://i-tec.pro/de/produkt/u3dualhdmidock-3/)

All drivers are up to date, Windows is Windows 10 20H2.

The following problem.:
Both laptops have the dock connected with USB-C. A LAN cable with 1000Mbit/s is connected to both docks. My Internet connection also manages 1000 Mbit/s.
On both devices I have the problem that the data transfer via the dock only comes to about 8% - 20% performance. So I don't transfer data with Gigabit but with about 80Mbit to 150 Mbit.
This does not change when I connect the docks to USB3 instead of USB-C.
If I now use the same LAN cable and connect it to the LAN port of the laptop, I immediately have a Gigabit connection.

I have already contacted the manufacturer i-Tec, but they do not find any fault.
So I connected one of the docks to a Dell Latitude 8811 instead of the HP Omen. And there I also had an immediate Gigabit connection via the dock.
I assume that the HP Omen either have a defective USB3 driver or the USB bus has a problem and would like support for this.

Please Help.
Thanks

Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation