cancel
Showing results for 
Search instead for 
Did you mean: 
PutDtCookieDown
Level 1
8 6 0 3
Message 1 of 4
186
Flag Post

Internet is so slow (not getting full internet speed), neither while I'm using lan nor wifi.

HP Recommended
HP Pavilion - 15-au109ne
Microsoft Windows 10 (64-bit)

Can't seem to be able to get my full internet speed on my laptop. When I run an internet speed test, I get half the speed I should be getting. Any other device connected to the same network gets the full speed. I tried both, lan connection and wifi connection, and neither of the two seem to be working. I'm getting less than 1/4 of my actual internet speed while on wifi and nearly half of it while on lan. I tried downloading the adaptors' drivers, reinstalling them, removing them and restarting the laptop, using the command prompt commands, and none of these solved the issue.

The connection is very jittery and I keep having packet loss. I tried many suggested solutions and read many articles, but none of them have led to solving my problem. Many people seem to have had the same problem I'm currently facing, but none of the threads out there seem to have found a solution.hp.png

3 REPLIES 3
banhien
Level 19
Level 19
90,889 90,766 11,690 25,032
Message 2 of 4
Flag Post
HP Recommended

@PutDtCookieDown 

 

Its specs

        https://support.hp.com/au-en/document/c05335966

 

It ONLY has

Wireless connectivity
802.11b/g/n (1x1) and Bluetooth® 4.0 combo (Miracast compatible)
Network interface
Integrated 10/100 BASE-T Ethernet LAN

 

Both are slow in comparison with today standard.

 

Regards.

       

BH
***
**Click the KUDOS thumb up on the left to say 'Thanks'**
Make it easier for other people to find solutions by marking a Reply 'Accept as Solution' if it solves your problem.



PutDtCookieDown
Author
Level 1
8 6 0 3
Message 3 of 4
Flag Post
HP Recommended

Thank you for taking the time to reply to me. I thought of that at the beginning, when the problem first arosed, but I'm barely getting 20mb/s while on wifi and 80mb/s while on lan connection. Isn't my internet speed supposed to be higher than that? Even though the network devices I have are old. Not to mention the stuttering, jittering and disconnections.

Reply
0 Kudos
PutDtCookieDown
Author
Level 1
8 6 0 3
Message 4 of 4
Flag Post
HP Recommended

On a different note, I read on other online threads posted by users who faced the same issue that it could be that my adaptors aren't compatible with windows 10, and that's what is causing the problem. I have no to little knowledge when it comes to laptops network adaptors.

Reply
0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation