cancel
Showing results for 
Search instead for 
Did you mean: 
PutDtCookieDown
Level 1
8 6 0 3
Message 1 of 1
86
Flag Post

Very slow internet speed, could windows 10 be causing it? Or is my adaptor corrupted?

HP Recommended
HP Pavilion - 15-au109ne
Microsoft Windows 10 (64-bit)

Can't seem to be able to get my full internet speed on my laptop. When I run an internet speed test, I get half the speed I should be getting. Any other device connected to the same network gets the full speed.

 

I tried both, lan connection and wifi connection, and neither of the two seem to be working. I'm getting 20-30mbp while on wifi and nearly 80mbps while on lan. I tried downloading the adaptors' drivers, reinstalling them, removing them and restarting the laptop, using the command prompt commands, and none of these solved the issue.

The connection is very jittery and I keep having packet loss. I tried many suggested solutions and read many articles, but none of them have led to solving my problem. Many people seem to have had the same problem I'm currently facing, but none of the threads out there seem to have found a solution.

 

On a different note, I read on other online threads posted by users who faced the same issue that it could be that my adaptors aren't compatible with windows 10, and that's what is causing the problem. I have no to little knowledge when it comes to laptops network adaptors.

Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation