wbmccart Student
Student
1 0 0
Message 1 of 4
Flag Post

Can't install Photosmart A636 on Mac OS Sierra 10.12.6

Photosmart A636
macOS 10.12 Sierra

When I connect the printer to my USB port it causes a folder to appear with the A630 Series installer. I run that but the installation fails with a message that the OS must be higher than 10.4. But it's 10.12. What do I need to do to connect this printer to work with my Mac. I really need it to print some photos, which is why I bought it in the first place. Thanks!

3 REPLIES
Provost Provost
Provost
70553 8479 18231
Message 2 of 4
Flag Post

Can't install Photosmart A636 on Mac OS Sierra 10.12.6

@wbmccart

 

It is a very old printer. I don't know why it is still around, on a shop for you to buy !!!. If youi bought from someone else or from a shop, please return and get your money back or try

 

     https://support.hp.com/us-en/drivers/selfservice/hp-photosmart-a630-printer-series/3256926/model/368...

 

I don't think this would help you.

 

Regards.

BH
***
**Click the KUDOS thumb up on the left to say 'Thanks'**
Make it easier for other people to find solutions by marking a Reply 'Accept as Solution' if it solves your problem.
Reply
0 Kudos
Provost Provost
Provost
22385 4022 8414
Message 3 of 4
Flag Post

Can't install Photosmart A636 on Mac OS Sierra 10.12.6

Hi,

Appologies for jumping in.

 

Your printer drivers are provided via Apple Software Update as listed below for the Photosmart A630 Compact Photo series:

https://support.hp.com/lt-en/document/c04473034

 

Please follow below steps to install your printer, generally you would need to connect it to your Mac and the drivers will be loaded from Apple, you should not install any software prior:

https://support.hp.com/lt-en/document/c04510394

 

For any issues you may manually install the drivers from Apple as described in the document.

 

Shlomi

Say thanks by clicking the Kudos thumb up in the post.
If my post resolve your problem please mark it as an Accepted Solution :)
Reply
0 Kudos
billmccart Student
Student
1 0 0
Message 4 of 4
Flag Post

Can't install Photosmart A636 on Mac OS Sierra 10.12.6

Thanks, but this doesn't work. I first reset the printing system to remove all printers. I then attached the A636 via USB. This automatically brought up the A630 series installer. I ran the installer but when I got to the step of selecting the installation disc, it failed with the message "Mac OS X 10.4 or later is required." My OS version is 10.13.4, which is obviously higher than 10.4. I then downloaded and ran HP Easy Start, but it does not recognize the printer.

 

I tried to follow the instructions in his article...

https://support.hp.com/lt-en/document/c04510394

 

but when I get to the step to add a printer the only option that's available is the A630 series scanner. There is no driver for the A636 Photosmart printer.

 

Any ideas?

Reply
0 Kudos
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation