Highlighted
bhall-nerd Honor Student
Honor Student
4 0 0
Message 1 of 1
40
Flag Post
HP Recommended

Issue with OfficJet 8500 (909a) installation/Printing

HP OfficeJet 8500
Microsoft Windows 7 (64-bit)

This printer is connected to a LAN using a CAT-5. There is no wireless or Blutooth with this printer. It is connected directly to a switch and I've pluged this computer into the same switch so there is no router between them. I have restarted the computer, switch, and printer. There are no errors on any of them.

 

I installed this printer and software using the Version 14.0 x64 Full version. This was the last one that was created for this OS and Printer. It was working fine, well most of the time, until one day when it was no longer found according to the Document Manager as well as Windows Devices. I went through the steps to try and get it to be recognized but they all failed so I uninstalled the entire OfficeJet Pro 8500 software from Add/Remove Programs.

 

I went to install it again and instead of trying to install the entire package, it only wanted to install a new device/printer. So this made me think something did not work in the uninstallation. The scan folder was still available under the C:\Program Files (x86)\HP\ but no driver folders or anything else. I aborted the installation as I knew something was not correct. I started to look around and came accross some Interesting findings, this was after the uninstallation and restart of the computer:

* I now had two printer driver enteries listed amongst my services that had not previously been there. Net hpz12 driver and PML hpz12 driver. I was able to remove these by using the sc delete" command. I looked and since there was no printer installed these should have been uninstalled as well.

* The OfficeJet 8500 now appeared in the "Device Manager" with an error that there was no driver installed - of course there wasn't as I had uninstalled it but apparently it was not removed from enteries within the system/registry.

 

I ran the "scrubber" abt 3 times and finally the printer no longer appeared in "Device Manager"

 

I attempted to install the printer again using the Version 14.0 x64 Full version, even freshly downloaded. Even though I have domain admin rights, I've still run this with right click "Run as Administrator" everytime i ran it.

 

It failed, as explained in next paragraph, so based on the fact that the scan folder was left behind I modified the registry, after making a backup of it, and removed all occurances of "\HP\" which contained references to the Scan folder. I also dleted C:\Program Files (x86)\HP directory. I also removed all HP folders located within C:\ProgramData as this is not an HP computer and the only HP item was the Printer so it wouldn't be necessary.

 

The setup starts and I get past accepting the license. I see a blank CMD Window open and close (assume this is the printer spool being stopped or something like that). I then recieve a fatal error and it says it is gathering information but the only thing I see is a guide for "HP Inastallation Error for Windows 7".  Once the info is gathered it proceeds to uninstall the setup.

 

I went through this entire troubleshooting guide and it basically had me do what I had already done. Each time the error still occured. I am not able to get past this error. 

 

Any thoughts?

 

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation