Highlighted
salimkhalaf Honor Student
Honor Student
2 0 0
Message 1 of 4
Flag Post

MAC OS X 10.13.5 High Sierra Driver for HP Officejet Pro 6978 All-In-One

TOF29A
macOS 10.13 High Sierra

HP website does not have Mac OS X 10.15.3 High Sierra driver or installer for HP Officejet Pro 6978 All-In-One.

 

I wrote to tech support but there was no response for the second day now.  I do not know what to do.  Should I return the printer to HP since, obviously, they don't care about Mac customers?

 

It is so shameful that no one bothered to respond from their tech support nor have I found a telephone number to talk with a real person about this subject.

 

 

3 REPLIES
Provost Provost
Provost
10890 1093 2339
Message 2 of 4
Flag Post

MAC OS X 10.13.5 High Sierra Driver for HP Officejet Pro 6978 All-In-One

Hi,

Thanks for using the HP Forums.

 

Please use this link to download the HP Easy Start:

 

https://support.hp.com/us-en/drivers/selfservice/hp-officejet-pro-6970-all-in-one-printer-series/828...

 

An example on how to download and install is shown here:

 

macOS 10.12 Sierra  Download and install software

 

 

Hope that helps!

I am an HP Employee
Although I am speaking for myself and not for HP.
Please click “Kudos Thumbs up” as an encouragement and “Accept as solution” if this has helped solved your problem.
Reply
0 Kudos
NeedForumHelp Honor Student
Honor Student
2 0 0
Message 3 of 4
Flag Post

MAC OS X 10.13.5 High Sierra Driver for HP Officejet Pro 6978 All-In-One

I have the same issue.  The MAC OS X 10.13 driver is not there for this model printer.  The last supported OS version is 10.12.  I just bought this printer in March of last year.  It has only been out of warranty for 5 months and already HP has dropped support for the MAC???

 

Please help.

Reply
0 Kudos
NeedForumHelp Honor Student
Honor Student
2 0 0
Message 4 of 4
Flag Post

MAC OS X 10.13.5 High Sierra Driver for HP Officejet Pro 6978 All-In-One

I went back to the hp.com web page and followed the links through Support/Software/Printers and entered my model and was able to get to the correct page.  I cannot remember the link/path I used originally so I don't know how I got to the page where it said 10.13 was not supported, but I know that the top-down approach I just mentioned does work.

 

Solved my own problem.

Reply
0 Kudos
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation