cancel
Showing results for 
Search instead for 
Did you mean: 
Common problems for Connectivity Issues
We would like to share some of the most frequently asked questions about Printer Wi-Fi, Connectivity Issues and Offline Status. Check out this link: Printer Wi-Fi, Connectivity Issues and Offline Status..
KCPete
New member
1 0 0 0
Message 1 of 1
39
Flag Post

Connected to WiFi. TCP/IP working. But still getting internet connection error.

HP Recommended
Deskjet 3512 e All In One
Microsoft Windows 10 (64-bit)

Okay, I get that my printer is really old and it is slated to be replaced but just not quite yet.  It has served me well and I'm just not ready to replace it. 

 

The problems first showed up when I try to scan via the desktop software installed from HP's latest greatest version of software for this printer.  When I do that, I get an error that I cannot connect to the scanner.  The only access I have to the scanner is via the embedded web server (ews). When trying to setup (re-Setup) ePrint Web Services just in case that will allow me to actually scan multiple pages to a single file, I get a message saying  that "The printer could not connect to the internet. Check the internet connection."

 

To be clear, I do not know if the scanning issue and the internet connection issue are related.

 

Also, to be clear, we print to this printer almost every day and our only connection to the printer is thru WiFi.  Also, as you may have gathered from the above, the printer's ews is working -- it actually lets me see all these same messages online and using the ews, As much of a pain in the backside as it is, ews does still allow me to scan one page at a time and each page to a separate file. Since TCP/IP is needed for ews, obviously TCP/IP is working.

 

Finally, the printer has the ability to check for updates via the internet and reports back (correctly) that it is up-to-date.

 

I'm thinking that maybe I need to open a port on my router to allow the printer to communicate correctly with the Web Services servers, but, so far, I have not found that information. I did find a hint that the port information has been posted here in the past, but I didn't find the actual post and Google didn't help me with this info either.

 

Any help in resolving either or both problems will be appreciated.

 

Thanks in advance.

Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation