cancel
Showing results for 
Search instead for 
Did you mean: 
anil-50
New member
2 1 0 2
Message 1 of 5
719
Flag Post
HP Recommended

Samsung ML 1670 internal error after upgrade to Fedora 30

Samsung ML 1670 laser printer
Linux

After the upgrade of Fedora to version 30, I am getting the following error with any document which has an image, even if I convert it to grayscale: 

INTERNAL ERROR - uw_color == 4

POSITION : 0x0 (0)

SYSTEM : h6fw_5.49/x1_image

LINE : 341

VERSION : SPL 5.49 10-20-2010

Thanks

 

4 REPLIES 4
Printer_S
Level 4
110 105 10 8
Message 2 of 5
658
Flag Post
HP Recommended

Samsung ML 1670 internal error after upgrade to Fedora 30

Hi anil-50

Does the same issue occur with another OS?

I ask you this because Samsung does not develop the software for LINUX. In case that you just have this OS my recommendation is trying contact a 3rd party LINUX software developer to check what altternative he could offer you.

 

Regards.

Knowledge is to be shared.
0 Kudos
PiotrekZurek
New member
1 1 0 0
Message 3 of 5
576
Flag Post
HP Recommended

Samsung ML 1670 internal error after upgrade to Fedora 30

Hi, I have the exact same problem with my printer (ML-1675 , the same family and driver). It used to work in both Ubuntu and Fedora prior to version 19.04 and 30 respectively. The driver downloadable from HP support site for linux for this printer is: "uld_V1.00.39_01.17.tar.gz". This driver works fine for sure in:
Ubuntu 18.04, Ubuntu 18.10, Fedora 29.
But in both Ubuntu 19.04 and Fedora 30 it doesn't anymore. The printer gets detected and drivers automatically installed but the output on paper is always as below (1 page prints with this text):

 

INTERNAL ERROR - uw_color == 4

POSITION : 0x0 (0)

SYSTEM : h6fw_5.49/x1_image

LINE : 341

VERSION: SPL 5.49 10-20-2010

 

The printer itself is OK for sure as I am able to print from a VM with Ubuntu 18.04 and redirected USB port for this connected printer. The driver used is exactly the same.

0 Kudos
Highlighted
anil-50
New member
2 1 0 2
Message 4 of 5
564
Flag Post
HP Recommended

Samsung ML 1670 internal error after upgrade to Fedora 30

I got the solution from:

https://www.bchemnet.com/suldr/forum/index.php?topic=363

I used the source from Fedora 29 - cups version 2.2.8-10 and could build it on Fedora 30 without any issues and the printer works.

 

 

 

spljaa
Level 1
5 4 1 1
Message 5 of 5
559
Flag Post
HP Recommended

Samsung ML 1670 internal error after upgrade to Fedora 30

MAny thanks Anil-50,

It indeed works - so kind of ugly workaraound - build rpm from source, downgrade and use dnf versionlock.

Open question is when ULD will work with current cups.

0 Kudos
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation