cancel
Showing results for 
Search instead for 
Did you mean: 
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
Radioman14
New member
2 1 0 0
Message 1 of 4
1,005
Flag Post

Windows 10 upgraded, now my computer says "cannot find Magic-i Virtual Driver"

HP Recommended
HP-A6552 Q6600
Microsoft Windows 10 (64-bit)

After a really smooth upgrade from Windows 7 Pro to Windows 10 (presumably Pro), when I first boot up, I get a popup message that states "cannot find Magic-i Virtual Driver" and a button option for [OK].  I have a HP Elite Autofocus Webcam that comes with ArcSoft Magic-i...and before the upgrade, I downloaded the Magic-i-3 version of the software and it seemed to work quite well as my video chat device with SKYPE and Facebook video messaging.  Now it's not working!  Any idea how to fix this problem?

0 Kudos
3 REPLIES 3
Malygris1
Retired
Retired
7,771 6,895 454 848
Message 2 of 4
Flag Post
HP Recommended

Hi @Radioman14,

Welcome to the HP Support Forums! I understand that after upgrading to Windows 10, your webcam is no longer working properly. I am happy to help with this.

 

After checking the support pages for your computer model, I found that the only specific drivers for your system are for Windows Vista. With that in mind, Windows 10 may be using mostly the built-in drivers.  Have you tried to reinstall the Arcsoft Magic software again? What operating system was the version you downloaded designed to work with?

 

From what you  wrote it sounds as if it was working in Windows 10 at first. Was there something else added later that may have interfered with the software?  It may be a good idea to try using one of the System Restore options in this document: HP PCs - Using Microsoft System Restore (Windows 10, 😎

 

Please let me know how that works for you, and if it does resolve your issue, please mark this post as a solution. Kudos would also be appreciated.

Malygris1
I work on behalf of HP
Please click Accept as Solution if you feel my post solved your issue, it will help others find the solution.
Click Kudos Thumbs Up on the right to say “Thanks” for helping!
0 Kudos
Radioman14
Author
New member
2 1 0 0
Message 3 of 4
Flag Post
HP Recommended

Hi!  ...

 

I have been using Windows 7 Pro for several years and my HP web cam worked quite well all that time.  I have Magic i 3 but apparently Windows 10 doesn't recognize that program.  In going to ArcSoft web site, they "aren't supporting" the Magic i program going forward so, I'm wondering why Windows 10 continues to look for that early version of the program.  Is there any solution to getting it to NOT look for Magic i but for Magic i 3?

Richard

0 Kudos
Malygris1
Retired
Retired
7,771 6,895 454 848
Message 4 of 4
Flag Post
HP Recommended

Thank you for the additional information. It may be a remnant from doing an upgrade installation.

 

Try uninstalling the software entirely then also remove your webcam from within device manager. Restart your computer, and then if the webcam is not found go back into Device Manager and try scanning for hardware changes.

 

Let me know if that helps at all.

Malygris1
I work on behalf of HP
Please click Accept as Solution if you feel my post solved your issue, it will help others find the solution.
Click Kudos Thumbs Up on the right to say “Thanks” for helping!
0 Kudos
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation