cancel
Showing results for 
Search instead for 
Did you mean: 
Murty72
Level 1
11 8 0 1
848
Flag Post
HP Recommended

MacOS High Sierra 10.13.6 Will Not Print to or Add New Printer HP Officejet Pro 8600 Plus

Officejet Pro 8600 Plus
macOS 10.13 High Sierra

My MacBook Air (A1466) stopped printing when it was updated to MacOS High Sierra  10.13.6 a few months back. When I would try to print, the document would show up in the printer queue, sit at 41% complete for anywhere from 5-10 minutes, then disappear. The printer, an HP Officejet Pro 8600 Plus, never even lit up.

 

I perused both the Apple and HP forums for several weeks. I checked the following:

1) The printer is on the latest firmware

2) The driver software is the most current version on the MacBook (re-installed HP Easy Start)

 

I reset the print system within High Sierra, which was mentioned in both Apple and HP support forums. This removed all my printers. Now when I try to put them back, this is what happens:

 

1) The printer, which is on my home network, shows up as the only nearby printer

2) Start the Add process

3) It ends with the error message "Cannot communicate with the printer at this time"

 

This happens independent of the access mode:  whether I select the webserver on the printer, the HP drivers, or the AirPrint options. I took my MacBook to my friend's house and tried to connect his printer. Same exact results.

 

I also tried using the HP Easy Start software to install the printer, the only difference is that running the process is automated via the software, but the same setting windows all pop open, and the same error message is the result.

 

I can print to this printer using AirPrint from my iPhone 7 and iPhone X.

 

And lastly, I noticed while entering this ticket, that my update history in the App Store is empty. I update this device whenever a new version of OS X or any software on the MacBook needs it. I do not wait, so the update to 10.13.6 was from whatever was the version immediately before it. I did not upgrade across multiple versions.

 

I know it seems that this seems like a laptop issue and not the printer, but I am getting no help from the Apple support forum and I was hoping someone from HP had come across this same issue...

Who Me Too'd this topic
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation