• ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
Guidelines
We have new content about Hotkey issue, Click here to check it out!
Check out our WINDOWS 11 Support Center info about: OPTIMIZATION, KNOWN ISSUES, FAQs, VIDEOS AND MORE.
HP Recommended
OMEN 17-CB1000 series
Microsoft Windows 10 (64-bit)

@developpers

 

Hello,

 

I use the last Omen Gaming hub version (11.0.14.0) and this version is buggy!

Info:

Unit: HP Omen 17-CB1041NF

System: Windows 10 x64 20H2

BIOS: F.20 Revision A

RAM: 2x16 Gb HyperX 2933MHz

 

Well, today I started the Omen Gaming Hub to change color of my keyboard and was surprised to see a new tab, the God tab for laptop users: Undervolting.

I started a Smart mode to analyse my PC. All worked fine and the app displayed its best result with 0.070v less. Ok. I closed the app and started a game to see how this new feature worked. All was fine.

So I launched Omen Gaming Hub to do some tests and... uhm... no... no way to start it, even by rebooting or killing the task. Nothing works! This is a fact: this app works only ONE TIME!

 

At first launch, I mean just after installing it, it works. Then, no way. if I restart it, I have this screen:

 

M1Dckdzxfd.png

 

 

Then if I kill this task, and restart the soft, I get that (an Omen Gaming Hub... empty):

 

HP.Omen.OmenCommandCenter_eDYFOcC0VB.png

 

 

What I tried:

1. searched for an update and found one on Microsoft Store. Installed it. => same thing

2. uninstalled completely the app, cleaning registry with Ccleaner, restarted the unit and reinstalled the last app from Microsoft Store. => same thing

3. restored my PC from a previous backup and tried again what I did previously on "1." and "2." => same thing

4. uninstalled all apps like HWInfo, MSI After Burner, ThrottleStop and/or Intel Xtrem Utility. => same thing

5. searched for other comments about this bug and how to fix it. Uhm... there is many people who have this problem and nobody seems to fix it.

 

So, :

1. is there a fix?

2. without a fix, this issue could be annoying cause if user undervolts too much its unit, which make the PC to crash, he couldnt change it anymore cause he couldnt access the software anymore.

3. something else: when we uninstall the app, undervolt stays in registry and/or elsewhere. Cause when we reinstall it, to make it work at least one time, OGH, even if it forgot what colors I chose for my keayboard, it remember well what undervoltage I did. So it could be fine if developpers add something to put system in default mode when this app is uninstalled.

Waiting for a (fix) reply

Best regards

 

EDIT: the 2 screenshot dont seem to be uploaded. Tried twice without result. Well, the first one is the Display Screen at start of the app (named Form1 :D) and the second one is the Omen Gaming Hub (OGH) without anything in it... no tab, no adds, nothing...

Who Me Too'd this topic
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the <a href="https://www8.hp.com/us/en/terms-of-use.html" class="udrlinesmall">Terms of Use</a> and <a href="/t5/custom/page/page-id/hp.rulespage" class="udrlinesmall"> Rules of Participation</a>.