• ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • post a message
  • ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • post a message
Guidelines
Be the first to explore and join the conversation on our brand-new Poly Support Community Blog, Click here It's live now!!
HP Recommended

Hi,
So we migrated a resource room from exchange on prem to exchange online and then migrated it from SfB to Teams, The room is functioning as expected but we are unable to logon to the room account from a Studio x30 as it is getting blocked due to not meeting compliance,
It sound like the account needs to be a device account and not a resource account.
This link https://docs.microsoft.com/en-us/microsoftteams/rooms/rooms-configure-accounts
States Microsoft Teams Rooms needs to be assigned a "device account" in Active Directory, Exchange, and Skype for Business. The account is used to access its meeting calendar and establish Microsoft Teams or Skype for Business connectivity. People can book this account by scheduling a meeting with it. Microsoft Teams Rooms will be able to join that meeting and provide various features to the meeting attendees.
It also states If you already have a resource mailbox account set up for the meeting space where you're installing Microsoft Teams Rooms, you can change that resource account into a device account. Once that's done, all you need to do is add the device account to a Microsoft Teams Rooms device.
We are unable to see how this is achieved? Can you please advise, thank you.
Roy.

5 REPLIES 5
HP Recommended

Hi Roy,

 

The fact that your Studio X is being blocked from sign-in due to compliance leads me to believe this is related to MDM, is this deployed within your tenant?

 

Regards,

 

Adam

HP Recommended

Hi Adam,

Thanks for reaching out.

Yes we us MDM, it seems to be looking for a device but how do we add the X30 as a device?

what we are trying to do is migrate one of our original active meeting rooms in Exchange on-prem / SfB to Exchange online and Teams. We have already migrated the room Teams_Room_Test01_Poly (6) as a resource room to Exchange online and then added it to Teams. This seems to be working as expected, but when testing this with a poly Studio X30 Collaboration bar we are running into problems with it not in compliance. 

So the steps that we took were to migrate the exchange room mailbox and then to run Move-CsMeetingRoom -Identity "Teams_Room_Test01_Poly (6)" -HostedMigrationOverrideUrl "https://admingb1.online.lync.com/HostedMigration/hostedmigrationservice.svc" -Target "sipfed.online.lync.com" -Credential $credential.

We are wanting to migrate all the on-prem rooms and ensure all meeting that are already booked are carried across and then connect to them with the poly Studio X30 Collaboration bar.

 

Roy

HP Recommended

Hi Roy,

 

It's unlikely that the root cause of this issue is related to mailbox or Skype for Business migration, but instead MDM being the root cause. I would recommend you review your MDM compliance policies and see where the Studio X is failing.

 

Once this has been identified you can always put in place an exclusion for these devices as they're not Android smart phones and do not present the same risk profile.

 

You can refer to a blog post I created here:

MDM Compliance Policy Exclusion for Teams Android Devices | I'm a UC Blog

HP Recommended

Hi Adam, on the page where you are revering to, the new dynamic query does not contain the X30 and X50. Should these not been added Or still using the device.deviceModel property?

"This syntax has recently been updated, instead of referencing the device.deviceModel property we now use device.displayName. Therefore the syntax should now be:

(device.deviceOSType -eq “Android”) and (device.displayName -eq “PolyCCX400”) or (device.displayName -eq “PolyCCX500”) or (device.displayName -eq “PolyCCX600”) or (device.displayName -eq “PolycomTrio8800”) or (device.displayName -eq “PolycomTrio8500”) or (device.displayName -eq “PolyTrioC60”)"

 

HP Recommended

Please include the following syntax:

(device.deviceOSType -eq "Android") and (device.deviceModel -eq "CCX400") or (device.deviceModel -eq "CCX500") or (device.deviceModel -eq "CCX600") or (device.deviceModel -eq "Trio8800") or (device.deviceModel -eq "Trio8500") or (device.deviceModel -eq "TrioC60") or (device.deviceModel -eq "PolyStudioX30") or (device.deviceModel -eq "PolyStudioX50")

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the <a href="https://www8.hp.com/us/en/terms-of-use.html" class="udrlinesmall">Terms of Use</a> and <a href="/t5/custom/page/page-id/hp.rulespage" class="udrlinesmall"> Rules of Participation</a>.