Post new question
Question
Reply
 
Honor Student
Posts: 2
Member Since: ‎07-03-2015
Message 1 of 2 (132 Views)

T520 - W7E - not redirecting Smart Card devices

Product Name: HP T520 thin client
Operating System: Microsoft Windows 7 (32-bit)

Hello everyone,

 

May i kindly ask for some assistance please? The issue is that smart card redirection from a T520 with W7E is not working to our Windows Server 2016 RDS sessions. 

 

In short: we have a WS2016 RDS-farm for which device redirection is enabled. We present full desktop sessions to our users. We use the T520 as client device with W7E. We use the HP Easyshell to present the user the Web Gateway RDS login page. After login the full desktop session is started.

 

For some reason the Smart Card (Belgian e-ID) is not working in the RDS user session. I've tried several troubleshooting steps:

 

We use Smart Cards to login in Belgian government websites, not for login in into Windows, just to be clear. 

 

  1. After installation of the e-ID software on the T520 thin client, e-ID logins are working directly on the thin client within Internet Explorer - with the Administrator account, and also as a normal user it is also working. 
  2. After login to the RDS user session from HP EasyShell, Smart Card is not working - the odd thing is that it is working from whatever fat client device i'm using here (PC, laptop, tablet) - for the same user - so this proves device redirection is effectively working.

 

I've played around with the HP USB Port Manager, and allowed all devices that were connected, restarted. It doesn't seem to help.

 

Anyone has any idea please?

Reply
0
Honor Student
Posts: 2
Member Since: ‎07-03-2015
Message 2 of 2 (39 Views)

Re: T520 - W7E - not redirecting Smart Card devices

After opening a ticket with Microsoft, this seemed indeed a issue with Windows Server 2016 RDS (WS2012R2 is not affected). 

 

  • Uninstall the following KB’s from the Windows 7 machines:
                    KB2830477 and KB2592687

  • Install the following KB:
                    https://support.microsoft.com/en-us/help/2913751

  • Verify the following GPO and change it to Disabled
    • Windows Component \ Remote Desktop Services\Remote Desktop Session Host\Devices and Resource Redirection\”Do not Allow smart card redirection”

After executing the above, a reboot things started working as intended: e-ID cards are working in WS 2016 RDS sessions within Internet Explorer. Digitally signing Adobe Acrobat documents is also working as intended.

 

With kind regards,

 

Sven

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation