Re: After loading Win 7 (32 bit), getting blinking cursor on black screen just after BIOS loading (274 Views)
Reply
Top Student
sv5020
Posts: 9
Member Since: ‎02-27-2012
Message 1 of 5 (318 Views)

After loading Win 7 (32 bit), getting blinking cursor on black screen just after BIOS loading

[ Edited ]

Hi there,

 

Can I get assistance on the following trouble with my desktop ?

 

D530 (CMT) motherboard with SATA HDD (160 GB ) -After loading Win 7 (32 bit), getting blinking cursor on black screen only if I do warm boot. The screen just stuck there and will not progress to anywhere after that. During cold boot, the OS loads fine. Also while BIOS loading screen, there is a message flash "press any key for ROM options" whenever this SATA HDD is connected to the motherboard. There is no issue with Win7 booting if I load it on a IDE hard disc with the same motherboard. Tried upgrading BIOS from v1.11 to 2.44 and still no luck. Pls advise.

 

Regards,

SV

Provost
Paul_Tikkanen
Posts: 39,968
Member Since: ‎07-13-2010
Message 2 of 5 (309 Views)

Re: After loading Win 7 (32 bit), getting blinking cursor on black screen just after BIOS loading

[ Edited ]

Hi:

 

See if clearing the CMOS helps.

 

To do that, shut down the PC, unplug everything connected to it...power cord, keyboard, monitor, mouse --everything.

 

Open the case and near the coin cell battery there is a little yellow button.

 

Push and hold it in for 30 seconds.

 

Put everything back together and hope that works. You will need to go into the BIOS and set the date and time.

 

Did the 160 GB SATA hard drive work OK when you had XP on it?

 

I only went up to a 120 GB SATA in my d530. Wasn't sure it would take more than that.

 

Did you install a windows 7 capable AGP video card?

 

If not, your graphics is not going to work under windows 7, unless you read this post and install the driver listed in the green shaded solution post from PhilBene.

 

http://h30434.www3.hp.com/t5/Desktop-Operating-Systems/Win-7-Support-for-Intel-865G-Graphics-HP-D530...

 

Paul

Honor Student
SVSV5020
Posts: 2
Member Since: ‎03-01-2012
Message 3 of 5 (277 Views)

Re: After loading Win 7 (32 bit), getting blinking cursor on black screen just after BIOS loading

Hi Paul,

 

Clearing of CMOS didn't help. I installed Win 7 on the SATA disc and it works fine when I cold start. The issue is only when I restart (warm boot) it. So the system detects this SATA drive.

I haven't tried loading Win XP on this SATA drive and test in fact.

 

Also there is a nVidia graphics card (Quadro4  750XGL) installed on the AGP slot.

 

The Win 7 works fine with another 20 GB IDE hard disc without any cold/warm reboot issues ! So I guess there is something wrong with D530 -Win 7 -SATA Drive combination. Pls advise.

RAM size 1 GB.

 

Thanks & Regards,

Shyam

Honor Student
SVSV5020
Posts: 2
Member Since: ‎03-01-2012
Message 4 of 5 (274 Views)

Re: After loading Win 7 (32 bit), getting blinking cursor on black screen just after BIOS loading

Hi-

 

Also I tried copying those driver files to C:\Windows\system32 folder as mentioned by PhilBene and still not working.

Provost
Paul_Tikkanen
Posts: 39,968
Member Since: ‎07-13-2010
Message 5 of 5 (274 Views)

Re: After loading Win 7 (32 bit), getting blinking cursor on black screen just after BIOS loading

Hi, Shyam:

 

I don't know why that is happening to you.

 

I installed W7 on my d530 CMT that had a Samsung 120 GB SATA drive and had no issues at all with the BIOS storage controller option set to the default of "add as separate controller."

 

Best Regards,

 

Paul

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation