Question
Reply
 
Tutor
DVFixxer
Posts: 24
Member Since: ‎11-30-2009
Message 1 of 115 (66,078 Views)

DV6000/DV9000 NVidia Issue fix!

I have stumbled across a fix that may help a lot of people. Some may be aware of it and have not told anyone on a large scale so I have decided to help.

A little history:

I was handed a DV6745US to fix. The lady said that the laptop never gets past POST (which is when the HP logo shows on the screen when the power button is first pressed). I would be able to get into the BIOS but it would sometimes freeze and show weird characters on the screen or it wouldn't go anywhere past that. I google’d this many times, tried removing the CMOS battery, etc. I then saw numerous posts about this "NVIDIA issue". After a while, the lady told me that I could keep the laptop and that is when I decided to dive deeper into this ongoing and famous problem.

A little history on myself:

I have been in the computer repair and programming business for 10 years. I am 29 now and used to own a computer repair business based on helping people without overcharging them. After getting a job as a software programmer, I put the repair business on hold, only helping friend's and family. I have built and repaired a lot of computers as well as laptops and I feel that I have a good understanding of how they work. I am not an expert as I feel that there are a lot of things out there I may not know but I do think I know enough to help out!

Now, on to the goods:
I think I may have repaired the problem! After taking apart the laptop and applying my fix (a fix that I have only seen ideas on), the laptop has been working FLAWLESSLY now for about a month and I have bought a broken laptop for my wife and applied the same fix only to have it work perfectly! I am in the process of writing up a tutorial to help others out and should be able to update this post with a link to it. I AM IN NO WAY TRYING TO GET MONEY FOR THIS! I will help anyone out if they want me to try and fix theirs or if they would like the materials sent to them for a small charge. Just contact me and we will work something out to send me your laptop if you don't feel comfortable working on it yourself.

Here’s the deal: When these laptops where first built, the heatsink for the chipset does not come in contact with the chip itself. In my opinion, for proper cooling to happen, the heatsink should contact the chip directly through heatsink compound only. Upon disassembly of this laptop, I found that there is a .05 gap between the NVidia chipset and the heatsink filled with, what I can only call, a "pillow" of material. My guess is that this "pillow" was once a very thin glue (?) pad that pulled the heatsink down to the chip thus creating a close contact and it eventually heated to the point where the heatsink came unglued from the chip allowing it to overheat. What I have done is cut two small copper "shims" (some of which can be found on Ebay with the proper search terms) out of .025inch copper plate and attached them with thermal adhesive to the heatsink. I then reattached the heatsink with thermal compound to the chipset/cpu and reassembled the laptop. Like I have said, I have done this to two laptops (DV6745US and DV6704NR) and they have both been working like new!! The great thing is that these laptops are being sold on Ebay for under $200 and you could make a few bucks fixing them and reselling them. I was thinking about doing the same thing but I don't have the funds to do so.

I think the DV9000 series as well as some others are having the same issue and could benefit from the same fix although I am not sure. I can't guaranty that this will work for you but I have done this to two machines and feel that this can possibly fix this rather common problem in most cases.

Like I said above, I am working on a tutorial with pictures to help anyone out who would like to try this on their own. Again, I cannot guaranty that this will work but I think it is worth a try. A few notes: After trying this fix the first time, I tried booting the system up without a hard drive. It gave me the same trouble (rebooting directly after POST). It wasn't until I put the hard drive in that it passed over POST and booted up normally.

Also, if you would like to ask me any questions or would like me to repair your laptop for you, contact me via email or this post.

I just hope people see this post and it helps turn a brick of a laptop into something useful!

If you do decide to try this out and I have not posted the tutorial, please feel free to contact me for directions. I can even cut out the peices for you to repair it with for a small charge. They may not be the nicest things in the world but they do the trick!

Below is a picture of the "pillow" that could be the cause of the problem (look at the gray square at the right in the picture).
dv6000 heatsink
Provost
Huffer
Posts: 11,721
Member Since: ‎11-12-2008
Message 2 of 115 (66,119 Views)

Re: DV6000/DV9000 NVidia Issue fix!

That pillow is just the thermal transfer pad that rides on top of the main chipset and under the heatsink. If I get this straight you have made no changes to the motherboard itself you have just rigged an alternate way to transfer heat away from the main chipset to the heatsink. But a lot of these laptops have video chips that have delaminated and need to be reflowed. This process might work for those machines like you describe where they still get to the HP screen or otherwise almost post. I think you still have the underlying problem of the bad substrate under the nVidia chip, which this fix does nothing to address. Nevertheless I have always thought the little "art gum eraser" heat transfer pads were a poor design and this is an improvement. Thanks.
Tutor
DVFixxer
Posts: 24
Member Since: ‎11-30-2009
Message 3 of 115 (66,065 Views)

Re: DV6000/DV9000 NVidia Issue fix!

I don't want to put anyone down but I have been thinking about this "unsoldered" idea that a lot of people have about these NVidia chips. I do agree that the chips get very hot and I do believe that the overheat could be causing numerous problems but I don't think that they are getting hot enough to melt the solder enough to pull the pins away from the motherboard. If that were the case, wouldn't the motherboard be melted somewhere near the chipset? If I were to place a hot soldering iron on the motherboard for a few seconds, would it not melt it? These chips run this hot for at least a few minutes, if not hours, and yet the motherboard itself is fine?

My idea from my fix comes from pulling heatsinks off of processors while they are running. Also, an incorrectly placed heatsink will also do the trick. Chips are sensitive like that where, if there is not a consistent contact with something to deviate the heat away from the source, the chip will fail almost instantly. For example: Intel CPU's are smart to the point where they will step themselves down in speed if a heatsink fails. AMDs aren't that smart, or were not that smart a few years ago (they may have fixed that, I'm not sure). What I do know is that it has fixed my problem two times out of two and I think it is worth a shot for everyone to try. Especially for all those in which HP doesn't extend that extra warranty for such as the 6700's.I definitely don't want to make any money from this, I just want to spread the idea of something new.
Intern
jimkola
Posts: 125
Member Since: ‎09-05-2009
Message 4 of 115 (66,058 Views)

Re: DV6000/DV9000 NVidia Issue fix!

These chips run this hot for at least a few minutes, if not hours, and yet the motherboard itself is fine?

 

Different solder?

I've always suspected that HP was pretty cavalier with their hucking of AMD under the proverbial bus. Does HP supply the

GPU to the motherboard manufacturer (AMD or Intel) and they install the it, or is it added at a later date by a different company?


Tutor
DVFixxer
Posts: 24
Member Since: ‎11-30-2009
Message 5 of 115 (66,056 Views)

Re: DV6000/DV9000 NVidia Issue fix!

That's a good question. I was always under the impression that an outsourced company assembled the motherboard, i.e. someone other than HP or Intel/AMD or even NVidia/ATI. I am not sure, though.

 

And your right! They could be using one hell of a crappy solder that melts at a very low temp! I shudder at the thought, LOL!

Intern
jimkola
Posts: 125
Member Since: ‎09-05-2009
Message 6 of 115 (66,030 Views)

Re: DV6000/DV9000 NVidia Issue fix!

The horrible irony, of course, is while most of the failures is on AMD equipped units, there's been very few issues relating to this problem if the gpu was ATI Radeon. And they're a subsidiary of AMD. I'd find it a little weird that AMD would readily install someone else's gpu on their board when they had their own gpu available.

There's so much in-breeding and cross contamination with all these guys that in the end none of them FEEL accountable.

They just sit on the porch pickin' at their banjo.

 

 

 

 

Tutor
NolaBlue
Posts: 15
Member Since: ‎11-29-2009
Message 7 of 115 (65,966 Views)

Re: DV6000/DV9000 NVidia Issue fix!

Hi DVFixxer,

 

I know you directed me to this thread to solve my own problem, so I thought I'd post my question here. I was wondering if a heatsink compound of some sort would work in lieu of those copper "shims". I headed over to eBay to check out their prices on laptops when I found myself following links to their selection of 'Fans, Heatsinks & Cooling'. This seems a whole lot easier to grasp the use of over soddering and copper bits. If this will work to make that fix, I will leap on the opportunity.

 

Thanks!

Tutor
DVFixxer
Posts: 24
Member Since: ‎11-30-2009
Message 8 of 115 (65,959 Views)

Re: DV6000/DV9000 NVidia Issue fix!

No, I don't think that compound alone would work being that the heatsink "hovers" above the chip itself at least .05 of an inch. To "bridge the gap", copper shims need to be inserted along with compound to make the fix work. In my opinion, the thermal cushion is one of the causes of why these series of laptops fail. These shims can be found on Ebay (here) or you can make your own (which I did).

Provost
Huffer
Posts: 11,721
Member Since: ‎11-12-2008
Message 9 of 115 (65,956 Views)

Re: DV6000/DV9000 NVidia Issue fix!

I can confirm you can't just layer enough cooling compound on there to bridge the gap. AMD does not make these motherboards. They are made in China under very specific specs provided by HP but HP got the specs for each subassembly from the supplier, i.e. nVidia for the video chip. Here is an explanation of the problem:

 

explanation

 

As alluded to above, the solder breaks connection between the motherboard and the video chip, under the chip. I am way oversimplifying but I think that is the essence. Since that is the problem I cannot see how adding enhanced cooling above the main chipset (not even the video chip) could help. If downward pressure were placed on the video chip that could conceivably help. Am I understanding correctly that the shims are placed on the main chip and not the video chip or am I missing something?

Tutor
DVFixxer
Posts: 24
Member Since: ‎11-30-2009
Message 10 of 115 (65,874 Views)

Re: DV6000/DV9000 NVidia Issue fix!

To tell you the truth, I think they are one and the same. After having two of these systems apart (both having the NVidia 7150M/630M graphics/chipset), I only saw one chip! The heatsink goes from the CPU to the chipset(/graphics?) and then straight to the fan assembly. The heatsink is only attached at the CPU location and lays across the other NVidia chip. I placed the shims on the NVidia chip itself which creates some pressure but not much as the heatsink is only screwed down at the CPU (which is about an inch or more away).
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation