my external speakers aren't working (hp beats audio)- pavilion dv7 (2750 Views)
Associate Dean
Dragon-Fur
Posts: 5,967
Registered: ‎04-14-2009
Message 21 of 36 (46,748 Views)

Re: my external speakers aren't working (hp beats audio)- pavilion dv7

OK.  Well, there was some confusion - maybe because of the way the thread was originally described and because the IDT driver didn't want to fall into place right away... whatever it was, it's not the issue now.

 

Beats-audio panel is there - that's good.  That means that regardless of what else is going on, the IDT HD driver is in place now.  That is important even if it doesn't prove the speaker hardware still works.  It's a place to start.

 

Looks like it's time for Sound 101. 

 

Questions:

  • Did you make any changes to the computer (since the sound became muffled and stopped working correctly)?
  • Did you load any new programs? If yes, what programs?  (This includes games, email accounts, office type programs...)
  • Change any options to existing programs?  If yes, what options to which programs?  (Guess if you cannot remember exactly.)

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------

From now on, "Sound -->" means to either Open the Sound menu with:

Right-Click on the Sound Icon in your Taskbar --> Playback Devices

OR

Control --> (view by Large icons) --> Sound

 

 

Things to Check (and it will familiarize you with some of the Basic Sound setup items):

  • First, make sure the regular speakers are Enabled.
  • When checking for functionality, it's best to have all Enhancements "Disabled"
  • If beats-audio is turned off (deliberately or otherwise), it can leave the regular Sound messed up (that's a technical term).  The bass / treble adjustments may need to be reset (tone controls).  This is going to be a simple, shove it back to one setting-fits-all fix.  If the sound works, AND it's needful, tone can be readjusted later.
  • The "configure" setting is used to set up and test the system speakers.

Sound --> Playback --> Click on "Speakers and Headphones" --> Properties --> General -->  Device Usage

                    (at the bottom, select) "Use this device (enable)"  --> Apply

 

Go to "Enhancements" -->  Select "Disable all Enhancments" --> Apply

 

Go to  "Tone Controls" -->  Move both Bass and Treble up to --> Apply

 

Go to "Advanced" --> Set Default Format to 16bit, 48000 Hz (DVD Quality)  --> OK

 

Back at Sound --> Playback, go to Configure and run through the steps. 

See if you can get some sound to come out of the speakers!

 

Check the questions and let me know your status after you try the sound checks and we'll go from there.

Good Luck.

 

 



 

 

 

 

 

Kind Regards,
Dragon-Fur
Top Student
Vwschade
Posts: 15
Registered: ‎11-04-2011
Message 22 of 36 (46,746 Views)

Re: my external speakers aren't working (hp beats audio)- pavilion dv7

I haven't made any recent changes other than the computer automatically updating,
Programs- I've downloaded a drive detector but the speakers were working then
Options- Im not aware of any options I might have changed

On a side note: I've disabled all enhancements, moved bass/treble to 4, and set default format. If I plug in headphones, the sound works perfect (just found that out) hope this helps you help me :smileyhappy:
Associate Dean
Dragon-Fur
Posts: 5,967
Registered: ‎04-14-2009
Message 23 of 36 (46,738 Views)

Re: my external speakers aren't working (hp beats audio)- pavilion dv7

Well, Rats.  Options dwindle.

 

OK, first TEST of the Day:

 

Disable and Enable:

I want you to temporarily disable the sound on Speakers and Headphones and then enable it again.

 

Sound --> Right-Click --> Playback --> Double Click on Speakers and Headphones

  bottom of page at Device Usage , select Disable  (it should be at "enabled", so you'll have to cllick to get the menu)

  click OK

 

Wait around for a minute or three.  You could even reboot your system, if you like.

Go back in and then enable "Select this device (enable)".

 

Check your sound - see if it works.  Tell me results.  I can provide graphics if you need help.

 

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Things to recheck (and things I may have missed):

 

Rechecks:

  • Speakers and Heaphones are the "Default" devices selected in Sound --> Playback.  Green Check mark!
  • Check Sound --> Sounds --> and make sure you have some sort of "theme" set.  It can be anything, Cityscape, Delta, Windows Default... the point is, Not to have "no sounds" selected.  (I'm sure this is OK, it's just a "thing to check".  It's also interesting to change your system sounds to something other than "windows default" when you do get your sound working...
  • Make sure you have you have a volume control for all your devices:  Sound --> Right-Click --> Volume Control Options --> Select the devices for which you desire a separate volume control.

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------

The Configure Test:

I infer from your response that when you tried "Configure" (Sound --> Playback --> Configure) ,

that you do not hear any sound from the "test".   I'm assuming you did run that test, if not, please do so.  Smiling.

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Sound Slider Test:

 

Sound --> Open Volume Mixer --> move/slide the volume up and down to/from about 14-30 (doesn't matter exactly)

 

Do you see any response on the mixer bar, that is, do you see a gray/green wave form at the bottome of the bar when the sound-bell is supposed to be chiming as you change the sound (move the slider).

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

IDT HD Audio Driver - Install Date:



I'd like to see the install date on that IDT HD driver. 

I believe that you installed it - just call it detail obsessive. 

I'm going to keep poking at that driver until I'm satisfied with it.

 

Control Panel --> Device Manager --> <your computer-name> -->

           Sound, video and game controllers

                   --> IDT High Definition Audio -- Right-Click  

                               --> Properties

                                     Details  (go to Property and click - look for)  Install Date

 

Just so you know, there is another shorter way to get this information (the driver information)!  I showed you the first way because I just may ask you update that driver in a particular manner and you'll have to get to it through the Device Manager. It's best to know how to do things a couple of ways.  To update the driver to you do have to go through the Device Manager.  If you just want to look at it, you can cheat a bit...

 

Here is the shortcut version to the Install Date information:


Sound --> Playback --> Double-Click on Speakers and Heaphones

 --> Controller Information --> Properties --> Details  (go to Property and click - look for)  Install Date

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Hardware Errors in The Event Viewer:

Next, Check the Event Logs for errors or events related to Sound.  This is going to be a bit intuitive.  I can guide you to open the file - then you are going to be somewhat on your own as far as looking and interpreting what you see.  It can be intimidating  - there is a lot of data.  I am also on a limb, here.  Your system may not look the same nor act the same. 

 

NOTE:

Unlike a work environment, I can no longer duplicate all versions of Windows applications - I'm running a couple of Win7 Ultimate notebooks and I have an old notebook running XP, the test system is down right now and I can't get to one more right this minute...  If you are running Windows 7 Home Premium, it may look slightly different.  You get the drift.  Hopefully, this will be close enough for you to get into where you need to be.

 

Start --> search for "event" --> look for "View Event Logs" and open it

 

Event Viewer --> Applications and Services Logs 

 

Down in the list on the left side of the page, there should be a "Hardware Events" list.  I the size of the Number of Events is greater than "0", then it is worth checking.  What you find there may be important., IF you have s hardware issue with your external speakers it may show up in this list.  I've never had a speaker failure so I cannot tell you what the failure code is.  The Event Viewr is a place to look.  If you find something, anything that looks suspicious (and has sound, IDT, audio in it), report it back and we'll look for what it means.  Simple as that.  Detective work.

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Graphics:

 

sound2.PNG

 

audio_driver_properties_1.PNG

 

event_viewer_apps-services_1.PNG

 

 

 

Final words for right now:

Here's something I found here on the Forum that caught my eye.  It's worth reading and  do note the last entry.  Now, I do realize this is apples and oranges.  If you don't have a warranty and you get to the point where you are sitting on a pile of metal, plastic and software rubbish, you may come back to this one before throwing the notebook on the fire.

http://h30434.www3.hp.com/t5/Notebook-PC-Sound-and-Audio/Probook-4720s-internal-speaker-not-working-...

 



Later.

Hmm.. I may ask you to update the audio driver in a particular way later.

 

 

 

Kind Regards,
Dragon-Fur
Top Student
Vwschade
Posts: 15
Registered: ‎11-04-2011
Message 24 of 36 (46,735 Views)

Re: my external speakers aren't working (hp beats audio)- pavilion dv7

Well for all that helpful info, I must reply with yet another sad face :smileysad:

 

Hardware Events Number of events: 0,  IDT High Definition Audio CODEC Install Date: 11/7/2011 9:31:33 PM, and on a side note- anytime i right click my speaker icon (not the beats one) and hit sounds it comes up as follows:

 

Windows has detected that audio enhancements for the following device are causing problems:

Speakers and Headphones (IDT High Definition Audio CODEC)

Would you like to disable Drive Enhancements for this device?

 

Also: my graphic to test the speakers doesnt look like yours ( the first picture in your last reply)

 

Thanks again for helping me with this, I promise I'm not this stupid all the time :smileyhappy:

Associate Dean
Dragon-Fur
Posts: 5,967
Registered: ‎04-14-2009
Message 25 of 36 (46,732 Views)

Re: my external speakers aren't working (hp beats audio)- pavilion dv7

[ Edited ]

Remember - there are no Stupid Questions.

My earlier response has been modified, but I stand by it: 

I have been IT for a long time - retired now, but  I am still IT at heart.

 

Computers are dumb, people are smart.

We always have to tell computers what to do.

People can always figure it out.

 

 EDITS 10-Nov-2011

 

Many edits - please re-read.

------------------------------------------------------------------------------------------------------------------------------------------------------------------------

HP help link on Sound Issues. 

 

Here is something very important that you may wish to look at.

There may be something new/different here that is particular to your setup that has been missed.

 

http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01912228&lc=en&dlc=en&cc=us&product=4062300&lan...

 

------------------------------------------------------------------------------------------------------------------------------------------------------------------------

I'd like to add this to the list of "things to try".

This is courtesy of one of the Forum Experts, CherylG.

 

There is a difference to how I've done this in the past...

See  #3 -  NO Battery for the first POWER on.

(NOTE: I do not know why this makes a difference, I plan on checking.)

---------------------------------------------------------------------------------------------------------

CherylG says:

Try a hard reset, works sometimes.

 

Disconnect all external devices first.

1- Remove power cord and battery

2- Press power button for 20 seconds (Dragon-fur says, "... I like longer than 20 seconds".  I've read some people recommend as long as 60 seconds. ??")

3- Reinstall only  AC power cord for first startup.

4- Power on

--------------------------------------------------------------------------------------------

 

And... Check if you have - Sound.

Then, next time you shut down the system, put the battery back in.

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

The error:

"Windows has detected that audio enhancements for the following device are causing problems:"

may be symptomatic of something else or it may be something I caused (due to incompatibility in our separate setups)...

 

Errors are sometimes better than no response at all.

Invoke that error and if it will let you, Click YES, or OK or some form of the Affirmative.

-------------------------------------------------

The above error - is it new?  IF yes, then I may have caused it to surface.

 

Sound -->Playback --> Double-Click Speakers and Headphones --> Enhancements

UNCHECK Disable all enhancements

Uncheck anything if it suddenly checks itself

Apply

OK

 

In other words, leave all the Enchancements UNCHECKED for now.  (See "Note!)

 

If the error is not new...

I've been looking for reasons - found everything from more software setups, to straight out hardware failures.  Still looking for something definitive.

 

NOTE!

There is one thing I just thought of...

 

IF the sound is very LOW (not completely gone), then you may be able to get some volume back by doing something different from what I just said above about the Enhancements. 

 

There are posts in the Forum that indicate that the "low volume" issue can be made less of a problem by Clicking on "Loudness Equalization".



-----------------------------------------------------------------------------------------------------------------------------------------------------------------------

Do these only if you wish to take the time.  Reinstalling the driver in this manner may kick it differently - I've read reports that installing drivers using different methods results in different responses by the system (and I've seen it myself).


Driver Uninstall Test:

Control Panel --> Device Manager --> Right-Click on IDT High Definition Audio CODEC --> UNINSTALL

  ... REBOOT your system  (The driver should reinstall itself when the system reboots)

 

---------------------------------------------------------------------------------------------------------------------------------------------------------------------

Driver Reload Test:

 

Go back into one of my older posts and download the IDT HD Audio driver sp* file.  Don't install it.  Just download and make a note of where on your system you put it.  You are going to need to know where it's located.

 

Control Panel --> Device Manager --> Right-Click on IDT High Definition Audio CODEC --> Update Driver Software

  --> Browse my computer for driver software --> Browse -->  find the file and then Click on it --> OK

 

 

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------

I will hunt a bit more on that error to see if I can find anything intelligent about it (most of what I've found is pretty useless or is redundant).

 

I have just gone through the HP link on Sound Issues - it's pretty thorough and covers most of what is covered by various posts here on the Forum and some of what I've seen during my hunts on the 'net for more information.  I will think more on this - if you have a resource near at hand, you might want to put an extra pair of eyes on this.

 

If it's software, it's likely to be something simple even if it's a devil to find. 

If it's hardware - usually simple  ... telling the two apart is the challenge.

 

Good Luck.

Let me know if you think we can do more. 

I will try and think of something useful that has been missed. 

There are lots of smart folks on this forum and maybe someone will have an answer.

 






 


 




 

Kind Regards,
Dragon-Fur
Top Student
Vwschade
Posts: 15
Registered: ‎11-04-2011
Message 26 of 36 (46,662 Views)

Re: my external speakers aren't working (hp beats audio)- pavilion dv7

Sadly, after trying all these suggestions, nothing happened still. Will I forever have muffled internal speakers and no Beats ones working? The world may never know.. :/

Associate Dean
Dragon-Fur
Posts: 5,967
Registered: ‎04-14-2009
Message 27 of 36 (46,660 Views)

Re: my external speakers aren't working (hp beats audio)- pavilion dv7

[ Edited ]

Rats and all that.  Technical term.

 

Don't give up - you may have to put this on the back burner (or speaker, so to speak). 

 

First Commentary - then "One More Grand Idea"

Maybe you could try external speakers.  From what I've read: The beats-audio chip is made for External Speaker Awesomeness (my old English professors are cringing, but it's descriptive).  The beats-audio is not actually your onboard speakers - it's a chip that makes it possible to connect speakers to your computer and listen to the beats-audio experience.  Even the onboard speakers (if you could just get the stubborn beasts to work) sound better with a beats-audio chip in the computer, but they don't sound as good as do high grade external speakers.  It may also be true that the onboard speakers in a system with beats-audio are better than those on other computers...??  I don't know about that - I have beats-audio on my system and my system (onboard) speakers sound pretty average.  Could be just me.  Smiling.  I do have to say, I'm grateful my sound still works.

 

Side Note: If there are issues getting external speakers to work, it may mean the problem is different form what was thought to be the original problem.  You have connectivity with headphones, speakers may work as well.

 

NOTE that if you buy speakers, that you should purchase POWERED speakers (with their own AC power supply) and not "passive" speakers.  Passive speakers do not work as well and are to be avoided unless you do not have a power supply available (or have other considerations that prevent the Powered option from being used).  The powered speakers do cost just a little bit more; you will be happier with them and you may as well have nice since you are already in Speaker Pergatory. Buy your speakers from a reputable source - if they work, you may well wish to upgrade when you hear the beats-audio in action.  Smiling.

 

One of the things I've found on the 'net that I think is intriguing is the idea that the sound disappears for no apparent reason, there have been no changes, the user's system is still functional (at least mostly) in other areas, and the sound doesn't respond to any of the known fixes.  There are so many variables, it's impossible to say it's not ten different things on ten different systems.  Still, aside from  hardware types, OS differences, updates (and there are a lot of variables here), and driver corruption, there ARE limits to what can go wrong.  After a while, one runs into a limit of options.

 

This is getting old, I know - but I have been looking for solutions to some of these issues and yours is on the top of the list.



Remember the Image and file backup I recommended?  Before you run a self-test, it's good to have your system backed up and your recovery disks created - safety first when you start poking at the system.  That's my IT background - I can't help it, and you need to keep your system backed up in any case.

 

IF you are interested and not complete insane by now...

Where else to look on your system? 

 

Hidden "Off" controls:

I cannot help be think that something was loaded on your system that sabotaged it.  If you have checked both HP Support Assistant updates and Windows Updates... then I cannot think of any other way an update could have snuck onto your system unless it was something from within a GAME setting, from a Media Center setting (watching a movie and turning off the sound and somehow it turned it off everywhere?)...  Do you remember doing any of that?  If yes, there are maybe a couple of places we can look for werid things of this type...

 

The Big Hardware Check

What if it is hardware, but not the speakers?  OR, What if it is the speakers and the system could tell us?  Here is a link to a document that outlines how to run Diagnostics on your system (Hopefully on YOUR system) that could tell you whether or not your computer is healthy. My advice?  Run everything - test it all.  Read the document, follow the directions and go for it.

 

Diagnostics for Windows 7

Testing for Hardware Problems Using Hardware Diagnostic Tools (Windows 7)

http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01895819&lc=en&cc=us&destPage=document&dlc=en

 

If nothing else, you'll find out if the diagnostic tools think your system is healthy and happy.

 

Let me know if anything changes. 

I'll let you know if I find anything that is worth reporting.

Keep checking at your website for updates - it's possible that HP will come up with a fix.

Kind Regards,
Dragon-Fur
Top Student
Vwschade
Posts: 15
Registered: ‎11-04-2011
Message 28 of 36 (46,657 Views)

Re: my external speakers aren't working (hp beats audio)- pavilion dv7

Some more known issues now:

"Windows Installer Service could not be accessed" ( I looked at solutions for this, but nothing helps..again. I've tried 5 different things so far and still looking)

Java, Quicktime, and Adobe can be updated

and Im not quite sure how to turn on my external speakers? It's a laptop and the only speakers that are on it are 4 small oval speakers holes on both sides with a Beats logo next to it.

Associate Dean
Dragon-Fur
Posts: 5,967
Registered: ‎04-14-2009
Message 29 of 36 (46,654 Views)

Re: my external speakers aren't working (hp beats audio)- pavilion dv7

When I was suggesting "external speakers", I was talking about buying some External speakers from a store, you know, in a box.  Smiling.  Connecting them to your laptop like you would connect speakers to a stereo system.  I am sorry to have confused you.  I know your laptop speakers are not working.  That's the whole point, isn't it.  :smileysad:

 

Windows Installer is down?  Well, rats.  Let me gather up some things to clear it.

 

 

 

 

 

 

 

 

Kind Regards,
Dragon-Fur
Associate Dean
Dragon-Fur
Posts: 5,967
Registered: ‎04-14-2009
Message 30 of 36 (46,650 Views)

Re: my external speakers aren't working (hp beats audio)- pavilion dv7

[ Edited ]

EDITS  15-NOV-2011

Previous Content Removed...  I'm not so sure just jamming around on the Windows Installer service is going to work or do anything.  The service is unhappy about something.

 

Subject "Windows Installer Service could not be accessed"

Everything I've read about this since I heard about it from you the other day suggests it's about incompatibility - installs or uninstalls of software that is somehow incompatible with the operating system in the condition that it is at the time the install takes place.

 

There are only two somewhat reliable fixes mentioned in the web posts I've found:

1)  Going back to a reliable Restore point prior to when the error occured and then NOT reenacting the action that causes the problem.  That is, do not try to install (or uninstall) that incompatible software.

 

2) Provide a registry fix.

 

Windows Installer Registry Fix (as used on Windows 7 Home Premium 64-bit by User DerekNess)

  • Go to Start, then Run, then type regedit
  • Go to HKEY_LOCAL_MACHINE\SYSTEM\CURRENT CONTROL SET\SERVICES\MSIserver\WOW64
  • Right click on WOW64, then select Modify
  • Set Value Data to 0 (mine was set at 1) and Base should be Hexadecimal.
  • Reboot, and you should be able to install your software.

 

Reference Link (User's entry is near the bottom of the page):

http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/error-1719-windows-insta...



The total reference is several pages in length - different remedies are mentioned for various systems and situations (including not having WOW64).

 

 

Muffed Speaker Options:

 

Headphone Port Dust:

Get a can of compressed air and blow out your headphone jack. There may be dust in the port and it makes the speakers think the headphones are connected all the time.

 

Bent Bits:

Get a rubber ended bobby pin or a match stick and clean poke it in the headphone port.  Gently.  There's a little sensor in there that can become bent and the system thinks your digital line is connected.  (Similar to Dusty Bits.)

 

Beats-Audio:

Someone just entered an HP forum post about Bose speakers -  "they are muffled", and the member has asked about editing the bass and treble.  Made me think... I realize you probably never edited your beats-audio panel settings, but maybe you could take a look at them.

beats-audio Logo HPBeats.png  --> Right-Click --> Open --> Listening -->

Beats Audio Checked

Music "checked"

Make sure that "Center" slider is NOT at the very bottom... if it is at the bottom, everything sounds muffled.

 

You could try adjusting the each of the white sliders and see if moving any of them changes the sound at all...  I'd at least check that center slider.  (You could just go to Advanced settings and set everything back to Default Settings.)

 

beats_audio_panel.PNG

 

Good luck.

Kind Regards,
Dragon-Fur
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation