Question
Reply
 
Honor Student
ch0l0n
Posts: 4
Member Since: ‎08-27-2012
Message 1 of 14 (3,002 Views)
Accepted Solution

I keep getting "unable to connect to web services on a 5520" when attempting to use them

Printer, Photosmart 5520

Prints wireless OK using iPad, Iphone and MacBook , OSX 10.7.4

Unable to use apps or connect to WEB Services.

Contacted HP a week ago and I was told that their server was down and keep trying.

A week later and still same error message.

A solution was posted saying "try replacing the DNS Server's IP address to 8.8.8.8 and 8.8.8.4". But I don't know where to find the DNS Server IP once I go to the printer IP page using Safari.

Help would be appreciated.

henri

Distinguished Professor
Shirlzz1
Posts: 3,242
Member Since: ‎12-12-2011
Message 2 of 14 (2,975 Views)

Re: I keep getting "unable to connect to web services on a 5520" when attempting to use th

Hello. To set a static DNS you must access the embedded web server (EWS).  You do that by entering the IP address for the printer into the address bar of the browser of your choice.

 

  •   Once it brings up your Photosmart’s EWS, locate the tab that is labeled “Network”. From there look in the left column on the new page that will pop up and select “Networking” and then select Network Address (IP).  That will bring up the page to set the Static DNS. It will be the 2nd portion of that page.  
  • Set the radial dial to manual.  Then, for the manual preferred/Primary DNS, set it to 8.8.8.8 and the Manual Alternative/Secondary to 8.8.4.4; then click apply.
  • NOTE: if another message with an option to click “OK” appears, read that message carefully. Most of the time it is an option to undo the change you just did and you will want to avid clicking that message. Just navigate away from that page by clicking on another tab.
  • Power cycle the printer. Once printer is back up and through with calibrations from being turned off and on. Reattempt to connect to web services by touching the icon.   
I am a former employee of HP...
How do I give Kudos?| How do I mark a post as Solved?
Honor Student
ch0l0n
Posts: 4
Member Since: ‎08-27-2012
Message 3 of 14 (2,969 Views)

Re: I keep getting "unable to connect to web services on a 5520" when attempting to use th

Done as your instruction, Eprint works fine. Finally got the password from the printer.
Thank you so much,
Henri
Distinguished Professor
Shirlzz1
Posts: 3,242
Member Since: ‎12-12-2011
Message 4 of 14 (2,938 Views)

Re: I keep getting "unable to connect to web services on a 5520" when attempting to use

I am always glad to help.  I am happy that you are up and running now! Happy Printing!!! :smileyhappy:

I am a former employee of HP...
How do I give Kudos?| How do I mark a post as Solved?
Honor Student
ch0l0n
Posts: 4
Member Since: ‎08-27-2012
Message 5 of 14 (2,926 Views)

Re: I keep getting "unable to connect to web services on a 5520" when attempting to use th

Thanks again, I asked a friend in China to print to my new HP here in Australia, not a problem, great.
Student
AnkeS
Posts: 1
Member Since: ‎11-25-2012
Message 6 of 14 (2,681 Views)

Re: I keep getting "unable to connect to web services on a 5520" when attempting to use th

HI I have tried your suggestion.  My MAC 10.6.8 cannot find the printer ip address  194.168.254.40  what do I do?

Distinguished Professor
VisionAiry
Posts: 3,127
Member Since: ‎02-15-2013
Message 7 of 14 (2,324 Views)

Re: I keep getting "unable to connect to web services on a 5520" when attempting to use th

@AnkeS - any luck yet?  Are you still having web-connection issues?  I know it's been a while.  I was doing a Google search and ran across a lot of unanswered questions so I wanted to check on you. 


Don't forgot to say thanks by giving "Kudos" if I helped solve your problem.

When a solution is found please mark the post that solves your issue.

Every problem has a solution!
Honor Student
SKBhargava
Posts: 3
Member Since: ‎10-21-2013
Message 8 of 14 (1,301 Views)

Re: I keep getting "unable to connect to web services on a 5520" when attempting to use th

I am facing the same issue with my HP 5520 printer. I am unable to setup the eprint. I even tried the manual dns entry however it is reset after I restart the computer. I am using a windows 8.1 machine. Pls help

Distinguished Professor
VisionAiry
Posts: 3,127
Member Since: ‎02-15-2013
Message 9 of 14 (1,297 Views)

Re: I keep getting "unable to connect to web services on a 5520" when attempting to use th

Are you getting the error message "Unable to connect to server" on your printer?  If so, I may know a trick but I will have to send you that information offline via private message.  What about printing wirelessly, are you at least able to do that?  Are you getting any other error messages and/or have you obtained an ePrint email address from the ePrint website yet?

 

Answer those questions for me please and I will be happy to help.  Click the "troubleshooting eprint section" of this help guide for the basics steps.


Don't forgot to say thanks by giving "Kudos" if I helped solve your problem.

When a solution is found please mark the post that solves your issue.

Every problem has a solution!
Honor Student
SKBhargava
Posts: 3
Member Since: ‎10-21-2013
Message 10 of 14 (1,274 Views)

Re: I keep getting "unable to connect to web services on a 5520" when attempting to use th

I am able to print wirelessly just that I am unable to enable web services and therby unable to setuup eprint

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation