cancel
Showing results for 
Search instead for 
Did you mean: 
LeifDP
New member
2 1 0 0
Message 1 of 4
313
Flag Post

USB port - difficult to accept connectors

HP Recommended
HP Pavillon 500-320 no
Microsoft Windows 10 (64-bit)

In the recent couple of months my PC are having increasingly difficulties in finding the UBS connectors. Ex. my Garmin watch or other electronic gadgets.

Previously there have been no problem.

Now it will sometimes find the connector very slowly (F: drive), or not at all. For instance my Iphone 6, although I accept the connection on the phone.

 

Could it be a missed driver-update or something similar?

 

Best regards

Leif

3 REPLIES 3
Flower_Bud
Retired
Retired
5,216 5,204 272 397
Message 2 of 4
Flag Post
HP Recommended

@LeifDP

Welcome to the HP Forums 🙂

I would like to take a moment and thank you for using this forum, it is a great place to find answers.

 

As I understand, USB port does not work, 

No worries, as I'll be glad to help you, that said, I'll need a few more details to dissect your concern & provide an accurate solution:

What is the product number of your device? Use this link to find it: http://support.hp.com/us-en/document/c03754824 

(Ensure you do not share any of your personal information such as serial, phone number, email ID, etc...).

Have you attempted any steps on your own before posting on the HP Forums?

When was the last time it worked fine?

Were there any hardware/software changes made? 

Have you tried connecting an external mouse? 

 

In the meanwhile, you could refer to this link: https://support.hp.com/in-en/document/c03327635

 

Once I have the information, I'll help you further with the troubleshooting steps,

Keep me posted,

Cheers!

0 Kudos
LeifDP
Author
New member
2 1 0 0
Message 3 of 4
Flag Post
HP Recommended

Hi Flower_Bud

 

There have been no changes made to my computer.

My Iphone will not connect through the USB port, and my Garmin watch works very slowly. Sometimes it takes 5-6 tries to connect. When the watch connects it refers to the F: drive.

 

The product number is: J5M89EA#UUW

(Your link didn't work :-))

 

I have tried to find information on HP pages, but not been able to find it in my own language (Danish), and I don't think I have the necessary skills in technical English to find it in the English pages.

 

I have not tried to connect an external mouse. My mouse is connected to a port on the front and it works perfectly.

 

The USB ports has been working without problem up till 3-4 months ago.

 

Please note that I have tried to connect the USB connectors to USB ports on the front and back. Perhaps my problem is not the USB ports but the connection to the F: drive?

 

Best regards

Leif

0 Kudos
Flower_Bud
Retired
Retired
5,216 5,204 272 397
Message 4 of 4
Flag Post
HP Recommended

@LeifDP

Thanks for responding, 

It's great to have you back,

 

As the mouse and USB port is working fine, this seems to be an issue either with the other device or the USB cable. You could try to the change the USB cable and check the functionality. 

 

You could also update the BIOS on your PC: https://support.hp.com/in-en/document/c00042629

 

If the issue persists, I would suggest you contact the manufacturer of that device. 

 

Hope this helps!

Cheers!

0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation