cancel
Showing results for 
Search instead for 
Did you mean: 
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
Nithya05
New member
3 0 0 0
Message 1 of 4
2,325
Flag Post

IN UFT 12.01, SWFobjects are getting identified as Winobjects

HP Recommended

We are automating a Window based application using UFT 12.01.

 

The Product and UFT Tool are installed in Client Network-Desktop and we are accessing through VPN connectivity.

 

Technology stack of the application are

  • .Net Framework 4.0
  • IIS6.0 or greater
  • Sql Server 2008 R2
  • DevExpress V11.2 (UI & Reports)
  • Janus Controls (UI)
  • AutoMapper used within Interfaces
  • Ciloci.Flee used for expression builder
  • Autofac used of IOC cache

 

 

We are using following Add-ins for automating the application:

.Net, Active X, PowerBuilder, Visual basic, Web, WPF

 

Scripts are generated in UFT by identifying the objects as Swfobjects.

 

Sometimes we are facing issue in identifying objects. The objects are identified as Winobjects suddenly in middle of writing scripts.

 

Can anyone explain me what goes wrong here and why we are getting this issue? What is the exact solution to overcome this?

3 REPLIES 3
tclasp
Level 1
11 11 0 0
Message 2 of 4
Flag Post
HP Recommended

 

You may want to try reposting your question on the forums specifically for the UFT product. Here's the link.

http://h30499.www3.hp.com/t5/Functional-Testing-QTP/ct-p/sws-Fun_Test

Was this reply helpful? Yes No
kulski666
New member
1 1 0 0
Message 3 of 4
Flag Post
HP Recommended

I'm just facing exactly the same issue - we try to migrate our .net application probes to UFT 12.01 - but the swfObjects are not recognized. Even if i try to start a new probe with this application, UFT does not start to recognize the Objects as swfObjects.

 

Anybody knows how to get this fixed?

Was this reply helpful? Yes No
Rajnikantsingh
New member
1 1 0 0
Message 4 of 4
Flag Post
HP Recommended

Sometimes UFT behaves unexpectedly.

 

There is a workaround for this.

 

you need to record some of the SWFObjects, 2-3 steps would be sufficient.

Stop the recording.

Do the Object Spy.

 

and SWFobjects will start getting identified as SWFobjects

Was this reply helpful? Yes No
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation