cancel
Showing results for 
Search instead for 
Did you mean: 
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
Oldarmy
New member
4 3 0 1
Message 2 of 5
1,147
Flag Post

Error: 536870141 c:\Program Files\....\...\HPreststub.inf when installing HP 7510

HP Recommended
HP Photosmart 7510
Microsoft Windows 8.1 (64-bit)

Updated to a newer Lenovo L450 with a clean stripped down install of Windows 8.1 x64. This particular laptop will not install the newest HP 7510 software / driver. 

 

Error:

Call to DriverPackageInstall returned error -536870141 for package C:\Program Files\HP\HP Photosmart 7510 series\DriverStore\HPRestStub\HPRestStub.INF

 

I have followed multiple troubleshooting documents/steps found online all have failed.

 

This is the same Windows 8.1 image loaded on all our devices with in the company. I've run all Windows updates and Lenovo updates. 

 

Suggestions?

 

Thank you

0 Kudos
4 REPLIES 4
Oldarmy
Author
New member
4 3 0 1
Message 1 of 5
Flag Post
HP Recommended

We are having the same issue with the 7500 series printer. I've gone as far as reloading the laptop and still having issues with 2 HP printers not wanting to install.  I've walked through all the troubleshooting I've been able to locate todate and nothing has worked.

 

Forgot to add: Windows 8.1 64bit - Lenovo L450

0 Kudos
Drakster
Retired
Retired
4,038 3,773 306 607
Message 3 of 5
Flag Post
HP Recommended

Hi @Oldarmy

 

Thank you for reaching out to the HP Support Forums! 
 
I see that you're unable to install the HP Software, I would be happy to help you and please remember to return to this thread and mark 'Accept as Solution', if I have successfully helped you resolve the issue. If you wish to say 'thanks' for my effort to help, click the 'thumbs up' to give me a Kudos.
 
It sounds something is blocking the drivers from installing. Third-party software, firewall, anti-virus, anti-malware or malware can cause this.
Try disabling them. 
 
If the issue persists, we are going to start by cleaning your computer up.
Disk cleanup in Windows 10. Click here.
Perform Clean Boot in Windows 10 / 8 / 7. Click here.
Use the System File Checker tool to repair missing or corrupted system files. It is always a good idea to back up your data before proceeding. Click here.
System file check (SFC) Scan and Repair System Files & DISM to fix things SFC cannot. Click here.
 
Uninstall and reinstall the HP Software. 
To cleanly remove the printer and drivers, follow the steps from this post by my colleague X-23. 
 
Try downloading the software using a different internet browser, like Google Chrome or FireFox.
Click here to download and install the HP Software again. 
 
I hope this helps. Please respond to this post with the result of your troubleshooting. Good Luck!  🙂

Drakster
I work on behalf of HP

If you found this post helpful, you can let others know by clicking the Accept as Solution button. You can also show your appreciation, with a kudos, by clicking the thumbs up" button!

0 Kudos
Oldarmy
Author
New member
4 3 0 1
Message 4 of 5
Flag Post
HP Recommended

Testing - loading a 2nd test machine as well. I will update next week. Thank you

Oldarmy
Author
New member
4 3 0 1
Message 5 of 5
Flag Post
HP Recommended

Hello Drakster,


Thanks for your reply. I did try the steps you provided and the same result. I also performed these on a new loaded device as well, same result. I agree it is a 3rd party software and I may have located it.

 

Device / Software Information:

 

Lenovo L450 & L430
Windows 8.1 x64 (installed using SCCM PXIE Boot)
MS Windows updates (todate)
Lenovo driver updates
Sophos Encryption
SCM
Symantec Endpoint Protection (firewall as well)
Adobe Reader XI
Citrix Receiver 4.1
doPDF 8
Meditech 4.25g

Troubleshooting Steps:

 

Test 1: (Base load)
Loaded device with just = Able to install driver
Windows 8.1 x64
MS Windows updates (todate)
Lenovo driver updates
Sophos Encryption
SCM

 

Test 2:
Loaded device with same + Symantec = Able to load driver

Test 3 + :
Loaded 2 laptop devices with Base Load.

  1. Device #1: All required software
    1. Failed to load
    2. New error “Unable to find core driver package” when trying to add through the add printer screen.
  2. Device #2: All software excluding Meditech 4.25g
    1. Drivers install, no error

I ran through your troubleshooting steps list above:

  1. Disabled Symantec = Failed to install drivers
  2. Disabled firewall = Failed to install drivers
  3. Performed Disk Cleanup 8.1 – Failed to install drivers
  4. Performed clean boot – Failed to install drivers
  5. Performed SFC / DISM – Failed to install drivers
  6. Uninstall HP driver – not possible, it never installs.
  7. Downloaded software pack from another computer – moved over, failed to install

Interesting Note:

If you go into Control Panel > Devices & Printers the printer shows up with a bang and say no driver installed. But if you go into Administrative Tools > Print Management the printer is listed with the HP Photosmart 7510 driver and you are able to print from Notepad, etc. But you still not scan or look at the printer properties because the driver shows as not installed from Devices and Printers.

 

***** UPDATED 3.21.16 1119hrs******

Okay additional test this morning and show that it is not just Meditech 4.25g. More troubleshooting steps coming after I load a few more laptops with different software loads. 

 

Thank you

Wade

0 Kudos
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation