cancel
Showing results for 
Search instead for 
Did you mean: 
hermidalc
Level 2
8 6 1 2
Message 1 of 10
5,025
Flag Post

Solved!

Boot with external display and laptop lid closed in hybrid graphics mode causes Windows blue screen

HP Recommended
ZBook 15 G4
Microsoft Windows 10 (64-bit)

I have a major problem with my HP ZBook 15 G4 Mobile Workstation.  I've had it now for six months, using it without any blue screen issues until now that I'm trying to use it with an external display for the first time.

I have hybrid graphics enabled in the BIOS.  I have installed all the latest HP, HP BIOS, Intel, Nvidia, and Windows 10 updates.  In Windows I have the multiple display setting set to "Second screen only" which is normal if you want to work on the external display when the laptop is closed on your desk.

 

What happens is if I boot or restart connected to the external display with the laptop lid closed then right after loading the pre-OS screen on the external display the computer will fail to go to Windows and restart, then cycle like this a few times showing the pre-OS screen again before finally showing a Windows blue screen with the following error:

"A required device isn't connected or can't be accessed. Error code: 0xc000000c"

The blue screen says that I should start a recovery but this only started happening once I connected an external display so I investigated further before believing anything needs to be recovered.

After troubleshooting and testing a lot of things this is what I found:

 

1) If I leave the laptop lid open so that when I boot the pre-OS screen displays on the laptop panel before then shutting off and sending the display to the external monitor then there is no blue screen.

 

2) If I boot or restart the laptop without using an external display then there is no blue screen.

 

3) Finally, if I turn off hybrid graphics in the BIOS and enable discrete graphics only then when I boot or restart using the external display with the laptop lid closed there is also no blue screen.

 

There seems to be some serious issue with the HP BIOS and pre-OS environment in hybrid graphics mode when you are booting with the laptop lid closed and an external display.  It causes Windows to have the blue screen thinking a required device isn't connected.


The problem also is that the workaround is not feasible, that is I cannot always run the laptop discrete graphics mode.  With the ZBook mobile workstations you need hybrid graphics turned on otherwise battery life is miserable (lasts 2-3 hrs on full charge) because the Nvidia GPU consumes a lot of battery power.  With hybrid graphics battery life is actually really good.  I use this laptop for work and business and I need it to run more than a couple hours on battery.  So the workaround is not good.  It is also very inconvenient to into the BIOS constantly to have to change the hybrid/discrete graphics mode setting for the times I need better battery life.

 

Could you please help me with resolving this issue?  Please if you could contact the engineering team to try and reproduce it.  I have a full 3/3/3 warranty and comprehensive CarePack with HP.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
hermidalc
Author
Level 2
8 6 1 2
Message 10 of 10
Flag Post
HP Recommended

HP developed new pre-production BIOS that fixes the problem since a lot of ZBook 15 and 17 G4’s have this issue. I opened a case for my laptop and became one of the testers and it fixes the problem completely.  It will eventually make it into a production BIOS update.

 

View solution in original post

9 REPLIES 9
soccer_dan
Level 8
Level 8
1,195 1,195 74 153
Message 2 of 10
Flag Post
HP Recommended

did you try changing Windows display settings back to normal, and NOT external only? i am not sure that is a correct setting to set as default

 

i would also make sure the TB 3 dock firmware has been updated. the latest version is 1.26

 

- http://ftp.hp.com/pub/softpaq/sp84501-85000/sp84553.exe

 

you can then run hp image assistant to confirm everything is up to date

 

- https://ftp.hp.com/pub/softpaq/sp85501-86000/sp85530.exe

 

if you need to contact hp support afterwards, you can try the elite support line at: 1-866-625-1175 or the specialty support line at 1-866-852-4865

I work for HP. However, all opinions and comments are my own.
hermidalc
Author
Level 2
8 6 1 2
Message 3 of 10
Flag Post
HP Recommended

 

Thank you for the recommendation on how to fix the problem.  Although there is no normal setting in Windows when you have multiple displays.  You can choose from "Primary display only" (i.e. laptop panel), "Duplicate displays", "Extend displays", "Second display only".  When you have your laptop lid closed on the desk and connected to the TB3 dock (as if it were a desktop machine) I believe the normal setting would be "Second display only", the others don't make sense because they involve the laptop panel that is closed?


 

 

0 Kudos
hermidalc
Author
Level 2
8 6 1 2
Message 4 of 10
Flag Post
HP Recommended

To follow up with more info:

 

- I had the TB3 dock firmware already fully updated to 1.26, the problem occurs without it as well when I have the external display directly plugged into to the laptop

 

- I tried as you suggested to use a different multiple display setting, the other that I thought might work was to duplicate displays.  Though this did not help, as long as the laptop lid is closed when I boot or reboot with hybrid graphics enabled it will cycle trying to boot and eventually blue screen.

 

Another very important point, the process that leads to this blue screen is particularly damaging.  Many times it will cause filesystem corruption that Windows has to fix, and even after fixing when I use the laptop by itself it will occasionally continue to have blue screens.  It causes some serious damage to Windows.  So I have to restore my entire computer from my backup image and then everything is fine.  For these reasons I find it difficult to continue testing different things as this is very serious.

 

I've even reinstalled Windows 10 on my laptop completely from scratch.  So Windows 10, then all the latest HP drivers for the ZBook 15 G4 and Windows 10 updates.  On a clean laptop this the problem still occurs.  So what does this say?   I have no idea what HP Support will be able to tell me over the phone other than waste time spending hours on the phone troubleshooting and trying different things from scratch and constantly having to recover my laptop from backup after the blue screens.  This type of problem is not the kind that has some magical solution that can be discovered with HP support over the phone.

 

This issue is an engineering issue, there is something critically flawed either with the current HP BIOS and pre-OS environment and how it deals with hybrid graphics wiht the laptop lid closed and an external display on the latest version of Windows 10, or something with the latest HP ZBook 15 G4 provided Intel + Nvidia Optimus drivers.  When the laptop lid is closed something goes seriously wrong with the handoff to Windows.

 

 

Does anyone out there have an HP ZBook 15 G4 with hybrid graphics enabled? (which is honestly the norm) 

 

 

 

 

 

0 Kudos
hermidalc
Author
Level 2
8 6 1 2
Message 5 of 10
Flag Post
HP Recommended

 

Another thing to add, reading through this HP document Multiple Displays on HP ZBook Mobile Workstations

 

This note seems to me to point to where the problem might come from:

 

Special note on hybrid graphics during Pre-OS environment:

On HP ZBooks with hybrid graphics, any one display whether it is connected to the integrated or discrete GPU is usable (viewable) during Pre-OS.This feature is called “Hybrid Graphics Enhanced Display” and is by default enabled in BIOS.

 

As I described my issue in this thread, in hybrid graphics mode if the laptop lid is left open when booting or restarting then there are no blue screens or other issues.  The pre-OS screen is shown on the laptop panel and then, in the case of "second display only", it shuts off and the Windows login screen displays on the external monitor, or, in the case of "duplicate displays", it doesn't shut off and both displays show the Windows login screen.  But when you have the laptop lid closed in hybrid graphics mode it will display the pre-OS screen on the external display and the cycle trying to boot and then blue screen.

 

Why is everything fine when the laptop lid is left open and terrible when it's not?  It really points to a possible HP pre-OS problem and handoff to Windows.  In hybrid graphics mode if it doesn't have the laptop panel available before gettting to Windows then it has serious problems.

 

 

0 Kudos
David-IT
New member
1 1 0 1
Message 6 of 10
Flag Post
HP Recommended

Hi!

 

I don't have much to add but to say that you are not alone.

We have about 140 HP Zbook 15 G4's in use right now, and we've had this particular problem with about 10 of these so far.

Also had the same problem on a Zbook 17 G4.

 

The really strange thing is that some get this problem a month into using the laptop. So I fear that this could escalate quickly.

 

So far we've changed to Descrete Graphics whenever the problem occurs, but HP needs to fix the problem.

 

Regards

David

hermidalc
Author
Level 2
8 6 1 2
Message 7 of 10
Flag Post
HP Recommended
soccer_dan since you work for HP if you could please read the rest of this thread here with my posts and a post from another IT Engineer having the same issue with a number of HP ZBook 15 G4s like mine and a 17 G4.

This is an HP engineering flaw that cannot be fixed by support wasting time with us to try different things that cause more blue screens and corrupt systems which need reimaging.

Please if you could report this problem to HP Tech/Engineering because I am sure they could reproduce it if the tried with enough 15 G4 models.

I paid over $3000 for this laptop it is very, very upsetting to see this type of problem on such an expensive piece of equipment.
iMaxx
Level 8
Level 8
579 567 29 240
Message 8 of 10
Flag Post
HP Recommended

I'm sitting with the Engineering team now and they are now aware of this issue.


Could I have you call in and have a case created? You can tell them that you want to get the case to 3LS (3rd Level Support - they work with R&D) This will allow the support teams to track this issue and push on R&D.

I am an HP Employee
Quality Manager - HP VR / Z Desktops
-----
iMaxx” FORMER VOODOO PC / HP LEGACY GAMING SERVICE MANAGER
While I am an HP employee, my comments and suggestions are my own and do not represent HP Inc.
0 Kudos
bubler
Level 4
71 65 1 21
Message 9 of 10
Flag Post
HP Recommended

What happend with this? Was it resolved?

0 Kudos
hermidalc
Author
Level 2
8 6 1 2
Message 10 of 10
Flag Post
HP Recommended

HP developed new pre-production BIOS that fixes the problem since a lot of ZBook 15 and 17 G4’s have this issue. I opened a case for my laptop and became one of the testers and it fixes the problem completely.  It will eventually make it into a production BIOS update.

 

View solution in original post

Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation