cancel
Showing results for 
Search instead for 
Did you mean: 
brraw_usr
New member
4 3 0 0
Message 1 of 7
818
Flag Post

Connection problem with USB-C / Thunderbolt

HP Recommended
HP ZBook Studio G5 Mobile Workstation
Microsoft Windows 10 (64-bit)

I have a HP ZBook Studio G5 Mobile Workstation. It has 2 USB-C / Thunderbolt ports. 

I also have a Thunderbolt G2 Dock and a HP USB-C to RJ45 adapter.

The Dock works fine ... the network adapter is a different story:

It was working fine until it suddenly stopped working on the built in port. If I plug the adapter in the USB-C of the connected dock, windows recognises it.

All the drivers, etc. are updated, does anyone know why it stopped working? What can be done about this?

6 REPLIES 6
TryToDoMybest
Level 8
829 820 81 166
Message 2 of 7
Flag Post
HP Recommended

Hello

 

I don't understand exaclty the setting.

Docking TB G2 has is own Rj45 port for network.

which port stopped working ? the RJ45 of the docking ?

so in order to have a RJ45 connection , you used an USB-C-to-RJ45 adapter, and connected it to one of the USB-C port of the docking ?

 

bye

 

0 Kudos
brraw_usr
Author
New member
4 3 0 0
Message 3 of 7
Flag Post
HP Recommended

Its not about the RJ45 connection on the Dock. I use the USB-C adapter while mobile, because the laptop doesnt have RJ45 onboard.

 

The problem is: this adapter was working, but suddenl stopped working. I just stated that it works on the dock to say the adapter itself is working

0 Kudos
TryToDoMybest
Level 8
829 820 81 166
Message 4 of 7
Flag Post
HP Recommended

Hello

 

oen thing I would try is:

connect the adapter to Zbook

start Device Manager

find the adapter in Network adapter

right click on it

from menu, select "uninstall Device"

wait jus ta second to see the Device Manager refreshing

remove and reconnect the adapter

verify if it works.

 

bye

0 Kudos
brraw_usr
Author
New member
4 3 0 0
Message 5 of 7
Flag Post
HP Recommended

When connected to the ZBook, the device is not listed in the device manager. Also when pluggin in, windows does not make that "something connected" sound.

0 Kudos
TryToDoMybest
Level 8
829 820 81 166
Message 6 of 7
Flag Post
HP Recommended

that's very uncommon.

difficult to say it hardware or software.

 

do you have the knowledge to try the dongle in WinPE or

attach the dongle , connect a LAN cable , able to go in Internet and , inside BIOS setting , try to start a BIOS update ?

 

bye

 

 

0 Kudos
brraw_usr
Author
New member
4 3 0 0
Message 7 of 7
Flag Post
HP Recommended

Okay I narrowed it down:

After plugging in the Dock, the laptop activates the Thunderbolt Software. This in turn kills the USB connectivity of both ports. After unplugging the Dock nothing happens. BUT: If I send the laptop to sleep and then wake it up again, the USB connectivity is restored.

 

I have tested this with 2 different HP USB-C to RJ45 adapters and with a cheapo USB-C/Thunbolt to RJ45 adapter. Both HP adapters wont work when the Dock is plugged in. Strangely enough the cheap adapter indeed has Thunderbolt and so it works with the Dock connected.

 

Are HP employees reading this or do I have to open a ticket in regard to ask if this behaviour is normal?

0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation