cancel
Showing results for 
Search instead for 
Did you mean: 
jceo
Level 2
20 17 1 0
Message 1 of 14
36,635
Flag Post

Elitebook Folio 9470m Won't Turn On -Flashing Charge Light Amber/White

HP Recommended
Elitebook Folio 9470m
Microsoft Windows 7 (64-bit)

Hi, Elitebook Folio 9470m will not turn on.  The power light on the power button is white, the power light on the front edge of the laptop is white, and the battery/charge indicator light is flashing alternating white and amber.

 

I tried booting without the battery, I tried holding down the power button by itself as well as power and mute simultaneously.  Any ideas?  Thank you

13 REPLIES 13
visruth
Level 15
13,019 12,958 1,700 3,967
Message 2 of 14
Flag Post
HP Recommended
Hi,


Do a hard reset: http://support.hp.com/in-en/document/c01684768

I am suspecting issue AC adapter, power connector or board.

To rule out, is the laptop powering on with battery alone? What do you get?

What about with another AC adapter? Another power outlet?


Follow this article: http://support.hp.com/in-en/document/c01732674


Regards

Visruth
0 Kudos
jceo
Author
Level 2
20 17 1 0
Message 3 of 14
Flag Post
HP Recommended

Hi Dean,  Thanks for the tips.  I tried everything.  I tried two different AC adapters and two different fully charged batteries.  One was from a known working laptop of the same model.

 

Either battery will make the charge/battery light flash as mentioned, even when not plugged in to AC power.  Same with the chargers.  Any more ideas?  Thanks

 

 

0 Kudos
visruth
Level 15
13,019 12,958 1,700 3,967
Message 4 of 14
Flag Post
HP Recommended

You're welcome.

Only one more thing to do:

Dust out through vents. Any chance of overheating?
http://support.hp.com/in-en/document/c01657439

If that's not working definitely power connector issue where cord plug into notebook or board failure.


Get it checked from certified HP technician or good local technician.

0 Kudos
bubler
Level 4
71 65 1 21
Message 5 of 14
Flag Post
HP Recommended

Have one computer with the exact same problem.

I'm guessing it's a hardware problem, but as there's no warranty left, so it's not much to do.

0 Kudos
just_a_username
Level 1
6 4 0 1
Message 6 of 14
Flag Post
HP Recommended

i have had the same issues on two different 9470m and it is a real problem, one was like new. 

 

i have done the following:

new adapter,

new ram,

new cmos battery,

new motherboard

as far as countless other things

 

the new mobo seemed to fix it but just a month down the line the same thing started happening again.

 

I have replaced the thermal compound, to see if it was an issue with oe thermal paste and no luck.

 

the weirdest thing is it will randomly start working a week later, a month later, not touching the computer.

 

i dont know what it is and the technical support is basically useless.

0 Kudos
TechieLover
New member
1 1 0 0
Message 7 of 14
Flag Post
HP Recommended

OMG that was such an easy fix. I got a can of compressed air and cleaned the fan from outside of the laptop. I didn't open it up (HP 840g 10 screws) and it booted right up. Thank you so very much Mr. Volenteer! I fixed it in 2 minutes with no expense. I will remember THAT

0 Kudos
Remdale
Level 1
3 3 0 3
Message 8 of 14
Flag Post
HP Recommended

I found out this strange thing happens when I connect the main keyboard cable and then I attach power cord or battery. Then the laptop turns on by itself without pressing the power button and I get the power led blinking. Then if I disconnect the main keyboard cable again, attach the battery and then connect the keyboard again, everything works fine. It would be working fine till the battery dies. Then I would have to repeat the same steps again. How can it be explained?? Probably it's because of the bad contact with the keyboard controller. Maybe it has something to do with PowerGood signal.
But one thing is really weird here is the fact that the laptop turns on by itself when you attach the battery or AC for the first time. Probably the Power IC is dying

Sohansr9
New member
3 2 0 0
Message 9 of 14
Flag Post
HP Recommended

I'm facing this problem too. Still i can't start my laptop attaching the biuld in key board. Please help me. Have you any idea?     

0 Kudos
Remdale
Level 1
3 3 0 3
Message 10 of 14
Flag Post
HP Recommended

It worked out for me. Probably there's an issue with something else in your case. Just connect the keyboard after you attach the battery. The laptop should be off when attaching the keyboard.

I don't have the laptop anymore, so I cannot tell you more.

Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation