cancel
Showing results for 
Search instead for 
Did you mean: 
The HP Calculator Community Message Board is moving. While we prepare for the move, we are unable to accept new postings. During the move, you can look for help from other users by visiting https://www.hpmuseum.org/ . Or if you need technical support for your calculator visit: HP Calculators. .
amil56
Level 2
22 20 1 0
Message 1 of 12
687
Flag Post

Solved!

Access denied when trying to initialize disks

HP Recommended
Z420
Microsoft Windows 10 (64-bit)

Hi, I'm trying to use 2 Seagate SAS SSDs I've purchased.

I'm using this SAS adapter:

HP SAS Adapter 

 

I've managed to see both disks using the RAID utility upon startup and defined them as RAID 0.

When I enter the bios I can't see the disks in the device configuration. I can see them in the Boot Order menu.

My SATA mode is set to RAID+AHCI in the BIOS as well,

 

When Windows start up and I open disk management I see 2 new disks with no information that needs to be initialized. 

When I try to initialize them I get "access is denied" message (both MBR & GPT).

 

What am I doing wrong?

 

Thanks, Amil

1 ACCEPTED SOLUTION

Accepted Solutions
amil56
Author
Level 2
22 20 1 0
Message 12 of 12
Flag Post
HP Recommended

Hi guys,

 

Wanted to share some good news alongside with contributing back to the community after all the assistance I got here.

So my short story went like this:

 

I bought an open box Z420 in order to create a Chia crypto plotter. 

After building my WS with a 20 thread CPU (e5-4657l v2) , the NVME (2TB PNY pci.e 3) and required RAM (64 GB 1866MHz which I don't really use now)I got really low results. The WS didn't handle the parallelism I was expecting, CPU wouldn't reach high utilization and production was quite low.

The recommendation here was to change the NVME with enterprise level SSDs.

 

I found 2 SSDs from a seller who didn't really know what he's holding (bought 2 1TB seagate 12GB/s SSDs for just a bit more than 300$). I also bought the mentioned LSI raid adapter.

 

So after dealing with it for a week I found the issue - the problem was that these SSDs are SED (hardware level encryption) and apparently cannot be used before re-formatted with SED info.

 

I used SeaTools (application by Seagate to monitor, test, format etc.. their disks) in order to "SED format" them using a 32 characters string printed on their sticker.

 

After formatting them I was able to create a RAID 0 volume from the both of them and it's working flawlessly!!! 🙂

 

Using a new app for Chia plotting I'm now able to better utilize my CPU and can create 3 times more plots a day that I could in my previous setup and app.

 

The SSDs reach read/write speeds of almost 1GB/s (and that's while using a 6GB/s raid controller, I guess I could have reach higher speed with 12GB/s controller, I don't think that I'll upgrade).

 

Many thanks to all of you trying to help 🙂

View solution in original post

Was this reply helpful? Yes No
11 REPLIES 11
DGroves
Level 11
4,786 4,065 450 928
Message 2 of 12
Flag Post
HP Recommended

raid o when working correctly will show up at the OS level AS ONE DRIVE, the bios however will show two devices configured as raid 0 the total drive capacity combined must be less than 3TB for the boot device (actually 3.8 TB) and for the early (pre zx40) systems legacy mode is preferred over GPT for the boot drive

 

a non booting data drive can be any size if using GPT format on it

 

the directions linked below for the zx00 series applies to the zx20 series also

 

https://support.hp.com/us-en/document/c02815117

Was this reply helpful? Yes No
amil56
Author
Level 2
22 20 1 0
Message 3 of 12
Flag Post
HP Recommended

Thanks DGroves,

 

I guess the instructions you pointed out would work if these were SATA SSDs.

I've connected 2 1TB SAS SSDs (Seagate ST960FM0013).

 

I also Use LSI Utility and not the BIOS one (since it's SAS).

 

When I enter the LSI utility I see the 2 connected disks, select both of them for RAID0 but then the volume is not created and I see no error message 😞

 

My current guess is that maybe I need to flash the adapter for a newer firmware.

The problem is that all the link I found here in the community forum are broken.

 

Can someone assist me with locating a guide/download of how to flash a firmware to a LSI  SAS2 2308 Mustang adapter?

 

Thanks,

Amil

Was this reply helpful? Yes No
joselso
Level 4
111 90 5 17
Message 4 of 12
Flag Post
HP Recommended

From the link you provided in your first post it turns out that you are using LSI 9205 4i4e SAS controller.

I suggest you consult Broadcom support website for detailed data and software/firmware downloads for your LSI controller.

Start at the following URL: https://www.broadcom.com/support/download-search

In Product Group select Legacy Products. Then, in Product Family select Legacy RAID Controllers. Then in Product Name write LSI and from the list select LSI SAS 9205-8e which is a similar version of your LSI controller.

Then, in Asset Type select All and press Search. You will be able to download various documents that explain the use of your LSI controller, and download firmware and drivers suitable.

 

Was this reply helpful? Yes No
amil56
Author
Level 2
22 20 1 0
Message 5 of 12
Flag Post
HP Recommended

Sorry, I put the wrong link..

My Controller is the 9217 4i4e.

 

I might running the wrong driver but that doesn't explain why I can't create a volume using the LSI utility..

I'm afraid the SSDs are not compatible with the controller 😞

Was this reply helpful? Yes No
joselso
Level 4
111 90 5 17
Message 6 of 12
Flag Post
HP Recommended

OK, for your Controller do the following search in the Broadcom Support link I gave you:

Product Group: Legacy Products, Product Family: Legacy Products, Product Name: SAS 9217-4i4e Host Bus Adapter, Asset types: All

Press Search.

In Search Results page press Expand All, and see what items - user guides, white papers, firmware and drivers downloads etc. are useful for your SAS 9217-4i4e controller (containing 2308 chips as you mentioned).

 

In particular you may find among the items offered in the search results page these PDF documents useful:

PCI Express to 6Gb/s SAS HBAs User Guide

(contains detailed hardware description of your 9217-4i4e Host Bus Adapter, among others);

 

SAS-2 Integrated RAID Solution User Guide

(contains instructions for use of LSI SAS Controller containing LSISAS2308 that you referred to in your post).

 

SAS9217-4i4e Product Brief

etc.

Was this reply helpful? Yes No
amil56
Author
Level 2
22 20 1 0
Message 7 of 12
Flag Post
HP Recommended

Thanks Joselso,

 

I did the search you offered and manage to realize that I have the latest firmware. 

I expanded all and searched for 2308 & 9217 and couldn't find anything relevant.. (I still don't get what is 2308, this is also how it appears in windows device manager in the storage controller devices)

 

Could it be that everything is OK on my system except for the SSDs which are dead?

When I try to format them using the LSI Configuration Utility is fails.

When I try to create a RAID 0 volume it fails.

When I try to initialize them from windows disk management it also fails.

 

Can it be that the SSDs are not working and that's it?

 

The only thing strange to me is when I use smartmontool I get information that shows like the disk is OK: 

C:\Program Files\smartmontools\bin>smartctl -a /dev/sda
smartctl 7.2 2020-12-30 r5155 [x86_64-w64-mingw32-w10-20H2] (sf-7.2-1)
Copyright (C) 2002-20, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Vendor:               SEAGATE
Product:              ST960FM0013
Revision:             C106
Compliance:           SPC-4
User Capacity:        960,197,124,096 bytes [960 GB]
Logical block size:   512 bytes
Physical block size:  4096 bytes
LU is resource provisioned, LBPRZ=1
Rotation Rate:        Solid State Device
Form Factor:          2.5 inches
Logical Unit id:      0x5000c50030161b0b
Serial number:        Z87130560000822150Z3
Device type:          disk
Transport protocol:   SAS (SPL-3)
Local Time is:        Thu Jul 01 22:05:02 2021 JDT
SMART support is:     Available - device has SMART capability.
SMART support is:     Enabled
Temperature Warning:  Enabled

=== START OF READ SMART DATA SECTION ===
SMART Health Status: OK

Percentage used endurance indicator: 7%
Current Drive Temperature:     47 C
Drive Trip Temperature:        70 C

Accumulated power on time, hours:minutes 16804:57
Manufactured in week 42 of year 2016
Specified cycle count over device lifetime:  10000
Accumulated start-stop cycles:  385
Elements in grown defect list: 0

Vendor (Seagate Cache) information
  Blocks sent to initiator = 562375382
  Blocks received from initiator = 981726741
  Blocks read from cache and sent to initiator = 1750053742
  Number of read and write commands whose size <= segment size = 525444815
  Number of read and write commands whose size > segment size = 12475577

Vendor (Seagate/Hitachi) factory information
  number of hours powered up = 16804.95
  number of minutes until next internal SMART test = 5

Error counter log:
           Errors Corrected by           Total   Correction     Gigabytes    Total
               ECC          rereads/    errors   algorithm      processed    uncorrected
           fast | delayed   rewrites  corrected  invocations   [10^9 bytes]  errors
read:   3164703584        0  12278475  3164703584          0     182804.974           0
write:         0        0         0         0          0     108261.564           0
verify:  3418515        0      1671   3418515          0          1.893           0

Non-medium error count:        0

No Self-tests have been logged

 

Was this reply helpful? Yes No
joselso
Level 4
111 90 5 17
Message 8 of 12
Flag Post
HP Recommended

To clarify: in the SAS9217-4i4e Product Brief it is stated that the PCI Express card LSI SAS 9217-4i4e is based on an integrated-circuit chip LSISAS2308 SAS controller which is installed on the card. The relationship between the LSISAS2308 controller and the 9217-4i4e card is further explained in the PCI Express to 6Gb/s SAS HBAs User Guide on pages 5 and 38.

 

Note that on selected HP Z Series workstations (Z820, Z840), LSI SAS 2308-4i Integrated SAS Controller is preinstalled on the workstation motherboard. Other HP Z Series workstations (your Z420 included) are capable of accepting and accommodating the LSI 9217-4i4e 8-port SAS 6Gb/s RAID Card, to be installed by the user.

 

 As to the difficulty in getting the controller and the SSD's going together, I suggest you read the section:

Integrated LSI 2308 or LSI SAS 1068E or Optional 9212-4i or LSI 9217-4i4e or LSI 3041E Logic Configuration (SAS) Controller   in HP publication Z Series Workstation - Detecting and Fixing a Hard Drive Failure in the RAID Controller Utility

in URL: https://support.hp.com/gb-en/document/c04474148

 

Also, make sure you follow the steps detailed in Chapter 3 of SAS-2 Integrated RAID Solution User Guide correctly.

 

Was this reply helpful? Yes No
amil56
Author
Level 2
22 20 1 0
Message 9 of 12
Flag Post
HP Recommended

Thanks Joselso,

 

So I've replaced the SAS SSDs with 3 WD Blue SATA 1 TB HDDs and managed to see them in windows. The thing is that even after creating a volume from the 3 of them I saw 2 of them as separate volumes in windows and the 3 one was unallocated and I couldn't do anything with it,

 

I then formatted the 3 of them using the LSI utility (almost 2 hours per each drive), recreated the volume using the utility and now I see in windows 1 disk of 3 TB.

 

Could it be that I just need to format the SAS SSDs properly. Since the LSI utility failed to format them is there another tool I can use? maybe smartmontool?

 

BTW - I contacted Seagate and according to them after reviewing the serial they told me that those disks are OEM and might have different characteristics and that I should contact the vendor they were pooled our of its machine (I don't know the vendor).

 

Thanks,

Amil  

Was this reply helpful? Yes No
joselso
Level 4
111 90 5 17
Message 10 of 12
Flag Post
HP Recommended

Well, now you have good evidence that your LSI controller is, after all, capable of configuring RAID on disk drives. It may indicate that its firmware is of the IR ('Integrated RAID') type, as it should be for RAID capability.

 

As to SSD's installation and formatting, I recommend that you read Seagate short publication SAS Solid State Drive Installation Instructions, URL:

https://www.seagate.com/em/en/support/kb/sas-solid-state-drive-installation-instructions-005705en/

 

BTW, it turns out that, not only are your SSD's OEM, but your LSI controller, too, is OEM, as stated in this URL:

https://www.servethehome.com/lsi-9207-9217-hbas-sas2308-6gbs-sas-sata-pcie-30/

 

So, just as you heard from Seagate, OEM devices are often different in characteristics from the 'Retail' version, mainly in their firmware versions, and this may sometimes cause difficulties in installing them in new installations.

 

Also, OEM SSD's that were pulled out of a server may have a short life span left, because of the huge number of Read/Write cycles they have already undergone in the server.

 

 

Was this reply helpful? Yes No
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation