• ×
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.Windows 11 Support Center.
  • post a message
  • ×
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.Windows 11 Support Center.
  • post a message
HP Recommended
T640
Other

Was wondering if its possible or how I would go about installing an old version of Firefox on an HP T640.  Looking for Firefox 50 or 51.  I've found the files on HP FTP servers but haven't had much luck installing the files.  Maybe because they were meant for ThinPro version 5?  

3 REPLIES 3
HP Recommended

@jordonc 

 

No idea how / if - I can point you to the mighty Firefox archives:

 

Firefox Archives

 

There are a number of both  "50.x" and "51.x" favored versions.

 

Select the version you want, Look for the OS and subsection needed.

 



Thank you for participating in the HP Community Forum.

We are a world community of volunteers dedicated to supporting HP technology.

 

Dragon-Fur

HP Recommended

Thanks.  The specific file extensions for the the ThinPro OS is .xar.  I have found an old HP FTP repoisitory of the files.  Just not having much luck installing.  Was looking to see if anyone with HP Thin Client experiance has done this. I called HP but their support seemed confused with the question so I gave up

 

ftp://ftp.hp.com/pub/tcdebian/updates/5.2/service_packs

HP Recommended

@jordonc 

 

Eidts - Added path to newer ThinPro Service Pack folder as FYI

 

You are welcome.

 

You are correct - the updates in that service_pack folder are intended for a different version of ThinPro.

 

All the .cva and .txt files provide the necessary descriptions.

 

For those reading: 

  • .cva files are text based - open with NotePad, for example.
  • Newer versions of Firefox are available - check the versions in the service pack folder for your OS.

                      One example, ftp://ftp.hp.com/pub/tcdebian/updates/7.0.0/service_packs/

                                                Firefox-52.9.0esrhp1b-ThinPro-7.0.txt

 

 

You might be able to hand install one of the updates in compatibility.

 

You are correct again - I am not the one to tell you how to edit the package (if it would even compensate for the wrong OS version) nor can I tell you definitively how to force the older .xar package on an unwilling (and newer) OS.  

 

Too many years between now and my IT days.

 

In the past, when I have needed a refresher or wanted to dig a bit deeper into any type of task, I have checked various other communities.  One example:  spiceworks

 



Thank you for participating in the HP Community Forum.

We are a world community of volunteers dedicated to supporting HP technology.

 

 

Dragon-Fur

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the <a href="https://www8.hp.com/us/en/terms-of-use.html" class="udrlinesmall">Terms of Use</a> and <a href="/t5/custom/page/page-id/hp.rulespage" class="udrlinesmall"> Rules of Participation</a>.