cancel
Showing results for 
Search instead for 
Did you mean: 
MassimoB73
New member
2 1 0 0
Message 1 of 7
6,117
Flag Post

HP Z420 USB3.0 Windows 10

HP Recommended
HP Z420
Microsoft Windows 10 (64-bit)

Dear sir,

I've the problem that i can not see USB3.0 device in my Z420 workstation; i've seen in the forum the same problem, i try to install the Texas USB3 Host driver, but installer software give me the message that "The operating system is not adequate for running TI USB3 Host Driver". I've Windows 10 Pro 1709 build.

I've installed all the latest driver/software/BIOS...

Can you help me ? 

Best Regards,

Massimo

 

6 REPLIES 6
mdklassen
Level 12
11,043 11,017 577 1,697
Message 2 of 7
Flag Post
HP Recommended

I found the article:

 

SUPPORT COMMUNICATION- CUSTOMER ADVISORY -- Advisory: HP Z1 / Z420 / Z620 / Z820 - USB 3.0 Device No...

 

from April 2012.

 

stating:

 

Method 2: Install Texas Instruments IOI USB 3.0 2+2 Port PCIe Drivers Version 1.12.24.0 or later.
HP has written SoftPaq SP57314 that resolves the issue. Download the SoftPaq and read the instructions carefully before proceeding.  SoftPaq SP57314 may not be the latest available version of the software.

______________

 

That driver seems to be applicable to Windows 7, not your Windows 10 system.

 

I looked at HP's FTP-site: ftp://ftp.hp.com/pub/softpaq/sp57001-57500/

but 'SP57314' is not found in that directory. 

Weird!

 

 

 

0 Kudos
DGroves
Level 11
4,508 4,491 411 943
Message 3 of 7
Flag Post
HP Recommended

windows 10 has native (generic) usb 3.0 drivers that do work with the onboard usb 3.0 ports

 

if windows is not seeing the usb 3.0 ports then you have a OS coruption or a hardware/bios config issue

 

since you have not provided information on the driver you are trying to install i can not be more specific than to say it appears that you are trying to install the wrong driver or that somehow you have previously installed a incorrect driver

for this device

 

you might want to try the steps in the link below:  (also applies to win 10)

 

http://www.thewindowsclub.com/how-to-remove-old-unused-device-drivers-in-windows-7

0 Kudos
SDH
Level 10
2,278 2,232 211 659
Message 4 of 7
Flag Post
HP Recommended

To the OP..... where exactly did you get the Texas Instruments USB3 chipset installer you used for your Windows 10 Pro 64 bit build?

0 Kudos
MassimoB73
Author
New member
2 1 0 0
Message 5 of 7
Flag Post
HP Recommended

I didn't get any installer for TI chipset... I had only installed Win10 and all the software update from HP site.

I noticed now that i cannot see the TI USB controller in Windows Device Manager. 

 

 

0 Kudos
SDH
Level 10
2,278 2,232 211 659
Message 6 of 7
Flag Post
HP Recommended

There is a bit of a mess here to wade through......

 

Google search for "Z420 drivers" and go to the top HP link there.  It will detect your W10 build assuming that is how you get there.  It defaults to the OS you are connecting from.

 

For me from a W7Pro64 workstation it detects that, but there are no official HP TI USB3 drivers for W10, or W8.1, but there are for W8.0 and W7.

 

You'd think the W8 driver service pack was more recent than that for W7, but no.  The W7 drivers are from 2014 but the W8 drivers are older, from 2013.  W8 drivers are 1.0.0.0, but the provided W7 drivers are 1.16.3.0 (more recent).

 

You want the later W7 HP SoftPaq... SP65043.   This latest driver SoftPaq will automatically load the proper items for a 32-bit or a 64-bit install.  How to get those if you have a W10 link to the HP driver site?

 

Simply use "Change" in the light blue bar to convert over to Windows 7 64-bit and then click the dark blue "Change" button inside the lighter blue area.  Go to "Driver-Controller" section and download the SP65043 from there.  Run it under W10 and you should be good to go.

 

I'll check one of our W10Pro64 ZX20 builds to see if the W10 upgrade process updated the TI USB3 drivers at all.

 

 

 

 

 

 

0 Kudos
SDH
Level 10
2,278 2,232 211 659
Message 7 of 7
Flag Post
HP Recommended

To clarify..... I've personally used those later 1.16.3.0 HP Texas Instrument "2x2" HP drivers for all installs on the Z420/Z620/Z820 workstation series plus on the HP TI based USB3 PCIe card I've posted about in the forum (that brought USB3 to the earlier Z400/Z600/Z800 workstations and even xw workstations).

 

The "2x2" designation for the PCIe card and for the ZX20 workstations refers to the chipset's ability to drive 4 total USB3 ports.... two out front and two at the rear face of the workstation.... the same TI chipset is on the motherboards and on the card.

 

I only use the SP65043 HP SoftPaq for the install, and use that for all OS installs including when I experimented with W8.0 and W8.1.  That installer works for both 32- and 64-bit installs, and we now are only using W7Pro64 or W10Pro64.

 

Finally, for installing drivers for the card always install it and power it before you install the drivers.  The installer cannot see parts of the card/chipset if you don't do that as your first step.  Some power to the card comes up from the PCIe slot, but it needs its supplemental power cable to be connected for all voltages to be supplied.

0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation