cancel
Showing results for 
Search instead for 
Did you mean: 
dvrolf
New member
2 1 0 0
Message 1 of 3
412
Flag Post

Solved!

HPDM sees other network as NAT but is not actually NAT, this puts the Agent in Pull mode

HP Recommended
HPDM
Microsoft Windows Server 2016

We have HPDM running on a local netwerk.

With multiple VPN connections to other branches

All of our 172.x.x.x branches have the HPDM Agent in Push mode

 

But we have 5 192.x.x.x branches that HPDM sees as being behind NAT.

This puts the HPDM agent in Pull mode, which by default only pulls once per day (can be changed to each 30 minutes but that still means a command like reboot or staged sequences would take forever)

 

These connections are not behind a NAT. 

How can change this behaviour of HPDM and force the Agents into Push mode? 

1 ACCEPTED SOLUTION

Accepted Solutions
Chen_HPDM
Level 7
Level 7
504 502 51 84
Message 2 of 3
Flag Post
HP Recommended

Hi Dvrolf,

 

HPDM make this option availabe start from HPDM 4.7 SP10. If this is the version you're using, then please go to ..\HP Device Manager\Gateway\Gateway.cfg, change the value of JudgeAgentMode to "no". <JudgeAgentMode>no</JudgeAgentMode>
Save the change and restart the Gateway.

 

One more thing, you can set the pull interval to 1 minute as minimum - try tying through keyboard instead of just selecting those default values.

 

I am an HPI Employee.
My opinions are my own, and do not express those of HPI.
**Click the White Thumbs Up Button on the right to say Thanks**

View solution in original post

Was this reply helpful? Yes No
2 REPLIES 2
Chen_HPDM
Level 7
Level 7
504 502 51 84
Message 2 of 3
Flag Post
HP Recommended

Hi Dvrolf,

 

HPDM make this option availabe start from HPDM 4.7 SP10. If this is the version you're using, then please go to ..\HP Device Manager\Gateway\Gateway.cfg, change the value of JudgeAgentMode to "no". <JudgeAgentMode>no</JudgeAgentMode>
Save the change and restart the Gateway.

 

One more thing, you can set the pull interval to 1 minute as minimum - try tying through keyboard instead of just selecting those default values.

 

I am an HPI Employee.
My opinions are my own, and do not express those of HPI.
**Click the White Thumbs Up Button on the right to say Thanks**

View solution in original post

Was this reply helpful? Yes No
dvrolf
Author
New member
2 1 0 0
Message 3 of 3
Flag Post
HP Recommended

Bless you Chen_HPDM!!

 

I have opened a case with HP more than a week ago, hoping the technical support would just give me a quick solution like this.

But after being on the phone for an hour, I was asked to fill in a weird Excel sheet so they could scale up to some other department, my filled in Excel was not accepted because I did not write down RDP versions and lots of other either non-existent or non-related stuff.

 

I just changed the value (%programdata%\HP\... b.t.w. )  and restarted the gateway service.

One of the devices that said Pull before now shows Push and it no longer incorrectly says the device is behind NAT.

 

I am still waiting on a reply from the HP support team .... 

Was this reply helpful? Yes No
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation