cancel
Showing results for 
Search instead for 
Did you mean: 
Terveg Top Student
Top Student
6 3 0 0
Message 1 of 5
156
Flag Post
HP Recommended

Solved!

Z840 raid not recognized by Win7

Z840
Microsoft Windows 7 (64-bit)

I have added two hdd into hdd/sas slots after i have win7 installed. OS does not recognise this. What should I do to fix this? And is there any way to use those bays but without configuration of raid? Just two normal drives, ultimately raid 1.

4 REPLIES 4
Distinguished Professor
Distinguished Professor
2,767 2,728 240 538
Message 2 of 5
134
Flag Post
HP Recommended

Solved!

Z840 raid not recognized by Win7

the z840 does have a onboard LSI raid controller,  so are you using it or using the OS supplied software raid

 

https://techridez.com/blog/configure-raid-hp-z840-workstation/

 

the HP links below while for the z800/z820  also applies to the z840 for the most part

 

https://support.hp.com/us-en/document/c02815117

 

https://support.hp.com/us-en/document/c01722374

Reply
0 Kudos
Terveg Top Student
Top Student
6 3 0 0
Message 3 of 5
124
Flag Post
HP Recommended

Solved!

Z840 raid not recognized by Win7

I made raid 1 by using LSI controller. However, i did this after Win7 installation and system does not see raid at all (raid is only visible in bios). I have tried to remove it and recreate again. With no raid, both hdds do not appear and moreover, Win7 doesnt start...just hangs at windows logo stage and gives logon sound on background built in speaker. How to fix this?

Is there maybe any other way to connect hdds via SATA? I guess then i need some power cables and sata cables in addition.

Reply
0 Kudos
Distinguished Professor
Distinguished Professor
2,767 2,728 240 538
Message 4 of 5
118
Flag Post
HP Recommended

Solved!

Z840 raid not recognized by Win7

have you acquired the LSI controller driver for windows 7?

 

this is necessary as win 7 does not have a built in driver for the  z840's embedded LSI 2308 SAS controller

 

and if booting from the lsi controller you must use the "F6" method of loading the driver during the win 7 setup

 

also have you installed the intel RSTe (enterprise) driver?

Terveg Top Student
Top Student
6 3 0 0
Message 5 of 5
103
Flag Post
HP Recommended

Solved!

Z840 raid not recognized by Win7

 Tnx Ia lot ! In the safemode, boot stopped at CLASSPNP.SYS. 

There was a driver conflict with Daemon tools, that i deleted through command prompt quickly. So first issue was solved. Next issue with invisible raid, and i have installed the proper driver from windows. Reboot, ctrl+c, and configured raid 1 once more. With next reboot, windows has initialized the raid drive. Second issue is solved. As i see now, there were two independent problems.

Reply
0 Kudos
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation