cancel
Showing results for 
Search instead for 
Did you mean: 
haliaeetus70
Level 1
9 7 0 0
Message 1 of 11
2,071
Flag Post

Help, No sound out of my HP w2207 monitor speakers??

HP Recommended
HP d4990y
Microsoft Windows 7 (32-bit)

Help, No sound out of my HP w2207 monitor speakers??  They where working last week before updates.  Under Device Manager there is a yellow mark that says, Multi Media Audio Controller.  I tried to update driver, but I guess I'm not getting the right one??   THANKS IN ADVANCE!!  Also when I goto control panel, manage audio devises, there is only one option and that is Realtek HDMI Output, no choice for just speakers??  I've done all windows updates and all driver updates, still no sound??  thanks again!!

10 REPLIES 10
Chimney_83
Retired
Retired
8,121 8,112 488 952
Message 2 of 11
Flag Post
HP Recommended

Greetings @haliaeetus70

 

Thanks for the post. 

 

I understand that you are not getting any audio from the speakers, is that right?

Kudos to you for trying to troubleshoot the issue on your own.

Not to worry, I will be glad to assist you. 

Have you run a diagnostics on your computer?

Have you tried to update all the drivers using HP Support Assistant?

 

Please open device manager from the Control Panel.

Expand "Sound, Video and Game Controllers".

Right-click on the audio driver and uninstall it. 

Run HP Support Assistant on your computer and it would help you install a new audio driver on your computer. 

Refer to this HP Article for assistance in using HPSA.

 

You can also refer to this HP guided troubleshooter for assistance. 

Did you check the aux cable from the desktop to your monitor?

 

Keep me posted. 

Chimney_83
I am an HP Employee

0 Kudos
haliaeetus70
Author
Level 1
9 7 0 0
Message 3 of 11
Flag Post
HP Recommended

Thanks for your response.  I've uninstalled and re-installed audio drivers a couple times, it wont install multimedia audio device?  Also I cant find a multimedia device to download.  I've downloaded HP Suport Assistant, I couldn't fix the problem either.  All cables are connected correctly.  Under Control Panel, Hardware and sound, manage audio devises there is only Realtek HDMI Output, no option for speakers.  ??

0 Kudos
Chimney_83
Retired
Retired
8,121 8,112 488 952
Message 4 of 11
Flag Post
HP Recommended

Thanks for the reply and trying the suggested steps. Did you try all the steps suggested in the guided troubleshooter? 

 

Did you run an audio test on your computer? Click here

 

Keep me posted. 

Chimney_83
I am an HP Employee

0 Kudos
haliaeetus70
Author
Level 1
9 7 0 0
Message 5 of 11
Flag Post
HP Recommended

thank you, the esc then f2 brings me to safe mode where there is no option for system tests. Once again there is no "Speakers" under manage audio devices Realtek HDMI Output only and under devive manager multimedia audio controller is checked that can not be updated from there.  Thanks you so much for your time, I use this computer for work and need to get the audio working, thanks again, Ron

0 Kudos
Chimney_83
Retired
Retired
8,121 8,112 488 952
Message 6 of 11
Flag Post
HP Recommended

Thanks for the reply and trying the suggested steps. 

 

Did you try to keep tapping ESC key on startup to check if your computer boots to the startup menu?

If the computer to boots to the startup menu, try to enter system diagnostics and try a system test.

 

However, as your computer is very old, there might not be UEFI diagnostics installed on your computer.

 

Give it a try and let me know if it worked.

 

Did you uninstall the audio drivers from device manager before using HPSA to update the driver?

 

Keep me posted. Good Luck.

 

Chimney_83
I am an HP Employee

0 Kudos
haliaeetus70
Author
Level 1
9 7 0 0
Message 7 of 11
Flag Post
HP Recommended

First of all thanks for hanging in here with me, I'm not a novice with computers but this one  I cant figure out.  I have uninstalled drivers before using HPSA, to no avail.  Using the ESC key on startup and any other F key does not take me to any menu that gives me an option for System Diagnostics.  I don't understand why there is no "Speakers" option under sound audio in device manager.  I understand this computer is old but it is lighting fast on line and on youtube videos, don't want to see her die..lol.   Thanks again Ron  

0 Kudos
haliaeetus70
Author
Level 1
9 7 0 0
Message 8 of 11
Flag Post
HP Recommended

Also kepps telling me no device driver for multimedia audio device... and I cant find one.

 

0 Kudos
A4Apollo
Retired
Retired
17,747 17,730 1,301 2,076
Message 9 of 11
Flag Post
HP Recommended

Hi! @haliaeetus70, I am the Mr.Robot. It looks like you were interacting with @Chimney_83, but he is out of the office today, so I'll take over from here.

 

I appriciate your efforts for trying out the steps.

 

As you mentioned the issue still persists after trying out the steps.

 

Have you tried checking with a different HDMI cable?

 

Try few steps recommended below.

 

Right-click on the sound volume icon in the lower right corner of Windows. A context menu will pop up.

 

Click Playback devices.

 

In the Playback tab, select Digital Output Device or HDMI option. Click Set Default and click OK. Then the HDMI sound output will be set as default.

 

If you do not see the Digital Output Device or HDMI option in the Playback tab, right click on the blank place, then click Show disconnected devices and Show disabled devices on the context menu.

 

Then set it as the default device.

  

If the issue still persists uninstall the audio driver from device manager and install the driver using HP recovery manager.

 

Refer this article to know how to restore drivers using HP recovery manager.

 

If the issue still persists try resetting the monitor to factory reset and check if it helps.

 

To restore the factory settings, access the OSD menu on the monitor, select Factory Reset, and then select Yes.

 

Refer the monitor user guide for more information.

 

If the solution provided worked for you, please mark accepted solution for this post.

 

Let me know if this helps!

Have a great day ahead! 🙂

 

Please click “Accept as Solution” if you feel my post solved your issue, it will help others find the solution.

                                                                                                                  

Click the “Kudos, Thumbs Up" on the bottom right to say “Thanks” for helping!

A4Apollo
I am an HP Employee

0 Kudos
haliaeetus70
Author
Level 1
9 7 0 0
Message 10 of 11
Flag Post
HP Recommended

Factory rest the monitor and changes cables, finnally found the multimedia device that has been missing.  I now have speakers and headphones under manage audio devices but it says they are unplugged??   and they are plugged in??  Do you think the sound card may be faulty??  Once again thanks soo much for your attention to this, I couldn't find anyone else to help me.  Ron

0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation