• ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • post a message
  • ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • post a message
Guidelines
We have new content about Hotkey issue, Click here to check it out!
Check out our WINDOWS 11 Support Center info about: OPTIMIZATION, KNOWN ISSUES, FAQs, VIDEOS AND MORE.
HP Recommended
t520
Microsoft Windows 7 (32-bit)

Hello, are here any HPDM experts, I'm out of ideas what the problem could be.

My Setup:

HPDM 5.0

Gateway, Repository, Console, Server all on the same Physical Server

I've got a t530 with Win10Iot64 (manually installed) - works with no Problems

I've got several t520's - one of them is manually installed with a newer Win7 Embedded Standard Version then the others.

The newer one works with no Problems. 

Now with the rest i have a Prproblem. They don't seem to get the Tasks from the gateway. 

What I've done so far: 

- entered manual DNS entry for _hpdm-gateway

- nslookup works on every PC within the Network

- updated Bios

- deactivated Firewall on Thin Client

 

Every Task i send to the old t520's gets stuck in the Gateway with status sending. 

 

Any help would be appreciated since I'm running on time here. Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
HP Recommended

I figured it out. Actually 1 hour after i posted this. But in my opinion it is kind of tricky. So for anyone in the future having the sam problem here is what I did:

 

It seems like the version of the Remote Agent, on the Windows 7 Embedded Standard Version which is stndard installed on the t520 when it's shipped isn't compatile with the HPDM 5.0. So i downloaded the newer Version of Windows 7 Embedded Standard (Sept. 2017) from the HP ThinUpdate Tool and installed it manually on my own Client. There I configured everything and updated the Agent via HPDM. Then i copied the Image via HPDM to a Template. Now you have to do everything in exact this order: 

Start the Task on the clients you want to deploy the Image, now the Task is stuck in the Gateway because the Remote Agent isn't able to communicate with the Gateway. You have to update it to the Agent Version which can be found in the HPDM Repository under Repository/Agents/Win32.  Copy the Win32 Folder to the client and make a .cmd File in the same directory. 

Copy this into the .cmd and execute it.

 

net stop hpdmagent
timeout 1
copy .\HPDMAgent.exe c:\windows\temp
update c:\windows\xpeagent\hpdmagent.exe c:\windows\temp\HPDMAgent.exe 0
net start hpdmagent
PAUSE

 

It updates the Agent and then instantly pulls the Task from the Gateway. 

Note you can't do this before you ran the Task in the HPDM because then the Client gets categorised into the Win32 OS category and that one isn't able to deploy images. 

 

I don't know if it's a bug or I'm abusing something there but it works in the end. 

 

 

View solution in original post

1 REPLY 1
HP Recommended

I figured it out. Actually 1 hour after i posted this. But in my opinion it is kind of tricky. So for anyone in the future having the sam problem here is what I did:

 

It seems like the version of the Remote Agent, on the Windows 7 Embedded Standard Version which is stndard installed on the t520 when it's shipped isn't compatile with the HPDM 5.0. So i downloaded the newer Version of Windows 7 Embedded Standard (Sept. 2017) from the HP ThinUpdate Tool and installed it manually on my own Client. There I configured everything and updated the Agent via HPDM. Then i copied the Image via HPDM to a Template. Now you have to do everything in exact this order: 

Start the Task on the clients you want to deploy the Image, now the Task is stuck in the Gateway because the Remote Agent isn't able to communicate with the Gateway. You have to update it to the Agent Version which can be found in the HPDM Repository under Repository/Agents/Win32.  Copy the Win32 Folder to the client and make a .cmd File in the same directory. 

Copy this into the .cmd and execute it.

 

net stop hpdmagent
timeout 1
copy .\HPDMAgent.exe c:\windows\temp
update c:\windows\xpeagent\hpdmagent.exe c:\windows\temp\HPDMAgent.exe 0
net start hpdmagent
PAUSE

 

It updates the Agent and then instantly pulls the Task from the Gateway. 

Note you can't do this before you ran the Task in the HPDM because then the Client gets categorised into the Win32 OS category and that one isn't able to deploy images. 

 

I don't know if it's a bug or I'm abusing something there but it works in the end. 

 

 

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the <a href="https://www8.hp.com/us/en/terms-of-use.html" class="udrlinesmall">Terms of Use</a> and <a href="/t5/custom/page/page-id/hp.rulespage" class="udrlinesmall"> Rules of Participation</a>.