• ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • post a message
  • ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • post a message
Guidelines
Any failures related to Hotkey UWP service? Click here for tips.
HP Recommended
HP Z25xs G3 QHD USB-C DreamColor Display
Microsoft Windows 10 (64-bit)

Heya all, 

 

Has anyone managed to set up MST over DP1.2 with this monitor (or even similar e.g. Z27xs)?

 

I'm having a real hard time getting things to work on my ZBook 14 G1 (which has the AMD M4100 which supports MST 1.2) and the Ultra Slim Docking Station 2013.

 

From what I have seen on the new Z25xs firmware (latest 1.0.13.0 Rev.A) -  there was improved MST capability and manual On/Off -  However, when set to On (or Auto with DP out connected) it overrides the DP Mode to 1.4.

 

When everything is connected, either the OS doesn't detect the second monitor and the display  is duplicated (DP 1.2 no MST on OSD) OR is detects all the monitors (and shown as Z25xs in Device Manager), but the display is distorted (MST set to Auto/On, and DP overridden to 1.4). It's kinda like a retro game, with RGB vertical lines and a grayscale image - doesn't look healthy that's for sure. Either that not No signal but still detected in the OS

 

My understanding is the 2x DP on the back of the dock use the AMD GPU. I do have an issue with the integrated GPU (that's another story - code 43, possibly a recent Windows Update broke it as it works on Ubuntu) so I can only use the ports on the dock not the one on the side of the laptop.

 

Yes - the dock firmware is updated - 2.33.004 REV: A. Also tried other cables and checked Pin 20 not wired. Issue persists on all monitors (I actually have 3.. so really wanting MST to work so I can hook them all up to the dock)

 

I've had to revert back to drivers from the AMD site from 2015 (15.201.2401) which uses the old AMD Catalyst Control Centre. The CCC actually shows that the monitor is MST capable and displays the DisplayPort diagnostics in the advanced view when connected. I've tried numerous drivers, including latest official from HP and AMD ones that don't officially support the M4100 but do support the Radeon HD 8000m series (which I believe is similar?). Either way.. the 2015 one seems to work the best with just getting DP to work. Also -DP-HDMI works perfectly, regardless of driver.

 

I haven't tested the MST on Ubuntu yet, but definitely no retro display with DP.

 

So, if someone could confirm they have DP 1.2 MST working or not on this display. If so, I guess I'm reinstalling Windows 😒

 

 

 

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the <a href="https://www8.hp.com/us/en/terms-of-use.html" class="udrlinesmall">Terms of Use</a> and <a href="/t5/custom/page/page-id/hp.rulespage" class="udrlinesmall"> Rules of Participation</a>.