cancel
Showing results for 
Search instead for 
Did you mean: 
  • ×
    Information
    Need Windows 11 help?
    Check documents and videos on compatibility, FAQs, upgrade information and available fixes.Windows 11 Support Center.
  • post a message
  • ×
    Information
    Need Windows 11 help?
    Check documents and videos on compatibility, FAQs, upgrade information and available fixes.Windows 11 Support Center.
  • post a message
Check out our WINDOWS 11 Support Center info about: OPTIMIZATION, KNOWN ISSUES, FAQs, VIDEOS AND MORE.
Ivanowitch
Level 1
5 2 0 1
Message 1 of 7
8,885
Flag Post

No PXE in UEFI mode HP ProDesk 400 G4

HP Recommended
HP ProDesk 400 G4 SFF
Microsoft Windows 10 (64-bit)

Situation: brand new HP ProDesk 400 G4 SFF. Received one for testing in company network.

 

Problem: we use SCCM 2012R2 to install our systems. Have had no problems with PXE booting systems.

 

- booting in UEFI mode - choosing IPV4 Network. Network boot starts. SCCM server receives request (activity LOG file). No further reaction. PXE gets timeout and exits.

- booting legacy mode - Network boot starts. Activity in LOG file. PXE boot continues. No single problem in PXE booting.

 

Thus, system is fine booting in Legacy mode, but fails UEFI mode.

 

Other systems (HP ProDesk G3 SFF) - no problems with legacy or EUFI.

 

Only one BIOS available on HP site. It's the same as installed on the system.

 

Has anybody run into this problem and (even more important) somebody with a sollution?

 

Thank you in advance.

6 REPLIES 6
SYSMASTER
New member
2 2 0 1
Message 2 of 7
Flag Post
HP Recommended

Hey, check your Bios!

00.02.04 Rev.A is current

Fixes issue where UEF PXE boot connection fails with two different VLAN(subnet).
- Adds DeviceGuard HSTI support.
- Fixes issue where system hangs during restart test on Device Guard-enabled systems with SKL CPU.

Was this reply helpful? Yes No
Ivanowitch
Author
Level 1
5 2 0 1
Message 3 of 7
Flag Post
HP Recommended

Bios update does solve this problem.

Was this reply helpful? Yes No
SYSMASTER
New member
2 2 0 1
Message 4 of 7
Flag Post
HP Recommended

perfect 🙂

Was this reply helpful? Yes No
Julio_MTD
New member
1 1 0 0
Message 5 of 7
Flag Post
HP Recommended

Any news on this issue we also have G3's and G4's with no luck booting via PXE to SCCM.

HP Prodesk 400 g3 and g4

Any help appreciated

Was this reply helpful? Yes No
Ivanowitch
Author
Level 1
5 2 0 1
Message 6 of 7
Flag Post
HP Recommended

I assume other systems are functioning ok with PXE boot.

 

Updating the BIOS (as mentioned above) solved the problem for us.

 

Have you checked your smsts.log for errors? Tried importing one of the troubled systems manually so it's not identified as an unknown system, or are the systems already known in the SCCM database?

 

At what stage of the SCCM PXE boot do you run into problems?

Was this reply helpful? Yes No
mmovq
New member
1 1 0 0
Message 7 of 7
Flag Post
HP Recommended

Hi everyone, 

i am experiencing the same exact problem: we recently acquired 20 new HP ProDesk 400 G4 MT. BIOS version is P03_0207. 

They cannot PXE boot in UEFI mode while they boot just fine in legacy mode. 

We  spent a long time debugging the issue and came to the conclusion that this is caused by some UEFI bug. 

At the moment these 20 PCs are thus useless (as we rely on PXE boot). 

I urge to find a fix for this.

Was this reply helpful? Yes No
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation