Having trouble signing in? Try this!
Ask questions. Help others.
The HP Community is here for you.
Post new question
Question
Reply
 
Note on archived topics.
This topic has been archived. Information and links in this thread may no longer be available or relevant.
If you have a question create a new topic by clicking here, or click on "Post new question" above and select the appropriate board.
Intern
Posts: 18
Member Since: ‎10-08-2015
Message 1 of 10 (92,756 Views)
Accepted Solution

BIOS Refuses to Enable Legacy Boot

Product Name: HP EliteDesk 800G2 SFF
Operating System: Microsoft Windows 10 (64-bit)

I have been attempting to Enable Legacy boot and Disable Secure boot on this machine for a few days now.  My current BIOS version is N01 2.05 11/11/2015.  It is the oddest thing.  I am able to make some changes, save and have them succesfully change...but I cannot get legacy to enable and save.  Steps I have taken:

 

- Cleared Secure Boot Keys - Reset

- Selected Legacy Support Enable and Secure Boot Disable - Reset

- Go back to BIOS --> Boot Options -->Attempt to Uncheck UEFI Boot Order (Unable to) --> Check to see if Legacy Boot is available and its a no go

- Then I go back to the secure boot options and verify that none of my changes saved. 

 

I have tried rolling the Bios Version back to 2.04 but that didn't make any difference so I put 2.05 back on it.

 

I am attempting to get these machines to PXE boot to grab our school district's image, but I need Legacy boot enabled to do it.  After several attempts to get Legacy to enable I resolved to just use our Win7 Ent disk BUT can't do that as well as it says the "selected boot image did not authenticate."  Of course the fix I found for this was enable Legacy Boot....which I can't do.

 

 

I have looked through the forums and found a few possible solutions, but none of them have worked.  Please help!

Accepted Solution

Re: BIOS Refuses to Enable Legacy Boot

Thank you for the reply.  I ended up doing the following, which worked finally(not sure why):

- Updated BIOS back to V 02.05

- reset back to factory settings in the main menu

- back into bios, set password and ownership tag as needed by the school district i work for--->reboot

- back into bios disabled bootable devices usb and cd rom (as is school district tech policy)

- went to secure boot options and selected in the drop down "enable legacy and disable UEFI boot" -->reboot

- back to bios THIS TIME the check box next to legacy in the boot options menu was available.  I checked the box and was also able to uncheck UEFI boot -->reboot

- f12 to PXE boot and like magic it finally worked

 

Again, this is very similar to the process I tried in the begining the only difference was the amount of reboots it took to get it accomplished.  I did have a similar issue with another 800 G2 and no matter what I did it would not PXE boot so I rolled the bios version back to 02.04, restored factory settings and did the process I just oultined above.  AND IT WORKED on that machine.  It is an inconsistant issue we are having with the 50 or so 800 G2s our district purchased this last month.  

 

In any case we are able to get these machines to PXE boot using one of the two methods I just mentioned.  So we're good for now.  Thanks again for your reply.

View solution in context
Teacher
Posts: 52
Member Since: ‎12-11-2014
Message 2 of 10 (92,656 Views)

Re: BIOS Refuses to Enable Legacy Boot

Hello Customer,

 

Welcome and Thank you for posting your query on HP Support Forum

 

I understand that you are not able to set the Legacy Boot Mode.

 

Please try to create the BIOS Administrator Password and then try to change the settings.

 

****Click the Kudos Button on left to say Thanks****
Make it easier for other people to find solutions by marking a Reply 'Accept as Solution' if it solves your problem.

Thank You,
K B T 86
Although I am an HP employee, I am speaking for myself and not for HP

I am an HP employee
Intern
Posts: 18
Member Since: ‎10-08-2015
Message 3 of 10 (92,630 Views)

Re: BIOS Refuses to Enable Legacy Boot

Thank you for the reply.  I ended up doing the following, which worked finally(not sure why):

- Updated BIOS back to V 02.05

- reset back to factory settings in the main menu

- back into bios, set password and ownership tag as needed by the school district i work for--->reboot

- back into bios disabled bootable devices usb and cd rom (as is school district tech policy)

- went to secure boot options and selected in the drop down "enable legacy and disable UEFI boot" -->reboot

- back to bios THIS TIME the check box next to legacy in the boot options menu was available.  I checked the box and was also able to uncheck UEFI boot -->reboot

- f12 to PXE boot and like magic it finally worked

 

Again, this is very similar to the process I tried in the begining the only difference was the amount of reboots it took to get it accomplished.  I did have a similar issue with another 800 G2 and no matter what I did it would not PXE boot so I rolled the bios version back to 02.04, restored factory settings and did the process I just oultined above.  AND IT WORKED on that machine.  It is an inconsistant issue we are having with the 50 or so 800 G2s our district purchased this last month.  

 

In any case we are able to get these machines to PXE boot using one of the two methods I just mentioned.  So we're good for now.  Thanks again for your reply.

Honor Student
Posts: 2
Member Since: ‎03-02-2013
Message 4 of 10 (84,966 Views)

Re: BIOS Refuses to Enable Legacy Boot

I am not sure if you noticed on a reboot after changing enable legacy... there is a message to type the code.  If you had typed the code and enter on that reboot, it should have worked.  I myself did not read the code prompt until I had started to follow your steps.  I only had to do the one change and enter the code but I read the screen this time to see that it was there. 

Tutor
Posts: 5
Member Since: ‎01-23-2017
Message 5 of 10 (82,562 Views)

Re: BIOS Refuses to Enable Legacy Boot

Thanks Rambling-Jack! 

My issue was after "enable legacy boot..." I was attempting to use the number pad w/out enabling it with the number lock key... You can also use the number keys on your top horizontol row of keyboard - you can tell the number key input is working becuase the numbers will display on the bios screen. 

Read the Effing Manual!!!
Top Student
Posts: 1
Member Since: ‎03-29-2017
Message 6 of 10 (75,368 Views)

Re: BIOS Refuses to Enable Legacy Boot

That is exactly what was happening for me too.  The numlock key turns back off after saving the BIOS Secure Boot setting to Legacy, then saving and exiting BIOS.  The numlock turns off, and when prompted to enter the Secure Boot code, you're thinking that you have entered the code, but you really haven't.  

You should actually see the secure code parroted on the screen as you type it, if you don't see this happening, check your numlock.  The steps given above on the change process work, if you make sure to turn numlock back on.  At least it did for me.

Top Student
Posts: 1
Member Since: ‎10-10-2017
Message 7 of 10 (39,420 Views)

Re: BIOS Refuses to Enable Legacy Boot

Same problem here: HP EliteDesk 800 G3 TWR, unable to enable legacy mode (you can select the setting, but it does not get saved). Bios version 2.06.

 

Solution: Change the setting to "Legacy boot enable, secure boot disable" and press F10 to save and exit (and save before you exit of course).

Do NOT use the  apparently intended way to first click on "Main" and choose "Save and exit" there.

 

No Factory reset, Bios downgrade or password setting was necessary that way.

 

 

Tutor
Posts: 22
Member Since: ‎06-29-1998
Message 8 of 10 (17,334 Views)

Re: BIOS Refuses to Enable Legacy Boot

Thanks much!  Hitting F10 when in the Secure Boot Configuration enabled the Legacy Support and boot without UEFI.  That was quite frustrating.  I should have clicked the Help button as it does state "F10 Exit with Option to Save" so now I know what that means. 

 

-Russell

Honor Student
Posts: 2
Member Since: ‎10-02-2017
Message 9 of 10 (6,365 Views)

Re: BIOS Refuses to Enable Legacy Boot

Spent half a day trying to get this beast to boot to a legacy device. I can't believe it was something so simple as using the number keypad without turning on numlock. 

Student
Posts: 1
Member Since: ‎03-20-2018
Message 10 of 10 (4,270 Views)

Re: BIOS Refuses to Enable Legacy Boot

I had the same problem with the HP Prodesk 400G4. After creating a BIOS admin password my settings stuck and I could boot from the network.

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation