cancel
Showing results for 
Search instead for 
Did you mean: 
  • ×
    Information
    Need Windows 11 help?
    Check documents and videos on compatibility, FAQs, upgrade information and available fixes.Windows 11 Support Center.
  • post a message
  • ×
    Information
    Need Windows 11 help?
    Check documents and videos on compatibility, FAQs, upgrade information and available fixes.Windows 11 Support Center.
  • post a message
Daniel8372
New member
1 0 0 0
Message 1 of 7
965
Flag Post

HP Reverb G2 stopped working - No longer powers up

HP Recommended
HP Reverb G2
Microsoft Windows 10 (64-bit)

I bought an HP Reverb G2 which was working on a Lenovo Legion 5 (Ryzen R5, RTX 3060) and then suddenly stopped working and nothing seems to power it up anymore, Its turned into a rather expensive paper weight. The G2 has been used maybe 20 times since purchase and was also working in a Desktop PC with Ryzen 7 and MSI Mortar B550M motherboard though I had to buy an external USB hub for it to work in that setup as it refused to work through the USB though whether that is AMD or HPs fault is somewhat irrelevant. I have tried the hub with the Lenovo and it still doesn't even light up. The power on the external PSU is on as that is lit

 

I have since tried a Rift S and this is detected and works.

 

I have reinstalled all the Software and drivers for Windows Mixed reality. But this hasn't fixed it.

 

I have tried plugging it in to another windows PC with Intel chipset and it is not detected.

 

How do you propose to resolve the problem?

6 REPLIES 6
aaapopups
Level 1
3 3 0 2
Message 2 of 7
Flag Post
HP Recommended

Daniel I hope you got this sorted!

 

FWIW I am facing exactly the same symptoms - something seems to have died. On hot plugging the USB or DP cables nothing is detected at all by the OS (nothing changes). Windows event viewer shows no hardware changes. Even on Linux not a single thing can be found in the syslog or dmesg when the device is connected - it might not be usable, but at least the USB devices should enumerate if it is powered. They don't.

 

The white LED on the side of the box on the 6m cable is not lighting up at all. This is the original 6m cable, revision 1. I have gone through the usual powercycling, reconnect everything, try different USB ports with and without the supplied USB A-to-C adapter. Have also checked the seat of the cable into the HMD and even checked the power brick is operating (it is outputting 19.5V, as it should).

 

HP's support pages are frankly completely pointless and hopeless on this; not a mention of all but the lowest common denominator issues in spite of plenty of mentions of similar problems out there on the web. This is clearly a problem a lot of people have been having but information is not even scarce, it's just utterly missing.

 

There is a revision 2 of the 6 meter cable. How do I know that? Youtube and Reddit. I will try to get in touch with support tomorrow to get one while I'm still under warranty. I suggest everyone else still with a rev 1 cable does the same, because it seems the clock is ticking on them from the moment they're made.

 

1 person found this reply helpful
Was this reply helpful? Yes No
madsby
New member
3 2 0 1
Message 3 of 7
Flag Post
HP Recommended

Hi there 

How do you find out what revision you have ?

 

Was this reply helpful? Yes No
aaapopups
Level 1
3 3 0 2
Message 4 of 7
Flag Post
HP Recommended

I believe the rev 2 has a switch on it rather than needing you to yank the power cord out, so that's probably the easiest way to tell. Otherwise, by purchase date; the rev 2 is more recent (October). Not having physically seen a rev2 I don't know a better way to tell.

1 person found this reply helpful
Was this reply helpful? Yes No
madsby
New member
3 2 0 1
Message 5 of 7
Flag Post
HP Recommended

yeah the revision 2 seems to do the trick, called support yesterday and today the cable arrived

1 person found this reply helpful
Was this reply helpful? Yes No
aaapopups
Level 1
3 3 0 2
Message 6 of 7
Flag Post
HP Recommended

+1 to that, I called and got a replacement cable too, it's rev 2 and now everything works again.

 

1 person found this reply helpful
Was this reply helpful? Yes No
glydur
New member
1 1 0 0
Message 7 of 7
Flag Post
HP Recommended

Hate to put a damper on hope but I just got a new G2 today and the version 2 cable stopped working after an hour or so. the power button lights up but turns off as soon as the button is released. On the phone waiting for support now.

Was this reply helpful? Yes No
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation