cancel
Showing results for 
Search instead for 
Did you mean: 
LYTRA
New member
3 1 0 0
Message 1 of 4
180
Flag Post

Solved!

HP Omen 2020 en0002ax GPU running at x8 3.0 pcie even under load.

HP Recommended
HP Omen 2020 en0002ax
Microsoft Windows 10 (64-bit)

My laptop HP Omen 2020 en0002ax with Ryzen 5 4600h and GTX 1660ti, the GPU bus interface is stuck at x8 3.0 pcie even under load. For power saving it changes to x8  1.1. It is supposed to run at x16 3.0 pcie. 

 

I have checked other laptops(acer predator helios 300) with GTX 1660ti and everything i.e. the core clocks and memory clocks are the same except it runs at x16 3.0 pcie under load. I have also noticed slight performance difference.


So far I have tried updating the gpu driver, downgrading gpu driver to HP default version with DDU, updating bios to F.07. Nothing works.

 

Screenshot (287).png

3 REPLIES 3
Photoray002
Level 15
Level 15
12,541 12,324 1,291 4,118
Message 2 of 4
Flag Post
HP Recommended

Hello @LYTRA 

 

You're not going to find anything to update to make the PCIe interface run at true x16. HP's have always done this, even on their Desktop versions. HP wont exactly give me a specific reason other than the lanes being shared. Im guess its sharing the M.2 NVMe lanes.

Sorry I cannot help you out on this. Its this way by design and cannot be changed. 😔

LYTRA
Author
New member
3 1 0 0
Message 3 of 4
Flag Post
HP Recommended

Thanks for letting me know.

Reply
0 Kudos
Photoray002
Level 15
Level 15
12,541 12,324 1,291 4,118
Message 4 of 4
Flag Post
HP Recommended

You are very welcome.

Reply
0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation