cancel
Showing results for 
Search instead for 
Did you mean: 
Buskerdu
New member
1 0 0 0
Message 1 of 2
184
Flag Post

Audio crackling issue with OMEN 15-ek0 when using external speakers connected with Thunderbolt 3

HP Recommended
OMEN 15-ek0xxx
Microsoft Windows 10 (64-bit)

Hello -

 

I recently upgraded to the OMEN 15 to run DAW software for my home studio. I am running external monitor speakers which are connected to a Presonus Quantum 2626 Audio Interface using a Thunderbolt 3 connection to the OMEN. I am running BIOS F.07 and all drivers are up-to-date, as far as I can tell 🙂

 

I am experiencing signficant crackling and pops when playing any audio through the Thunderbolt 3 connection; whether from my DAW or any other local or streamed audio. After doing a good amount of research I was able to determine that there is an issue with how TB3 connections interact with the quad-core processing and it was recommended that the Processor Idle Policy Settings be DISABLED. To do this I am using RightMark PPM Panel which allows you to disable/enable these settings.

 

The good news is that with these settings disabled the crackling dissapears completely and everything sounds great!

 

The bad news is that when Processor Idle Policy Settings are Disabled the fans spin significantly more often, and more loudly which is not great when doing audio work.

 

So my (long-winded!) question is: Does anyone know of a way to get rid of the audio crackling and pops when using a TB3 connection without causing the fans to spin so much and so loudly?

 

NOTE: When the Processor Idle Policy Settings are re-enabled, the fans almost immediately stop spinning (within several seconds) and based on other settings I have in place the laptop is actually VERY quiet! So I just need to achieve the same result when I'm using the TB3 connection!

 

Thanks in advance for any help with this issue. Hopefully I explained it properly! If any other information is needed to answer please let me know.

1 REPLY 1
Echo_Lake
HP Support Agent
HP Support Agent
24,988 24,942 1,161 1,194
Message 2 of 2
Flag Post
HP Recommended

@Buskerdu

Thank you for posting on HP Support Community.
 

Don't worry as I'll be glad to help, I have a few troubleshooting steps we could try to fix the issue:  

Firstly, perform Windows Update and HP Support Assistant: (do not skip any troubleshooting steps if you feel steps are repeating) 

To check for updates now, select the Start button, and then go to Settings  > Update & security  > Windows Update, and select Check for updates.

Install updates from HP Support Assistant: Go to Download HP Support Assistant to install the tool.

  1. To open HP Support Assistant, double-click the HP Support Assistant icon https://support.hp.com/doc-images/932/c05040382.jpg.
  2. Click My devices in the top menu, and then click Updates in the My PC or My notebook pane.
  3. Click Check for updates and messages to scan for new updates.
  4. Review the list of updates. Updates with a yellow information icon are recommended. Updates with a blue information icon are optional.
  5. Click the update name for a description, version number, and file size.
  6. Select the box next to any updates you want to install, and then click Download and install.

Hope this helps! Keep me posted for further assistance.
Please click “
Accept as Solution” if you feel my post solved your issue, it will help others find the solution.

ECHO_LAKE
I am an HP Employee

Was this reply helpful? Yes No
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation