cancel
Showing results for 
Search instead for 
Did you mean: 
sholland99
New member
4 3 0 0
Message 1 of 8
7,223
Flag Post

Solved!

HP Spectre 15 x360 Audio Issue

HP Recommended
HP Spectre x360 15-bl012dx
Microsoft Windows 10 (64-bit)

Recently I began having issues with my audio. When I go into several programs there are different issues. For example:

1. Spotify will play a few seconds of one song, then proceed to skip through the play list.

2. Youtube will play a few seconds then play the remainder of the video with no audio.

3. Various PC games will crash and give errors in regards to the audio.

4. In the audio settings, the output device (Realtek High Definition Audio) will randomly disappear and reappear, resulting in the muted icon appearing and disappearing in the tool bar. 

5. When audio attempts to play, the volume will go from 100 to 0 then horrible static (primarily in the right speaker) with low volume in the background.

 

I am under the impression that it is a software issue, as when I do the hardware audio tests from the F2 screen, there are no issues. However, this could be completely wrong. I have followed along with the Virtual Agent and have had no luck. Here is everything I have tried:

1. Restarted the computer (no change)

2. Hard restarted the computer (no change)

3. Uninstalled/reinstalled audio drivers (no change)

4. Updated audio drivers (Intel (10.23.0.567, 811.53 KB (831,008 bytes)))

5. Ran the audio component test from F2 at restart (passed)

6. Updated BIOS (was previously at AMI F.39 11/12/18)

7. Restored from System Restore, back to last functioning restore point (no change)

 

The last suggested step is an HP System Recovery - Windows 10, which I am afraid to do in fear of losing my hard drive information. However, I am able to save my information to a cloud if needed. If there are any other ideas available, feel free to let me know. Additionally, if anyone can help me figure out how to access my Bang & Olufsen settings toolbar (which disappeared as well), that would be great. Thank you in advance!

 

***Additionally, the audio is fully functional when headphones are inserted into the jack, making me think it is an issue solely with the Intel Audio driver.

1 ACCEPTED SOLUTION

Accepted Solutions
banhien
Level 19
Level 19
94,822 93,479 12,286 26,121
Message 2 of 8
Flag Post
HP Recommended

@sholland99 

 

Please do a clean install Audio softeware/driver, this should help.


(a) Download the following driver and save on your computer,


   https://ftp.hp.com/pub/softpaq/sp92001-92500/sp92073.exe


(b) Go to Device Manager, Sound to uninstall sound driver and reboot,
(c) Right click downloaded file and select Run as administrator,
(d) Reboot again.

 

For B&O tool bar, please look at

 

      BandOa.png


Regards

BH
***
**Click the KUDOS thumb up on the left to say 'Thanks'**
Make it easier for other people to find solutions by marking a Reply 'Accept as Solution' if it solves your problem.




>

View solution in original post

Was this reply helpful? Yes No
7 REPLIES 7
banhien
Level 19
Level 19
94,822 93,479 12,286 26,121
Message 2 of 8
Flag Post
HP Recommended

@sholland99 

 

Please do a clean install Audio softeware/driver, this should help.


(a) Download the following driver and save on your computer,


   https://ftp.hp.com/pub/softpaq/sp92001-92500/sp92073.exe


(b) Go to Device Manager, Sound to uninstall sound driver and reboot,
(c) Right click downloaded file and select Run as administrator,
(d) Reboot again.

 

For B&O tool bar, please look at

 

      BandOa.png


Regards

BH
***
**Click the KUDOS thumb up on the left to say 'Thanks'**
Make it easier for other people to find solutions by marking a Reply 'Accept as Solution' if it solves your problem.




>

View solution in original post

Was this reply helpful? Yes No
sholland99
Author
New member
4 3 0 0
Message 3 of 8
Flag Post
HP Recommended

This did not solve the issue and now I have no driver for my Intel Speakers. It is almost as if the device was deleted entirely. As for the B&O tool bar, I can see that icon and the small menu but when I click on "audio control" nothing happens.

Was this reply helpful? Yes No
banhien
Level 19
Level 19
94,822 93,479 12,286 26,121
Message 4 of 8
Flag Post
HP Recommended

@sholland99 

 

Did you do a CLEAN install ?

 

Regardfs,

BH
***
**Click the KUDOS thumb up on the left to say 'Thanks'**
Make it easier for other people to find solutions by marking a Reply 'Accept as Solution' if it solves your problem.




>
Was this reply helpful? Yes No
sholland99
Author
New member
4 3 0 0
Message 5 of 8
Flag Post
HP Recommended

I followed your steps exactly, including the rebooting and opening as an administrator. 

Was this reply helpful? Yes No
sholland99
Author
New member
4 3 0 0
Message 6 of 8
Flag Post
HP Recommended

It appears that I have audio after restarting my computer again. I am unsure of what made a difference but I am happy to have it functioning! Thank you!

Was this reply helpful? Yes No
banhien
Level 19
Level 19
94,822 93,479 12,286 26,121
Message 7 of 8
Flag Post
HP Recommended

@sholland99 

 

You are welcome

 

Regards.

BH
***
**Click the KUDOS thumb up on the left to say 'Thanks'**
Make it easier for other people to find solutions by marking a Reply 'Accept as Solution' if it solves your problem.




>
Was this reply helpful? Yes No
mdh2959
New member
1 1 0 0
Message 8 of 8
Flag Post
HP Recommended

In attemting to follow your guidenace, when I click on Device Manager, Sound - which should I uninstall?  all three listed? or which?  Intel Display, NVIDIA virtual audio or Realtek High Def?

 

Thanks

Was this reply helpful? Yes No
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation