cancel
Showing results for 
Search instead for 
Did you mean: 
Rukfasd
New member
2 1 0 0
Message 1 of 2
161
Flag Post

AMD Driver issue

HP Recommended
HP Probook 4740s
Microsoft Windows 10 (64-bit)

Hi everyone

 

I am using HP Probook 4740s for 3D modeling in Solidworks. It worked pretty smooth and functional until 2 days ago, and that was the last time I used it. Today, it was really slow and laggy with questionable operational functionality since every single operation takes 10-20 seconds at least to respond in the simplest sketches started from scratch. That shouldn't happen. I found on some specialized sites that the reason for this could be a bad graphics card update or windows update. I did have windows update last night and I suspect that the reason for this lies there.

 

Anyway, in the process of detecting the problem, I noticed I have a warning in the device manager about Microsoft Basic Display Driver and it says that the device is not working properly (Code 31).

 

I have tried to auto-update via Windows and it finds drivers, but soon after the begging of installation screen freezes and doesn't respond to anything.

 

I have also downloaded from hp sites AMD catalysts driver for my model, again it starts installation, detects components, and starts the procedure, but again the same problem. Screen freeze and doesn't respond. 

 

I can only turn off pc manually after freezes in both cases.

 

For the graphics, this model has both intel integrated and AMD dedicated graphics card.

 

I would appreciate it if you could help me to resolve this issue.

 

Regards

 

 

 

 

1 REPLY 1
Rukfasd
Author
New member
2 1 0 0
Message 2 of 2
Flag Post
HP Recommended

UPDATE:

 

I have tried to resolve issue with no success in the meantime. I have tried to do installation of AMD Catalyst in the safe mode. That way there was no screen freeze, but setup fails to "detect components". I also noticed that in system information there is no detection of AMD HD 7650 M graphic card, only Intel integrated graphics. 

 

I was wondering if this is part of the same issue or this means something else like hardware issue?

 

 

Capture.PNG

0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation