cancel
Showing results for 
Search instead for 
Did you mean: 
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
JackDNevin
New member
2 0 0 1
Message 1 of 7
4,138
Flag Post

HP EliteBook Folio G1 Notebook PC - Unable to Network/PXE Boot

HP Recommended
Elitebook Folio G1
Microsoft Windows 7 (64-bit)

Hi,

 

My company have recently got a few of the new EliteBook Folio G1 M5 notebooks in to do some testing as a new device for our users. To test it we need to install our corporate image onto the device to give it a road test but we have been unable to PXE boot it and even unable to image it via a USB.

 

I am lost for possible solutions now at this point with the device.

 

I am trying to install Windows 7 Professional 64-Bit as this is our corporate operating system.

 

We currently have one 32-bit boot image that allow us to boot all of our other laptops and when we get a new device I just update the network driver into the boot.wim and it works fine however this hasn't worked with this model.

I even extracted a Windows 7 64-Bit ISO so I could get my hands on an x64 boot.wim to inject the driver into this however I still get the same issue.

 

On the laptop support docs on the HP website it says for Windows 7 Compatablity you need to download the 3.1 Pack and two Windows updates and then inject them into the boot image which again I have tried on the x32 & x64 boom.wim and neither work.

 

I have even downloaded all drivers for this model of laptop and from the Windows 7 X64 version and injected them one by one to see if any are needed additional and it doesn't work with any combination.

 

There is also no previous version for the Realtek USB Ethernet NIC that I can try although I have downloaded 99% of USB NICs available from Realtek, injected these into the boot.wim and again still the same issue.

 

I have Windows 10 boot.wim that allows it to boot without any issues and install a test Windows 10 image I have and not got a clue what I can try now to get this to work with Windows 7!

 

I have tried the network boot via the USB-C Dock & the USB-C to USB & Ethernet adapter and both the same issue.

 

Just in case anyone is confused on the laptop model its the below link:

 

http://support.hp.com/in-en/product/hp-elitebook-folio-g1-notebook-pc/9764622/drivers

 

The Error:

It allows you to start the PXE Boot and tries to load up the boot.wim but fails and advises to install the correct NIC drivers for the network card being used.

(Which the above steps should have done)

 

Any helps or ideas would be extremely appreciated.

6 REPLIES 6
Jonilj
New member
4 3 0 0
Message 2 of 7
Flag Post
HP Recommended

We are having the very same issue, this machine just refuses to PXE boot. If I select an IPv4 PXE boot, all it does is load, get an IP and then revert back to BIOS. I have tried three different USB C-to-ethernet adapters and none of them will work.

0 Kudos
Jonilj
New member
4 3 0 0
Message 3 of 7
Flag Post
HP Recommended

I found a solution, or a work around atleast...I had to enable Legacy Mode and disable Secure Boot, after that I was able to get the PXE boot working.

0 Kudos
cvyn187
New member
2 2 0 0
Message 4 of 7
Flag Post
HP Recommended

I am also not able to Boot to Network. I have the USB Travle Dock (the blue one).

When HP Stock WIndows is running that thing works.

 

But when i press F12 i am not able to boot to Network. The screen is just empty.

Pressing F9 for Boot Device selection, it does not offers me Network at all.

The LEDs at the TravleDock are flashing for my RJ45 connector. Its 100% a cable i use all the time for installing new NBs.

 

Pls help, how can i boot to Network/PXE from this EliteBook?

0 Kudos
Jonilj
New member
4 3 0 0
Message 5 of 7
Flag Post
HP Recommended

Have you tried the steps I advised regarding UEFI/SecureBoot?


I also had trouble with one of my USB C to Ethernet-adapters, when I switched it worked. Strange.

0 Kudos
cvyn187
New member
2 2 0 0
Message 6 of 7
Flag Post
HP Recommended

Yes i tryed. I choosed option "to anable Lagacy mode / disable secure Boot"

But it changed nothing.

 

I guess i will open case at HP.

0 Kudos
AmirNadeem
New member
2 1 0 0
Message 7 of 7
Flag Post
HP Recommended

Hi,

 

did u open case with Hp, any update?

0 Kudos
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation