cancel
Showing results for 
Search instead for 
Did you mean: 
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
lucas_demh
Level 3
55 44 0 6
Message 1 of 15
4,326
Flag Post

Solved!

MediaSmart won't run

HP Recommended

The computer is a Pavilion dv8t-1100

 

MediaSmart start menu won't run
(That second button on the panel. Between the power button and the multimedia keys)

 

I installed:


sp48159        HP Quicklauch Buttons
sp38358        QuickTouch
sp53677        Firmware update to fix Wi-fi crazyness

sp45617        HP Tone control

 

sp46762        MediaSmart StartMenu
sp48552        MediaSmart StartMenu

(None Worked)

 

What did I forget?

0 Kudos
14 REPLIES 14
Dragon-Fur
Level 16
Level 16
31,513 31,221 2,863 10,490
Message 2 of 15
Flag Post
HP Recommended

Hi Lucas,

 

I'm not sure you forgot anything.  I've heard that the "Menu" likes to be "first" into the mix.  Maybe if you removed the rest of the MediaSmart bits and started over - installing the Menu First, then the packages that go with in the MediaSmart menu.

 

The only other thing I can think of right this minute, is the keyboard driver itself.  I had the same issue on my old HDX 18t - no MediaSmart button.  I just ignored it for a long time.  I ended up solving the issue at the last install of Windows 7 / 64bit Ultimate install - not deliberately - but it may have been an update to the keyboard driver that was done during this last install that kicked everything back into place.   You might kick the keyboard driver and see if it wants to update.

 

As mentioned, the only other thing done differently (just because it was a clean install); I started with the Menu and then loaded the "other" MediaSmart packages.  Hmmm... I also did allow Windows Update to load Visual C++ and some Framework packages; I doubt that had any effect on any except the packages they were meant to accompany.

 

I hope this helps.

 

Say “Thanks!” by clicking Kudos Star in the Post that helped you.

Mark a Post “Accepted Solution” to say your issue is solved.

 

 

Dragon-Fur

lucas_demh
Author
Level 3
55 44 0 6
Message 3 of 15
Flag Post
HP Recommended
Nothing..
😞

I've uninstalled all those stuff in the list I put.
There were no other MediSmart softwares installed. Of them, the menu was indeed the first and only.

Reinstalled the StartMenu.
A program shortcut was automatically placed on the windows start menu. The program won't run from there either, so it's not a problem with the key on the keyboard..

Really don't know what to do.
The startmenu is the only thing installed. No interference from other programs...
Dragon-Fur
Level 16
Level 16
31,513 31,221 2,863 10,490
Message 4 of 15
Flag Post
HP Recommended

Lucas,

 

RATS.

Not looking much like Christmas around here. :Crying:

 

  • How about updating the BIOS?
  • Maybe the menu won't run until it has something to run against - maybe load the DVD and the Webcam...

 

Will look a bit more and come back when I find anything useful...

 

Dragon-Fur

Dragon-Fur
Level 16
Level 16
31,513 31,221 2,863 10,490
Message 5 of 15
Flag Post
HP Recommended

Hey Lucas,

 

OK, Nothing else comes to mind right now...

This is not even for your hardware, but this Menu is working on my HDX 18t - lights up the keyboard, opens on the Desktop and offers the DVD, the webcam, and the Video software options.

 

You could try it if you like.  Your system should reject it if the architecture is incompatible.

 

Here is the MediaSmart Menu for HDX 18...

ftp://ftp.hp.com/pub/softpaq/sp45001-45500/sp45140.exe

 

Hmmm... Merry Christmas  :generic:

 

 

 

Dragon-Fur

lucas_demh
Author
Level 3
55 44 0 6
Message 6 of 15
Flag Post
HP Recommended

Merry christmas, in first place...
...10 day to go

Well,
Tested your sp.
Same behavior: nothing happens.
Updated bios from v15 to v25: nothing.
sfc /scannow: still dead.
😞

Problem with windows, I deeply believe.
Worked once... why not now?

Dragon-Fur
Level 16
Level 16
31,513 31,221 2,863 10,490
Message 7 of 15
Flag Post
HP Recommended

Hi Lucas,

 

I wish I knew.  The dastardly thing; it's probably something easy to fix.  It frequently is.

OK - things to try...

 

Look on your website - download and install

QuickLaunch

I think you need this...  I'll track it down if you cannot find it.

 

Order of Events:

I just found a thread that said that the Menu likes to be Last Loaded.  This is contrary to what I've been reading. ?

Maybe you need to load up a bunch of the MediaSmart programs first.  The thread was not for the HDX series systems and it was a couple of years old... Nonetheless; an interesting idea and a different point of view.

 

 

Registry Cleaner:

Bad things happen to good computers when the registry is dirty.

Clean out the registry, use your favorite or download and use CCleaner, it's a good one and it's free:

http://www.piriform.com/ccleaner/download/standard

 

Check the Registry:

After you clean the registry, you might open it and see what MediaSmart entries are still lurking about.  If you think to make ANY changes to the registry, be sure you EXPORT the registry first (make a backup) so you can import if anything goes wrong.

 

Hard Reset:

  • Disconnect all external devices first.
  • Remove AC power and the battery
  • Press and hold power button for at least 20 seconds (Dragon-fur says, "... I like 60 seconds.")
  • Reinstall only AC power for first startup.
  • Power on - Log in
  • Test the sound
  • Next time you shut down the system, put the battery back in.

If you like, you can ignore the bit about leaving the battery out - just put the battery back in the first time and be done with it.

 

 

Don't give up -- There is nothing to fear -- it's all just ones and zeros!  :generic:

 

 

 

 

Dragon-Fur

lucas_demh
Author
Level 3
55 44 0 6
Message 8 of 15
Flag Post
HP Recommended

I had HP Quick launch Buttons already (sp49104 - latest)

Reinstalled to ensure.

But doesn't matter anyway if the buttons work or not. The StartMenu won't launch even from the executable..

 

By the way, reinstalled the startmenu (sp48552, sp46762 - latest and the older one, respectively) both as admin (don't know if they are TrustedInstaller, so the windows (I hate so much) might not let it put stuff in the registry)

But no success..

 

CCleaner... I use it at least twice on a week.. used again... no entries on mediasmart stuff..

 

MediaSmart Live Tv, SlingPlayer, MediaSmart Webcam and HP advisor with dock (maybe relevant ) work normally...

The StartMenu is the only one that doesn't.

😞

 

Full hard reset also done. Even more than 60 seconds... (never gonna fully drain a capacitor..)

 

There must be  a '2' between the ones and zeros..

Now I believe in demons..

Dragon-Fur
Level 16
Level 16
31,513 31,221 2,863 10,490
Message 9 of 15
Flag Post
HP Recommended

Lucas,

 

Many years ago, when I was baby IT, a very smart man taught me several important things about working smart.  In those days the people who invented Google were probably in kindergarten.  .  Maybe they weren't even born.  Smiling.

 

Two of those lessons:

  • Stop looking in the same place for the answer - if it were there, you'd have found it.  (Speaks of trusting one's self)
  • Take notes - writing it down in one's own hand connects the idea to the brain.

 

My Own:

  • The simplest answer is rarely the answer - if that were true, all programs would only have 500 lines of code.
  • When something goes wrong - it's the small stuff the makes you crazy.

 

 

Check List:

  • .NET framework?  Running framework 4
  • I have some extra C++ libraries in my HDX system.  Most folks don't, so that's probably not it...
  • I do notice the 'Menu is in Program Files, everything else is in Program Files (x86)...
  • You are not running Norton, are you?  Meh.

 

Current OS:

You are running 64 bit on your machine, yes?

What flavor of Windows 7?

 

 

Benchmark:

Start > Task Manager > PerformanceResource Monitor > CPU

> sort by image  >>> Scroll down

Check for SmartMenu.exe

 

Running process = success

 

I am running this (for an HDX 16) on my HDX 18t

MediaSmart Menu  V3.0.30.1

ftp://ftp.hp.com/pub/softpaq/sp45001-45500/sp45140.exe

 

I do agree about the demons.  IT are superstitious.

It's a piece of code - it should run on your computer.

 

OK.. Will dig more.

 

 

Dragon-Fur

HaggisCat
Level 12
4,523 4,426 238 1,229
Message 10 of 15
Flag Post
HP Recommended

I'll give Dragon-Fur a break here.

 

 This works for the HDX series as well as the dv8 as they are the same machines when it comes to the hot key bezel at the top of the key board. I am running a retail version of W7 on my dv8 and this is what I did to get the buttons working. It should work with an HP version of W7.

 

 First off uninstall the quick-launch button software , it's not needed on the dv8 or the HDX for that matter. HP installs this on most machines as a blanket utility, but it's not needed here. After you uninstall it, restart your machine. It's just a cumbersome program that runs in the back ground that takes up resources.

 

 Next go to "Computer" click on that > Drive "C" > Program Files > Hewlett-Packard > HP Media Smart.

 This assumes you're running a 64 bit version, I am quite sure that all the dv8's were 64 bit.

 Make a note where the HP Media Smart File is, that is where the Menu is that operates the Media Smart quick launch button that has stopped working on your machine.

 

 Uninstall all and any Media Smart Smart Menu's from program's and features and restart. Next go back and find the HP Media Smart file from above, it should be gone. If it's not, right click on it to delete it and restart.

 Also at this point the file should be empty, if it's not, please take a screen shot of what's there. Don't delete the file if it's not empty. I need to see what's in there first, but in most cases after uninstalling the Menu It's empty.

 

 Go to this link and follow it's quirky instructions to the letter. It should not matter what versions os Media Smart applications you have, but you need at least one to get the menu to work. I have Media Smart DVD and MS Web Cam.

 

 Go to the solution.

 

 http://h30434.www3.hp.com/t5/Notebook-Display-and-Video/On-Screen-Volume-Treble-amp-Bass-Display-Err...

 

 Make sure and restart as the instructions point out in the solution and both files must be saved to the desk top and ran from there, not from a temporary folder.

 

 What caused it to stop working, did it stop after a Windows update or some software that you installed ? Or did you install a retail version of W7 and now you can't get it to work ?

 

 Note that the solution is to deal with the volume OSD, but that Menu should allow your MS icons to show up when the MS button is pushed.

ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation