cancel
Showing results for 
Search instead for 
Did you mean: 
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
cbmonk71
New member
1 0 0 0
Message 1 of 2
443
Flag Post

system restore failed

HP Recommended
HP Envy m6 Notebook
Microsoft Windows 10 (64-bit)

I have been trying to run a system restore on my HP Envy, but I keep getting the error message

 

System Restore did not complete successfully.  Your computer's system files and settings were not changed.  

 

Details:  System Restore failed while restoring the directory from the restore point.  

Source:  appxStaging  

Destination:  %ProgramFiles%/WindowsApps

An unspecified error occurred during System Restore.  (0x8000700091)

 

Here is what I have tried so far.  

 

Running system restore at various restore points.  

Turning off my McAfee antivirus software and running the system restore again.  

Running system restore in safe mode

Running system restore in safe mode with networking.  

Running a system scan which said "Windows Resource Protection did not find any integrity violations."

Running malware bytes to see if any malware was causing the problem.  

Checking to make sure all windows updates are current

Running system restore using wifi at a different location (in case it was something to do with my att wifi connection)

 

The weird thing is that I have 3 other HP laptops in addition to this one (all with Windows 10 and McAfee) and they are all having the same issue with system restore (giving the same error message).  

 

I have run system restore on this laptop previous, but it's been a few months, but the fact that all 4 laptops in my house are doing the same thing tells me that it's not specific to mine.  

 

I'm at a loss for what to do next, but I need this issue fixed.  

0 Kudos
1 REPLY 1
WAWood
Level 16
Level 16
30,556 30,463 2,785 6,725
Message 2 of 2
Flag Post
HP Recommended

@cbmonk71

 

Hello;

Allow me to welcome you to the HP forums!

 

Sorry, I'm not personally affected by this problem -- possibly because I stopped using McAfee years ago!

 

But ... here is a LONG thread about this issue, and you will see in their reference to AV products that their "solution" is to remove that product completely and try again:  http://borncity.com/win/2017/02/22/windows10-version-1607-system-restore-error-0x80070091/

 

Personally, I prefer MBAM (Malware Bytes Anti-Malware) as it has performed far better for me in finding and removing malware than anything else I have used.

Good Luck

***If my post helped, click the thumbs-up symbol to say thanks***

***Please mark Accept As Solution if my post solved your problem***

I am a volunteer and I do not work for, nor represent, HP
0 Kudos
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation