cancel
Showing results for 
Search instead for 
Did you mean: 
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
cbhamlyn
New member
2 1 0 0
Message 1 of 4
890
Flag Post

Deskjet 2540 can't connect to new Spectrum Cable wireless router.

HP Recommended
Deskjet 2540
Microsoft Windows 10 (64-bit)

Recently switched from DirectTV to Spectrum Cable and got their latest wireless router, now my Deskjet 2540 will not connect to it.  The router supports both 2.4 and 5.0 ghz.  Prior to this I had used a Netgear wireless router with DirectTV and prior to that a Timewarner Cable router without any issues.

 

I keep getting "wrong wifi password" or "unknown" errors.

 

Troubleshooting steps:

 

1) Tried the WPS auto-configuration.

2) Uninstalled the printer from my PC completely and then ran through the new printer configuration steps online.

3) Tried connecting the printer to a second computer via USB and then choosing to "Convert USB to Wifi".

4) Tried changing the 2.4ghz Wifi security from WPA2+AES to WPA+TKIP/AES.

 

Of course between all the above steps I rebooted the printer and router regularly.  I also re-set the printer wifi by holding the wifi button and the cancel button until the power light blinks a few times between steps.  Nothing seems to work.  I finally took the printer to a friend's house and connected it to that wifi without issue, so I know it's not an issue with the printer's actual wifi hardware.

 

I would also like to note that I have several devices (laptop, phones, tablet, smartTV) connected to the Wifi without any issues, so the wifi is working fine for everything but the printer.

 

I'm planning to plug in my old Netgear router (in addition to the Spectrum one) just so I can get the printer on the network, but I'd really like to not have to do that.

 

Does anyone have any ideas of things I haven't tried yet?

0 Kudos
3 REPLIES 3
The_Fossette
HP Support Agent
HP Support Agent
29,155 29,140 1,944 2,571
Message 2 of 4
Flag Post
HP Recommended

Hi @cbhamlyn

 

Welcome to the HP Forums!

 

Thank you for posting your query in this forum, it's a great place to find answers.

 

I reviewed your post and I understand that you are unable to connect to your wireless network after switching internet service provider.

 

Don’t worry, we will work together to resolve this issue and It’s a pleasure to assist you in this regard.

 

Awesome job on diagnosing the issue correctly and performing smart troubleshooting before posting your question on HP forums. Kudos to you on that score.  It is a privilege to work with tech-savvy and technically competent customers like you and we greatly value your business with HP. It is a genuine pleasure to share this platform with you. 

 

I would like to inform you that if your PC is getting connected to 5GHz frequency and the printer is connected to 2.4GHz then you will not be able to print. I recommend you to make sure both the printer and the computer are on the same frequency.

 

If possible, I recommend you to change the mode on the router to b and g and channel to 11 and check whether you are able to connect and print.

 

Let me know how it goes and you have a great day!

 

To simply say thanks, please click the "Thumbs Up" button to give me a Kudos to appreciate my efforts to help. If this helps, please mark this as “Accepted Solution” as it will help several others with the same issue to get it resolved without hassles.

 

Take care.

 

Cheers!

The_Fossette
I am an HP Employee

cbhamlyn
Author
New member
2 1 0 0
Message 3 of 4
Flag Post
HP Recommended

Hello,

 

The router was already set to b and g (and n).  The Channel was set to automatic so I tried setting it to 11 but it still didn't work.  

 

I restarted both the router and printer several times in my troubleshooting.  The first attempt to connect after reboot always says the password is wrong, but I triple checked it and it wasn't.  The second attempt always just says "unknown".

 

Here is what the router setup screen looks like:

2017-05-16_8-54-22.png

 

I tried a couple other channels and tried flipping between the two Channel Bandwidth settings but it doesn't seem to want to connect to the router.

 

Any other ideas?

0 Kudos
The_Fossette
HP Support Agent
HP Support Agent
29,155 29,140 1,944 2,571
Message 4 of 4
Flag Post
HP Recommended

Hi @cbhamlyn

 

Follow below steps and check.

While holding down the power button, press the Start Copy Black button  two times, then press the cancel button  three times.

 

Then try to configure the printer again and check.

 

Let me know how it goes.

The_Fossette
I am an HP Employee

0 Kudos
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation