cancel
Showing results for 
Search instead for 
Did you mean: 
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
foxtwp
New member
1 0 0 0
Message 1 of 1
661
Flag Post

Check if SoftPaq not ssm-compliant needs to be updated and way to auto install it

HP Recommended
Elitebook x360 g2
Microsoft Windows 10 (64-bit)

I use Hp sdm and ssm to automatically deploy and install updates on selected notebooks.

 

My question is:

 

Since ssm install only ssm-compliant packages, how do I determine if I need to install a package that is not ssm-compliant?

 

For example, the "HP Thunderbolt 3 Dock Firmware" package is not ssm-compliant but my notebook may have installed the latest thunderbolt firmware, so how can I programmatically check if the thunderbolt firmware is up to date in my pc or if it needs to be updated?

 

Another question is: Is there a way to programmatically automatically install the packages that are not ssm-compliant?

 

Thanks a lot

 

Regards

0 Kudos
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation