cancel
Showing results for 
Search instead for 
Did you mean: 
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
AlanNnNn
New member
1 0 0 0
Message 1 of 7
4,617
Flag Post

hpqFlash64.exe in Windows PE 5.0 x64

HP Recommended

We currently push BIOS updates to our Elitebook 840 G1 and G2 laptops using HPBIOSUPDREC64.exe as part of our task sequence when deploying images from SCCM 2012 R2, and it's working fine... however we wanted to do the same for our older laptops (Elitebook 8470 and 8440 models) and I cannot get hpqFlash64.exe to run at all in Windows PE 5.0 x64, whether I am trying to run it as part of a task sequence or manually from a USB stick.

 

I want to stress that attempting to run hpqFlash64.exe appears to do absolutely nothing regardless of swiches used, it doesn't even generate an hpqFlash.log file. Has anyone else run into this or found a way to get hpqFlash to work in Windows PE 5.0 x64?

 

Any advice would be appreciated.

0 Kudos
6 REPLIES 6
ddiops
New member
1 1 0 0
Message 2 of 7
Flag Post
HP Recommended

I have the same issue - I switched to UEFI x64 and winPE 5 x64 . Nothing happens - does not generate log file and if you run hpqflash64.exe /? nothings happens either. 

Could any from hp comment on this please!

0 Kudos
PARC_STM
Level 2
16 13 0 1
Message 3 of 7
Flag Post
HP Recommended

Many month and still no info on how to do this with winpe? wow...

0 Kudos
_Travis
New member
3 2 0 0
Message 4 of 7
Flag Post
HP Recommended

Will somebody, anybody from HP Please look into this? There are still BIOS updates being released for older generation HP equipment. Having to Flash from the Desktop is painstaking. As Admins all we want to do is Flash from WinPE 5.0 x64 and above. Please update hqpFlash64 so it works, or go back and update older models to use HPBIOSUPDREC64.exe.

0 Kudos
nkofahl
New member
New member
2 2 0 1
Message 5 of 7
Flag Post
HP Recommended

You need to add packages to your winpe 64 in order to use this utility. I just tested on a 9470m by updating the bios 

 

Make sure you have WMI, HTA and Scripting in your PE. I have a few other packages in mine (see my WINPE 10 x64 Package list). 

 

hpqflash64x2.jpghpqflash64x2.jpg

I am an HP Employee
PARC_STM
Level 2
16 13 0 1
Message 6 of 7
Flag Post
HP Recommended

I do have all of that in my winpe, I use other scripting tools and BCU. Thing is, if you run it silently, it return nothing and does nothing. I can run it without -s, I'll get the prompt window asking what I want to do and it will do the job. But run it silently, nada, no flashing. You should see it yourself, take a computer without the update and try to flash, the version will not change. It doesn't even generate a log file.

0 Kudos
nkofahl
New member
New member
2 2 0 1
Message 7 of 7
Flag Post
HP Recommended

I think you are missing what happened in the screenshots. I did run it silently, but from a batch file so I would know when it was done. It worked and flashed the new bios on this old 9470m which was fully applied on reboot. If it isn't working for you, please get a real support case open so our support teams can gather the information about your configuration. 

 

One other thing, if you already have the bios version you are trying to flash it will not do anything running it via the -s switch

I am an HP Employee
0 Kudos
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation