cancel
Showing results for 
Search instead for 
Did you mean: 
  • ×
    Information
    Fix Windows 10 Update Issues

    Resolve Windows 10 or update issues on HP computer or printer– Click Here

  • post a message
  • ×
    Information
    Fix Windows 10 Update Issues

    Resolve Windows 10 or update issues on HP computer or printer– Click Here

  • post a message
Highlighted
Level 2
21 17 2 1
Message 1 of 4
364
Flag Post

Solved!

Anyone using Wake on Lan on a Z400?

HP Recommended

My old PC was on 24x7 and used to burn a frightening amount of power.. I can't imagine how much its cost me to run over its life.

 

I have just built a Z400 and its running well, and I have found that Sleep is entirly stable. I started by putting it to sleep overnight and then occasionally during the day but now I have Power Management set to put it to sleep after 15 mins.. And it working really well.

 

I have a number of apps that seem to block sleep, but I am finding ways around it, and I also have a backup that runs every night, which wakes up the PC and then lets it sleep again after.. And I have pretty much got it nailed.

 

But my work colleague reminded me that when I get back to work,  I will want to use TeamViewer to access the PC during the day.. So I set out to get Wake On LAN working.

 

I have run into a few problems but after binding the IP with the MAC address in the router, and reserving the IP, I have it working (both from the local LAN and over the public internet (via Port 7)).. But just as I was about to give myself a pat on the back, it stopped working (both locally and remote).

 

But after of a long day of experimentation I have found that I can wake the PC straight after sleep, but after a period of time (in the order or minutes) wake no longer works.

 

This looks to be a power save issue, where initially the PC is in "light sleep" but then after a period of time it goes into "deep sleep" and once this happens, the Ethernet port will no longer respond to a "Magic Packet" needed for WoL.

 

I have read pretty much every article and forum post I can find, which has given some suggestions but nothing works.. I have changed every setting that I can find or have read about, but the problem remains.

 

So before i spend any more time on this, I just wonder if anyone is successfully using Wake On LAN?

 

I look forwards to hearing from you if you do.


Cheers


Jon

 

3 REPLIES 3
Highlighted
Author
Level 2
21 17 2 1
Message 2 of 4
Flag Post
HP Recommended

I fixed it and just thought I would reply back incase anyone else encounters this.

 

I have spent the last few days trying literally every option I can find in WIndows and the BIOS... But nothing changed the behavour.. Sleep would work for around 5 mins and then would not respond.. And I was convinced that it was some kind of "power saving" feature..


But I was wrong.. .

 

I went back to the guides again and much of what I read pointed to an ARP timeout.. .So after a period of time the Router didn't know the MAC Address/IPs relationship of the device I wanted to wake. But everything I read looked to be pointing at the PC/Windows.. But it wasn't.. It was the router... The router didn't know the MAC address of the device.

 

So I dug a bit deeper looking for the ARP settings in my router... And then realised that it was on the same page was the MAC/IP Bindings that I had setup before... And then I noticed it.. A toggle switch..

 

So whilst i had created a MAC/IP binding in the router (Which utimately created a permenant ARP entry) I hadn't switched the feature on..

 

I flicked the switch.. And its been fine since.. PC wakes every time.

 

So if by chance you discover this, look at the ARP table in the router.. And see if an entry for your IP/MAC is there.. But then after a period of time disappears.. if it does.. This is the reason you can't wake so you need to find a setting in the router to make a permenant entry.

 

I hope this helps someone in the future.

 

Jon

Highlighted
Level 10
1,998 1,953 179 567
Message 3 of 4
Flag Post
HP Recommended

Jon,

 

Thanks for that.  Makes sense..... WOL has been quite the hassle for years now, and now I need to go become an ARP expert too.

0 Kudos
Highlighted
Author
Level 2
21 17 2 1
Message 4 of 4
Flag Post
HP Recommended

To be honest, i didn't think it would be that reliable.. But its been faultless in every test I have done over the past few days.

 

You don't really need to know much about ARP to fix this.. My mistake was that I was looking at the ARP tables in Windows.. I couldnt' for the life of me understand how that had anything to do with it, after all the PC was asleep so how could it be anything on the PC.


So I assumed that the PC was simply entering another layer of sleep and switching off power to the NIC.. So I spent all my time trying to toggle power related settings in the OS and BIOS.

 

But it turned out that the Router was "forgetting" the MAC address of the PC (Which is needed for WOL as the Magic Packets are set to the MAC rather than IP address) so all you have to do is put a static ARP entry (TPLink call this this a MAC/IP Binding) into the router..

 

Now this is done its working perfectly.. And now my Z400 goes to sleep after 15 mins, but I can wake it using TeamViewer should I want to connect remotely.

 

I hope this helps someone.. Cheers all.

 

Jon

 

0 Kudos
Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation