cancel
Showing results for 
Search instead for 
Did you mean: 
Get help with Large Format Printers, with direct access to all Latex Knowledge Center · Ask anything · Find anything · Share anything at HP LKC
Fossy_01
New member
2 1 0 0
Message 1 of 3
518
Flag Post

DesignJet T610 - Printhead problem (with headache)

HP Recommended
HP DesignJet T610
Microsoft Windows 10 (64-bit)

Hello friends:

 

I'm dealing with a problem of months ago. My T610 one day show the MK/Y Printhead faulty and asked me to replace it..., Ok, in that moment I had 3 new printheads and I replaced it, but the error persisted, it was a loop with "faulty MK/Y, please replaced it". Ok..., I was think that new printhead could be too defective and I bought a new one, but the same error persisted!!!.

 

I'm not going to write all the tests I did, but in summary, I have doing the following:

- Reseat printhead(s) hundred of times.

- Replaced complete carriage by new one (with PCB included).

- Replaced Trailing cable.

- Replaced carriage belt.

- Reinsert the firmware (last version).

- Replaced ink catridges by new ones (all are 100%).

- Power on the Plotter without ink catridges and printheads, and insert it when Plotter ask for it...

........

........

 

None work!!, I get same error when power on... "Installation of printheads not finished, please push OK to finalice it". When I push OK, 4 or 5 minuts later Plotter says "Please, replace faulty printhead" (and forever points to MK/Y). Is an LOOP!!

 

I have entered to Service Menu, and all tests is OK!!, carriage, ink system, power supply..., all tests is OK, I don't know why I have this problem. I've spent a lot of money trying to repair Plotter, I have read all forums and possible solutions and nothing works.

 

I called to an HP partner and they have said that I have made to Plotter all everything an HP technician would do, and they can not help me. They said me that I need to call to HP..., well..., I have called to HP and they said that I need to contact with HP partner..., they drive me crazy!.

 

I do not know what to do anymore, and also surfing the Internet I have seen many people with this same problem that have not been solved either. Please, I need help!!, I need the Plotter this week :'-(

 

Thanks for all!!.

Jose.

 

 

2 REPLIES 2
Valsimot
Level 12
Level 12
6,354 6,337 756 1,063
Message 2 of 3
Flag Post
HP Recommended

You have done all you could, only one part has left that hasn't been replaced and that is the main board.




My profile on LinkedIn

Was this reply helpful? Yes No
Fossy_01
Author
New member
2 1 0 0
Message 3 of 3
Flag Post
HP Recommended

Thanks for your reply!.

 

You think it could be the motherboard?. In that case, why all tests in service mode are ok?.

 

Exists any other thing that I can test?.

 

Thanks!!

Was this reply helpful? Yes No
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation