cancel
Showing results for 
Search instead for 
Did you mean: 
  • ×
    Information
    Need Windows 11 help?
    Check documents and videos on compatibility, FAQs, upgrade information and available fixes.Windows 11 Support Center.
  • post a message
  • ×
    Information
    Need Windows 11 help?
    Check documents and videos on compatibility, FAQs, upgrade information and available fixes.Windows 11 Support Center.
  • post a message
The HP Calculator Community Message Board is moving. While we prepare for the move, we are unable to accept new postings. During the move, you can look for help from other users by visiting https://www.hpmuseum.org/ . Or if you need technical support for your calculator visit: HP Calculators. .
cdt2013m
New member
6 3 0 0
Message 1 of 4
311
Flag Post

Solved!

Gigabyte Nvidia GTX 1060 WF2 - Not installing on HP-599UK (Mobo Pegatron 2AB6 version1.04) Bios 7.15

HP Recommended
HP-599UK (XS624EA#ABU)
Microsoft Windows 10 (64-bit)

Hi guys,
I've just purchased a new graphics card for my HP Pavillion Elite (HPE-599UK) and it freezes at the HP splash screen.

I am unable to get past this and have had to revert back to the onboard graphics which loads fine.

 

I have had a little google and it seems their is an issue with the Bios Version (7.15) which seems could be solved with the option to to disable secure boot and enable legacy boot which Bios 7.15 doesn't offer!!

It seems i have no other option than to return the Graphics card to Amazon unless some wizz out there knows of a solution?

I use the PC for Flight Simulator and read that this was a good graphics card without breaking the bank so went ahead and purchased it.
If there is no solution for this then please can anyone advise of a good compatible graphics card that would do the job and work with my currrent Motherboard / Bios Version?  

These are my specs:

Graphics Card (New): Gigabyte Nvidia GTX 1060 WF2 6GB GDDR5 PCI-E

PC : HP Pavillion Elite (HPE-599UK)
Motherboard: Pegatron 2AB6 Version 1.04
Bios: AMI7.15
OS: Windows 10 64bit

Thanks for your help and time.

1 ACCEPTED SOLUTION

Accepted Solutions
banhien
Level 19
Level 19
96,807 65,520 12,543 21,621
Message 2 of 4
Flag Post
HP Recommended

@cdt2013m wrote:

... I have had a little google and it seems their is an issue with the Bios Version (7.15) which seems could be solved with the option to to disable secure boot and enable legacy boot which Bios 7.15 doesn't offer!!


@cdt2013m

 

That is true, you need at least BIOS 8.x and above to be able to use Nividia GTX 10xx and your machine was built before 2012 therefore the best you can do is to use GTX 6xx/7xx cards.

 

Regards.

BH
***
**Click the KUDOS thumb up on the left to say 'Thanks'**
Make it easier for other people to find solutions by marking a Reply 'Accept as Solution' if it solves your problem.




>

View solution in original post

Was this reply helpful? Yes No
3 REPLIES 3
banhien
Level 19
Level 19
96,807 65,520 12,543 21,621
Message 2 of 4
Flag Post
HP Recommended

@cdt2013m wrote:

... I have had a little google and it seems their is an issue with the Bios Version (7.15) which seems could be solved with the option to to disable secure boot and enable legacy boot which Bios 7.15 doesn't offer!!


@cdt2013m

 

That is true, you need at least BIOS 8.x and above to be able to use Nividia GTX 10xx and your machine was built before 2012 therefore the best you can do is to use GTX 6xx/7xx cards.

 

Regards.

BH
***
**Click the KUDOS thumb up on the left to say 'Thanks'**
Make it easier for other people to find solutions by marking a Reply 'Accept as Solution' if it solves your problem.




>

View solution in original post

Was this reply helpful? Yes No
cdt2013m
Author
New member
6 3 0 0
Message 3 of 4
Flag Post
HP Recommended

Thank you Banhein for your reply and advice.

Is there a graphics card that you could recommend (doesn't have to be a GTX) that would work?
I've looked on Amazon as i then have the fall back to return for free (just in case) but am unable to find any GTX 6xx/7xx cards on there as they are probably mostly obsolete now?
Orginally i had a  HP GeForce Gtx460 FH PCIe 16x 1g Video Card installed but it recently died !!

Many Thanks
Mike

Was this reply helpful? Yes No
cdt2013m
Author
New member
6 3 0 0
Message 4 of 4
Flag Post
HP Recommended

I have just purchased a new Radeon RX580 Nitro + for my HP Pavillion Elite (HPE-599UK) and now i just get a blank screen at start up? The Graphics Card led and fans are on however nothing displays not even the Bios. I have tried the Bios switch but still nothing? Please Help? I'm using a new EVGA 500 PSU.

Was this reply helpful? Yes No
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation