• ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • post a message
  • ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • post a message
Guidelines
The HP Community is where owners of HP products, like you, volunteer to help each other find solutions.
HP Recommended
OMEN 16.1 inch Gaming Laptop PC 16-c0000 (343L4AV)
Microsoft Windows 11

I have a problem with my new laptop Omen 16. When working in Blender the system freezes after some minutes and artefacts (small squares) show up on the screen and program not respond.

My first thought was that it's Blender's fault. But the same thing start happens when I play games.

It's not the case of system overload or overheating either because the problem occurs even when I do the simplest things in Blender, and temperature is normal .

At some point when I play, the game or blender freezes and artefacts show up on the screen - and the program doesn't respond and I have to swith it off via Task Manager. And waiting for it to respond doesn't do any good. At the same time the rest of programes and apps open in the background work perfectly fine.

My laptop is Omen 16 c0322nw
ryzen 7 5800H
AMD Radeon RX 6600m
16 Gb ram
Win 11 

I have the most up-to-date dreivers amd gpu (22.2.3) and I've already tried the old drivers - no changes, I install all drivers for omen 16 from HP site too. Windows System has all the updates. The problem doesn't depend on whether the laptop is plugged or not.

I've updated the Bios' drivers and tried to run the programes in backwards compatibility mode and as Administrator. Then I've reset the entire system back to the factory settings - nothing's changed. The problem still occurs.

I've played Hearts of Iron 4, Batlle Brothers and Kingdom Come Deliverance and the problem's occured only with Hearts of Iron 4 and Batlle Brothers (which have less requirements in theory). Kingdom Come's worked perfectly fine.

Do you guys have any ideas what could be the nature of problem? Bez tytułu.jpg

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the <a href="https://www8.hp.com/us/en/terms-of-use.html" class="udrlinesmall">Terms of Use</a> and <a href="/t5/custom/page/page-id/hp.rulespage" class="udrlinesmall"> Rules of Participation</a>.